Video Screencast Help

BE2010/Exchange 2010 can't connect to mailstores

Created: 14 May 2010 • Updated: 18 Jun 2010 | 3 comments
This issue has been solved. See solution.

Hi all,

I have a BE2010 server (stand-alone) running on 2008R2.  I also have an Exchange 2010/2008R2 server.  The mail backup was running fine until I installed hotfix 348284 to fix the restore issues...

The final error in the Job log is as follows:

Error category    : Resource ErrorsError             : e0000f04 - The media server could not connect to the remote computer. The remote computer may not be running the Backup Exec
Remote Agent for Windows/Linux. Make sure that the correct version of the Remote Agent is installed and running on the target computer.
For additional information regarding this error refer to link V-79-57344-3844

But that's a lie, because beremote is indeed running on the Exchange box.  I can see from the not-very-human-readable beremote log that it found all of our mailstores, and doesn't seem to suggest any specific failures on the remote agent side, but I can attach this log if anyone wants to see it.

From the selection list, I can connect to everything else on the mail server except the mailstores.  In the existing job, if I run a credentials check, it successfully connects to the server but fails with "resource not found" on the mailstores.

I've tried deleting and recreating the logon account in BE, created a new job/selection list, checked all the permissions, restarted services, and rebooted both servers (can't reboot Exchange again any time soon, but BE can be rebooted any time as it's a stand-alone box).

Here's where it gets weird:  If I do a test run, it completes successfully, and it passes the credentials check on the three mailstores I'm trying to backup.  

Help, please! :)

Comments 3 CommentsJump to latest comment

Dev T's picture

Hello,

Have you pushed the remote agent again on the Ex2010 after installing the hotfix?

Its a best practice to have a "Support Contract" with Symantec...
 

sazz.'s picture

If you think it is caused by the HF then please uninstall the HF from the addremove programs and reboot the BE server and try to connec to exchange again.
Also can you please check that you have a valid license for exchange from tool- install options and license key. I mean you are not using the evaluation for exchange and that might be expired

SOLUTION
voltage's picture

HOLY CRAP!  They key was there under Tools>Install Options and License keys, but when I looked under Help>About>Licensing Information, Agent for Microsoft Exchange wasn't even listed!  I removed the Exchange key, restarted services, readded it, and restarted the services again - then it worked!

The credentials check in job setup completes successfully and I can see the mailstores in the selection list again.  I haven't run the backup job yet but I'll get a chance to run it tonight...I assume it'll be just fine.

I don't understand why if it was a licensing issue, why didn't it just say that!?!  When we were actually using the trial of the Windows Agent (and let it expire because we forgot to enter our official keys), it told us that the job failed because the agent was unlicensed.

Thanks a lot, though!  Sometimes it just takes another set of eyes to double check everything you thought you already checked :)