Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

BE2010R3 - AOFO: Initialization failure using VSS - VSS Snapshot Failed

Created: 19 Oct 2012 • Updated: 01 Nov 2012 | 4 comments
This issue has been solved. See solution.

Backup was working fine for a few months and then all of a sudden I started getting this error.  Weird thing is that I didn't tell it to use AOFO option when backing up...so not sure why I'm getting an AOFO error. I've already tried restarting the server.  Any ideas?

Full error message below:

Backup - AOFO: Initialization failure on: "\\Server\System?State". Advanced Open File Option used: Microsoft Volume Shadow Copy Service (VSS). V-79-10000-112177 - VSS Snapshot error. The Microsoft Volume Shadow Copy Service (VSS) snapshot failed. Make sure that all provider services and tasks are running. Check the Windows Event Viewer for details.

Windows Event Viewer Reports:

Source: VSS
Event ID: 12289
Description: Volume Shadow Copy Service error: Unexpected error DeviceIoControl (\\?\Volume{21089296-a5ff-11d9-b1de-806e6f6e6963} - 00000178,0x0053c020,0003A690,0,00039688,4096,[0]).  hr = 0x80070017.

 
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Comments 4 CommentsJump to latest comment

VJware's picture

check the status of the vss writers... you might need to re-register the VSS .dll's or reboot the machine (depending upon the OS)

any specific reason for not explicitly enabling aofo ?

Nuri Inuki's picture

Last admin who built the job did not have it enabled.  When I rebuilt the job, I thought we had to pay for that option, so I didn't enable it either.

Will enabling AOFO address this issue?  How do you re-register the VSS dlls?  I've already tried rebooting the machine and that didn't fix the issue (Windows Server 2003 SP2).

VJware's picture

Check if this patch is installed or not - http://support.microsoft.com/kb/940349 & http://support.microsoft.com/kb/887827

And as you are using BE 2010, AOFO is not a paid option...enable the option...choose the system microsoft vss provider...

Nuri Inuki's picture

Okay, I finally figured out the issue.  First, enabling AOFO did not address the issue.

I ended up going onto the server that was throwing the errors and ran a "vssadmin list writers."  I saw a bunch of writers listed of which two of them had "State: Failed" and "Last Error: No Error."  Further research suggested that the associated services needed to be restarted to address these kinds of failure.  For me, the services were Cryptographic Services and IIS Admin Services.  Once I did that, all the writers was in a stable state and my backups no longer failed.

For a list of services associated with the writers:

http://activelydirect.blogspot.com/2011/01/resolving-system-state-backup-failures.html

SOLUTION