Video Screencast Help

BE2010R3 LiveUpdate SP3 error 1603 (sp3 already installed)

Created: 19 Aug 2013 • Updated: 06 Sep 2013 | 13 comments

I have already updated my backup exec 2010 R3 installation to SP3 early non-liveupdate due to requirements that I do so, and Liveupdate not showing SP3 as downloadable at the time.

I found the article on liveupdate seeing Backup Exec 2010 R3 SP3 (Hotfix 203157)

http://www.symantec.com/business/support/index?pag...

But when I run Liveupdate, it errors out

Installing Symantec Backup Exec (TM) 2010 R3 (1 of 1), failed.
LU1812: A program that was part of this update failed when it ran.  This update was not applied.

Installation failed, error summary...
LU1806: LiveUpdate downloaded all of the updates you requested, but all of them failed to install.  Please try to get the updates at a later time.
 

The Event logs say that the file (service pack 3) is trying to update something already updated.

 

It isn't resetting Liveupdate to not see sp3 as needed.

I Realize this may be too soon to be expecting this to be resolved or it may be being worked on, but thought I would put it up and see if any answers.

 

Operating Systems:

Comments 13 CommentsJump to latest comment

Donald Eady's picture

I would suggest logging a support case so that logs can be collected and escelated if neccessary 

I hope this posting was helpful

  

Judh's picture

Marking as Solution due to the end result of logging a case with support resolved the issue.

Final Solution: beupdateops.exe -addbe -optin

 

lmosla's picture

I agree with Donald, but first you might want to try uninstalling and reinstalling Live update through Add and Remove programs. Live update can be installed from here  ftp://ftp.symantec.com/public/english_us_canada/liveupdate/3.4/,  

Donald Eady's picture

Hey Judh

 

Out of curiosity would you please verify that SP3 shows present under installed updates. Additionally that it shows up in add/remove programs as well if so i would suggest that you go ahead and log a formal support case. 

I hope this posting was helpful

  

Judh's picture

I can't do any operations to the server at this time, I may get some time tommorow.

But, Installed Updates confirmed that SP3 was installed after I had installed it manually, and rechecking, confirms it still says service pack 3 is installed.

 

I will see about Live update reinstallation tommorow and let you know.

Donald Eady's picture

Ok... You may want to try launching Backup exec as Administrator and then running live update as such 

 

Edit.. 

Here are a few docs for you to look over 

http://www.symantec.com/docs/TECH67023

 

I hope this posting was helpful

  

Judh's picture

just got off the phone with tech support rep.

Doing a command prompt with the command beupdateops.exe -addbe -optin

appears to have resolved the issue of liveupdate not detecting service pack 3 being installed.

 

 

Colin Weaver's picture

Hmm slightly concerned because: 

a) This will mean BE will try and patch whenever any other Symantec software on the same system tries to apply patches - which could result in services being stoopped in the middle of a backup. This may of course not be a problem if BE is teh only Symantec product on the system.

b) That the 1603 error might re-appear  if/when we release a future hotfix or Service pack, I guess if it does you should log a support case at theat time as we will nto knwo until we release another update.

 

A thought though, did they get you to run this command because you re-installed LiveUpdate - if they did then the correct command should have been

beupdateops.exe -addbe -optout

 

Judh's picture

I had not re-installed Liveupdate.

we do run SEP which is updated via a different server and not liveupdate, but other than that, this server only has BE 2010 on it as its Liveupdate target.

All other hotfixes that this servers Liveupdate ever ran always updated and didn't re-occur until service pack 3 manual install.

 

 

 

Colin Weaver's picture

I checked with the engineers that worked your support case and apparently as well as running the beupdateops command they also repeated the SP3 install from within LiveUpdfate to clear the list (the 1603 error was no longer seen) - and at the end also ran the optout command to see the regsistration to default behaviour. As such my previous comments/warninsg had apparently already been handled.

Judh's picture

The information you recieved from the engineer is partially incorrect.

I did not allow him remote access to my server, I did these things myself as he instructed me to do

The 1603 error was always in the Event Logs only. I relayed this to him.  How much he understood of what I was telling him I do not know, he had a thick accent, and I had to have him repeat some of what he was telling/asking me.

I confirmed to him that I had SP3 installed, I had checked Installed updates from help->about.  He had me go back there to re-confirm that this was the case, I relayed to him that this was.

I ran the Liveupdate program which had the errors LU1812 and LU1806, which did not change until the Optin command was run.  NO optout command was run or asked to be run.  I only ran LU after the Optin command as instructed which confirmed that it was no longer updating SP3. At that point, he transferred me to his supervisor to make sure everything was done, but no new instructions were relayed.

 

 

monty1981's picture

Is there a final solution?

I have the same problem! SP3 is installed and Liveupdate trys to install once more.

Judh's picture

The Final Solution ended up being a workaround.

The beupdateops.exe -addbe -Optin command did indeed make liveupdate not detect the patch.

I ran the beupdateops.exe -addbe -Optout command, and Liveupdate goes back to trying to download service pack 3.