Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

BE2012 7 Robotic tape library - suddenly using a lot more tapes

Created: 21 Mar 2013 | 18 comments

Hi all,

I have Backup Exec 2012 with and IBM robotic tape library (with 2 x drives)

There are a series of jobs that run overnight backing up various things.

I have had my backup routine reasonably settled for a couple of months now and each night normally 2 tapes have been used, sometimes 3.

Over the last few days this has suddenly changed to 5, 6 even 7 tapes (the amount of data being backed up has not changed dramatically).  This is going to start causing me a problem because I have around 50 tapes in total on a 2 week cycle and I am going to run out of tapes.

I have around 8 seperate overnight jobs.  It used to be that when one job finished and the next one started, it would use the same tape.  Now it seems to use a different tape pretty much with every job.

I did have my jobs set to 'append to media, overwrite if no appendable media is available' so i tried changing this to 'Overwrite media' last night, but this did not seem to make any difference.

How can I reduce down the number of tapes being used to how it was previously?

Operating Systems:

Comments 18 CommentsJump to latest comment

VBU's picture

Hi twshelpdesk,

Please check the compression settings with your tape device and the backup jobs. Please let me know the capacity of the tapes being used by you and the amount of data you are backing up on daily basis. The number of tapes taken for backups normally depends on the amount of data you are backing up or the amount of compression you are getting and has not much to do with the backup application.

twshelpdesk's picture

I am backing up around 700GB.  

Most of my tapes are LTO4 (800GB) although I have a couple of LTO3 tapes as well.

Compression type on the jobs is 'Hardware'  and is set to 1.0:1 on all the tapes

VBU's picture

Ideally it should take 1 tape for the backup as per the details you gave above. Please can you check the console for your library if compression is not disabled at the hardware level. Also if it is saying 1.0:1 that means you are not getting any compression. Just make sure the tapes you are using are fully compatible and as per the standards with the Library and drives.

twshelpdesk's picture

Its not going to be possible to use 1 tape as the tape library has 2 drives and I have jobs set to run at tthe same time and take advantage of the 2x drives, hence why my overnight backups normally used only 2 tapes.

The tapes are fully compatible and have been working fine for months.

twshelpdesk's picture

How should the overwite and append settings be configured for the media set to achieve what I want to achieve?

VBU's picture

Please click on tools>>Options>>Media Management, Check the option for "Partial - protect only allocated media" Uncheck the box just below that "Prompt before overwriting imported media". Also please check the option Overwrite recyclable media contained in the targeted media set before overwriting scratch media" click ok.

Please go to the "Media" tab and right click on the media set you are using for your jobs and go to properties. In the general tab set the overwrite protection period to 2 weeks and Append period to Infinite and then click ok.(You may also give it some fancy name as well).

twshelpdesk's picture

VBU - I am using BE 2012 and dont see tools >> options >> media management.  Are you refering to a different version?

Larry Fine's picture

re: I have around 8 seperate overnight jobs.  It used to be that when one job finished and the next one started, it would use the same tape.  Now it seems to use a different tape pretty much with every job.

Are all 8 jobs starting/launching at the same time?  I know that only two will run immediately due to having two drives.  But do all 8 jobs have the same window?

I assume that all 8 jobs are using the same media set.  I am also assuming that none of your tapes used in one night are full?  If tapes are full (according to the BE GUI), then a different course of troubleshooting would be suggested.

I would suggest an experiment of starting 2 jobs, wait 5 minutes, start 2 jobs, wait 5 minutes, start 2 jobs...

I suspect that the first 2 jobs run as overwrite jobs, as they should.  The other 6 jobs "should" be append jobs, but because they start at exactly the same time, there are no appendable media available at that instant, so they switch to looking for overwrite media.  Generally, once a job starts looking for overwrite media, it will never go back and check if appendable media is available once a drive becomes available.

If you find this is a solution for the thread, please mark it as such.

twshelpdesk's picture

Hi Larry, thanks for getting back to me.

All 8 jobs are not starting at the same time.  They are set to start (roughly) a short time after the last job is expected to finish.  

E.g. First job starts at 22:00 and runs for 2 hours, next job starts at 00:30

All 8 jobs are using the same media set, yes they are not full but I have just noticed that all say 'not appendable'.

Is this the problem?

Larry Fine's picture

re: All 8 jobs are using the same media set, yes they are not full but I have just noticed that all say 'not appendable'.

The "not appendable" is a major clue.  Why are they not appendable?

Top 3 reasons for not appendable are:

1) due to the append period being past

2) due to the media being full - which shows as "Not appendable (Media full)"

3) due to a failure during write - which shows as "Not appendable (end marker unreadable)"

What is the "append period" of the media set you are using?  I am assuming you need to set it longer.

If you find this is a solution for the thread, please mark it as such.

pkh's picture

In order to maximise the space usage on your tape, your first job should specify overwrite.  If you specify append for your first job, it will append to the tape and not use the portion of the tape which was used previously.

As previously advised, you got to set your AP long enough for your jobs to append to the tapes.  The AP is calculated from the time the tape is first overwritten.

twshelpdesk's picture

Ok, I think I need some serious help to get this in order!  I think I have misunderstood append period and overwrite protection period.

Looking at my tapes, they are mostly "not appendable (end marker unreadable)".  I have had a lot of failed jobs recently which I understand is why this happens.  I also have some which just say "not appendable".

I have made some adjustments since I last posted but believe my append period was set to 6 days (with an overwrite protection period of 2 Weeks).

The tapes should be removed from the library each morning to get them in the safe, so I think the longest I need to protect them for is 5 days (just in case of a long weekend/Christmas break etc).

How should the overwirtie protection & append period be setup with this information in mind?

Also, pkh can I just clarify your last point.  Should my jobs be setup as below.....

21:00 - job1 - set as "when job begins overwrite media"

23:00 - job2  - set as "append to media, overwrite if no appendable media is available"

00:00 - job3  - set as "append to media, overwrite if no appendable media is available"

00:15 - job4  - set as "append to media, overwrite if no appendable media is available"

02:00 - job5  - set as "append to media, overwrite if no appendable media is available"

02:30 - job6  - set as "append to media, overwrite if no appendable media is available"

etc etc

pkh's picture

Your job setting is correct.

The end marker unreadable will go away when you next overwrite tape.

The OPP is calculated from the END of the job that last write to the tape, so you have to factor this into your OPP setting.

For a better understanding of OPP and AP, read this document

OPP and AP explanation

twshelpdesk's picture

Just been reading up, but due to the complications of having a tape library with two drives, I am really struggling to understand how I should set things up.

I want to ensure that overnight when a series of jobs run, they append to the same tape to minimise the amount of tapes that are used.  I then want to ensure that if those tapes are left in the library for 5 days, the system will not overwrite any jobs on those tapes.

With this in mind I am thinking that the append period should be set as infinite (to allow to constantly append until it is full) and then have an OPP of 5 days, to ensure that no jobs on that tape will be overwritten 5 days AFTER the last job to append that tape has completed.

Is that correct?  Would that suit my situation?

pkh's picture

You can do this, but you are going to have a problem with your tapes.  You don't know when the tape is going to be full and thus you don't know when the tape is going to be reused.  Suppose your tape only filled up after 5 days which means that you can only reuse the tape 10 days after it was first overwritten.  It would be better to be more predictable, like setting your AP to 3 days, then you would know that when a tape is overwritten, at most 8 days would lapse before you can re-use it.

Because you have 2 tape drives, you must ensure that the first jobs that use the tape drives overwrite the tape.

twshelpdesk's picture

Ok, so 5 days OPP and 3 days AP sounds good.

That will allow my tapes to append for 3 days (from the original overwrite job) and protect them for 5 days after the last append job.

My first job of the night however must be set to overwrite.

Is that correct?

pkh's picture

Because you have two tape drive, the first jobs which write to each tape in the tape drive needs to overwrite.

twshelpdesk's picture

Ah yes good point.  I have adjusted my jobs so that the first one runs at 21:00 and the second one runs at 21:10 and set both this jobs to 'overwrite'.  

This should ensure that each job uses a different tape and a different drive and hopefully overwrites.