Video Screencast Help

BE2012 beremote.exe crashes on VMWare backups

Created: 27 Nov 2012 • Updated: 27 Nov 2012 | 19 comments


We are running BE2012 Sp1 with hotfixes 189571, 180964 and 194470.

When trying to make a backup of our VM's through the VMWare option, beremote.exe crashes (most of the time).

The following error is in the eventlog:

Faulting application name: beremote.exe, version: 14.0.1798.0, time stamp: Faulting module name: ntdll.dll, version: 6.1.7601.17725

The job log shows:

Job ended: Tuesday, November 27, 2012 at 3:41:21 PM Completed status: Failed Final error: 0xe0009b61 - Backup Exec could not log on to the server with the logon account specified for it. The logon account does not have valid credentials. Ensure that the user name and password are correct in the logon account. Final error category: Security Errors For additional information regarding this error refer to link V-79-57344-39777

I'm sure the logon account is correct. Backup Exec Remote Agent runs on the media server using the local system account, vCentre is installed on the same server.

Please help me out!!



Comments 19 CommentsJump to latest comment

jzondervan's picture

Also, sometimes I get this error, not the credentials problem:

V-79-57344-65072 - An error occurred while connecting to the Backup Exec Remote Agent on the Backup Exec server. Ensure that the job options are correct, and then submit the job again. The backup set was not created.

V-79-57344-65304 - The Virtual Machine resource is not responding. Backup set canceled.

VJware's picture

Jasper, I have PMed you an action to take..Do let me know if it works.

CraigV's picture


Please share with the forum, and not via PM. This is a community forum so anything that might have helped the OP could possibly help someone else. Unfortunately there is no way to know now!

Alternative ways to access Backup Exec Technical Support:

Paul VanDyke's picture

Your not alone... I get that error too from time to time...  It's a pain in the butt, because none of my other backups will run because the remote agent on the media server has stopped.

jzondervan's picture


Here is the crashdump you asked for in PM.


AttachmentSize 967.01 KB
Nabil polska's picture

A hotfix is now available for this issue in the current version(s) of the product(s) mentioned in this article. Refer to the Hotfix link under Related Documents at the end of this article to obtain the hotfix needed to resolve the issue.

Backup Exec 2012 Revision 1798 Hotfix 180964

awisch's picture

Thats funny I have the same problem. Nabil if you'll note the originally poster states he already has that hotfix installed as do I.

Colin Weaver's picture

There is at least one VMware backup beremote crash condition still active after either the latest 2010 R3 or 2012 Hotfixes. Symantec are investigating this, however you will need to log a formal support case for us to check your crash dump to confirm you have the same condition (or to give us a new one to research) If you have the condition that we are already aware of then I think (not in office to check) that we have a private orphan (similar to a beta) update that should help - again you need the formal support case to get this as well.

jzondervan's picture

Hi there,

The problem seems to be solved after changing a few registry settings:

HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Backup Exec For Windows\Backup
Exec\Engine\VMware Agent
Enable Buffered Reads set to 0
Enable Buffered Writes set to 0

Recycled the BE services.

However, the backup now takes 4-5 hours LONGER to complete, forcing us out of the backup window, so this might be a temporary workaround but not a solution.

@Colin Weaver: Would the suggested hotfix help with this issue? I'm not a real fan of using beta hotfixes in a production environment...

Colin Weaver's picture

The orphan update was released to support in response to an open support case when the latest hotfix did not solve all the crashes and that registry key changes had solved them but had affected performance. As such I believe the latest orphan update should allow you to undo the registry chanegs and get back the expected performance.

However I have personally have not yet used either the 2010 R3 or 2012 versions of this new orphan with a customer yet, so on a personal experience level cannot confirm the effect on performance.

jzondervan's picture

In addition to my last comment: I also had to disable the GRT options for this to work.

Colin Weaver's picture

if you had to disable GRT as well then you probably needed to disable NTFS Used Sector tracking (possibly with the buffers disabled) instead of disabling GRT. This is another registry sequence.

jzondervan's picture

Ok, I'll try setting "Disable NTFS Used Sector Tracking" to 1. Thanks for your reply.

I'll also try logging a formal support case to get the hotfix you mention.

BStefan's picture
I have the exact same problem, did you get any solution.
thank you
zadood's picture
Sorry to post in an old thread but I'm having the same set of issues you all are having
Backup Exec 2012 with all patches upto date and using a DELL DR4000 as destination. Backing up a VM with GRT enabled. At somepoint after most of the data has been backed up I get the error that the job failed and agent crashes on the media server. I have to close backup exec and restart the agent service and then view the job log with the error related to this:
Backup of a virtual machine using the Backup Exec Agent for VMware Virtual Infrastructure (AVVI) fails with the error "V-79-57344-38264 - Unable to copy the virtual machine disk using the VMware VixDiskLib.
According to this thread I did the following:
"netsh int tcp set global netdma=disable"
Now I ran into this error:
Final error: 0xe000ff18 - A communications failure has occurred with a Virtual Machine resource.
To solve it I followed the following thread and did this:
HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Backup Exec For Windows\Backup Exec\Engine\VMware Agent
Set the below to 1
Disable NTFS Used Sector Tracking
Disable NTFS Used Sector Tracking Dynamic Disk Support
Disable NTFS Used Sector Tracking GPT Disk Support
My question now is that I noticed that the job now backed up the whole vmdk without any consideration if it is free space or not. I am guessing this basically disables CBT but the backup did work.
What is going on? Why is this happening on some VMs and others now. Is this my only choice to backup VMs with GRT?
Please help!
Colin Weaver's picture

The 2012 SP2 release (beta currently but going public soon) does contain a fix for most, if not all, of the beremote crash conditions linked to VMware backups and should allow the buffers to be re-enabled and so increase the performance

mscaraglino's picture

I have the same problem with a Sharepoint Backup.

I have installed the sp2 on media server and i have updated all agents on servers farm, but beremote.exe crash and backup jobs fails.


Colin Weaver's picture

If it is NOT a VMWare issue it is a different problem and not related to the content of this thread. As it may also not be a known issue you should probably log a formal support case.