Video Screencast Help

BE2012 Can't add Robotic Library Support option

Created: 02 Apr 2014 • Updated: 04 Apr 2014 | 9 comments
This issue has been solved. See solution.

So I've been having trouble with my tape library (I only have one). A faulty tape kept getting stuck in the drive, rendering the library inoperable from BE. I finally shutdown the BE server and the tape library and then re-started both. Unfortunately the library was then offline.

I found article TECH138338

I was able to do part one - uninstall the Virtual Tape Library Support and Robotic Library Support options. Rebooted the server on completion.

Now I can't enable Robotic Library Support. I follow the procedure, it looks like the install is going to work and then at the point where the progress bar says 'Copying New files' a prompt comes up saying "Install Disk:" (it doesn't say which disk, but I assume it means the BE2012 install DVD). The install disk is in the server optical drive and in explorer I can browse it fine and even run browser.exe, but I cannot get the Licence reinstall procedure to recognise it.

I'm stuck without a usable tape library.

Any advice would be greatly appreciated. Thanks

Operating Systems:

Comments 9 CommentsJump to latest comment

lmosla's picture

What version of tape drive is this?  Make sure it is in the Backup Exec HCL

Larry Fine's picture

Is it possible that your optical drive changed drive letters between the original product install and the repair you are attemping now?

A workaround may be to run the installer from the optical drive.

If you find this is a solution for the thread, please mark it as such.

jon_manager's picture

Thanks Imsola. No it's not on the compatibility list, BUT it has been working fine with this version of BE for 18 months, so I'm not giving up yet on having it working again. In any case, the real issue is the running of the install routine and gettting the Robotic Library Support option active again. Perhaps I've mis-titled this question.

Larry - I did look at running the installer from the DVD, but it appears to want to do a full install ('over the top'?) which I want to avoid. Can you guide me in how to run the License Installer from the DVD? Are there command line switches?

Larry Fine's picture

I think that if you just go through the process and select the "additional options" radio button, it should do what you want.  But I don't claim to be an expert, so YMMV.

What tape library do you have that isn't on the HCL?  I was under the impression that virtually every tape product was supported.

If you find this is a solution for the thread, please mark it as such.

jon_manager's picture

90px_2014-04-03 15-44-55_Clipboard.png 

So I ran setup.exe from the DVD and it allowed me to just select additional options. Nevertheless, the 'Insert Disk:" message still comes up (see screenshot) so I'm still stuck.

The Tape Library is a SONY LIB-81 (AIT4)

Larry Fine's picture

Sorry, I don't know why the installer is asking for a disk.  You may need to open a tech support case.  Or do an uninstall & re-install?

It appears the the LIB-81 with AIT4 is on the BE 2012 HCL, page 118.  But it looks like it won't be supported in the next version of BE.

LIB-81 [1] SCSI Sony SDX-900V AITi520/S (AIT-4) SCSI SONY^^^^LIB-81 SONY^^^^SDX-900V

If you find this is a solution for the thread, please mark it as such.

jon_manager's picture

thanks for help. Not a solution exactly, but helped clarify that I wasn't being stupid!