Video Screencast Help

BE2012 latest patch lvl - after successfully backup direct on loader tape, tape not moved back

Created: 11 Sep 2013 | 4 comments

hi

we got a hp msl2024 lto 5 loader in the past (2months ago) all works fine we backup our ndmp netapp filer direct to tape and got a bunch of other jobs that backups at evening and duplicates data next day in the morning, this works fine for around 6 months since we got the new loader, in the last time we have following problem:

backup direct to tape job starts for at midnight...the backup job completes successfully in the backup log i can see that it takes slot 7 and do the backup

after the backup the tape is not moved back to the loader slot and is still in the drive, if i view the slots in backup exec it is moved back drive looks empty, on the loader webinterface i see that slot 7 is still in the drive, now when the next job is started to duplicate data be2012 takes the loader offline..

in adam.log following appears ->

[5156] 09/11/13 08:00:35.864 DeviceIo: 02:07:00:01 - Device error 1117 on "\\.\MediumChanger2", SCSI cmd a5, 1 total errors
[5156] 09/11/13 08:00:46.017 PvlChanger::MapErrorCode() - offline device
       Job = {4AC6EDCB-B123-4086-8BF0-23CAAB61BE82} "JobName"
       Changer = 1024 "Details - HP MSL2024 LTO5"
       ERROR = 0xE000820A (E_CHG_HARDWARE)

[5156] 09/11/13 08:00:46.042 PvlChanger::UpdateOnlineState()
       Changer = 1024 "Details - HP MSL2024 LTO5"
       ERROR = The device is offline!

Now all jobs fails because BE2012 thinks the Drive is empty, i need to manually move now the tape backup to its slot via webinterface, and reboot the backup server, set all jobs to pause mode, and after reboot do a inventory in be2012 on the loader, if the jobs are not paused after reboot be2012 trys instant to start the next job and loader goes offline again, restarting services or mark the loader as online does not work

On the HP Loader there are no Errors everytime we run into this Problem we see that the Tape of the last Backupjob from BE2012 is still in the Loader Drive and not moved back

 

Operating Systems:

Comments 4 CommentsJump to latest comment

VJware's picture

Any error events 5, 7, 9, 11 or 15 in the system logs of the media server ?

Is the changer using MS driver and is the drive using Symantec driver ? Have you run any diagnostics using OEM's tools against the tape drive ?

 

 

pkh's picture

A)  Re-install your tape library

1) Delete the library from BE
 
2) Stop the media server and the library
 
3) Start the tape library
 
4) Start the media server
 
5) Ensure that the library and tape drive is recognised and functioning correctly in the Windows Device Manager. The library should appear as an Unknown Medium Changer with a Microsoft driver and the tape drive should have a Symantec driver.
 
6) In BE, install the library if necessary. 

 

B) Run the HP LT&T utility against the tape drive.  Make sure you select the write test and that you have stopped all the BE services beforehand.  If the utility passes and you still have tape stuck in the tape drive, then I would suggest that you get the drive replaced.  BE will send the unload command to the tape drive.  If it does not respond, then BE will not know about it.

Larry Fine's picture

DeviceIo: 02:07:00:01 - Device error 1117 on "\\.\MediumChanger2", SCSI cmd a5, 1 total errors

SCSI cmd "a5" is the command that is attempting to move the tape from the tape drive back to the slot.  The request received an error response and BE took the robotic library offline as a result.  You should be able to see more about the failed a5 MOVE_MEDIUM command in the adamm.log which will give you more clues on how to troubleshoot or resolve.

If you find this is a solution for the thread, please mark it as such.

PremiaS's picture

hi sorry was away last 2 weeks,

problem still not solved, i tried what pkh wrotes all works fine, tests with hp lt&t are ok

i reseted the database to the factory default and configured a test duplicate job, with 1 tape in a mediaset with overwrite protection 1 day, append unlimited, i delete the tape, in the slots view of the loader i see the tape empty and linked to the test media set, status is overwriteable, if i start the job i see on the loader webinterface that the correct tape is loaded into the drive, now when the job should it cancels...

I got german version of be 2012 i try to translate:

first entry in the job log is:

V-79-57344-33039 - Error - loader error.
Operation of the Physical Volume Library canceled by the user.

and next is:

The order has been canceled because a media request message was answered with 'Cancel', because the message was configured so that they automatically respond with 'Cancel', or because the Backup Exec Job Engine service was stopped.

where does this come from? backup exec dont move the tape back now and its still in drive until i move it manual via loader webinterface back to the slot, in the slots view the slot is not loaded in the drive be thinks that the tape is still in the loader...

loader goes offline then i need todo what i wrote on top, reboot library, reboot server, do a inventory whats successfull and takes around 1 hour to inventory

i add 2 screens...default be options / storage and the test job duplicate storage window

please help

regards

 

 

storage-option-be2012.png testjob-dupeoptions.png