Video Screencast Help

BE2012 - Selected files not backing up, job says successful

Created: 07 Jan 2013 • Updated: 08 Jan 2013 | 8 comments
This issue has been solved. See solution.

I'm having this issue on 2 different servers.  New installation of BE2012 on Win2K8 R2, with the Agent for Applications and Databases installed, for Lotus Domino backups.  I've created a daily backup job that runs every week night - Incremetals M - Th and a Full backup on Friday.

The issue is that I have folders selected on the server that are not getting backed up.  These are just Windows directories, nothing special about them.  In one of the folders, I only have 1 file selected - this file backs up successfully.  So, my backup selection looks like this:

E:\Folder1 - box is checked, all folders/files underneath are checked

E:\Folder2 - box is checked, all folders/files underneath are checked

E:\Folder3\Subfolder1\File1 - this is the only file selected.

Lotus Domino DBs in E:\Folder3\NotesDataFolder.

Folder1 and Folder2 are completely skipped and BE reports nothing about them.  Lotus Notes databases and File 1 are backed up successfully.  This happens during both the Incremental as well as Full backups.

I only discovered it after attempting to restore a file, which didn't exist in backups.  Luckily for me, I had only been running BE2012 (on a new server) for a couple of weeks and still had the file in an old backup from the previous server.

I ran a Full manual backup of those folders, and it worked fine.  I went into my backup job and deselected and reselected those folders, with no change.  Finally, I added those folders as "Required" and that seems to have fixed the issue.  I assumed that this was an issue with this one server, however I have since installed BE2012 on another server and it has the same issue.

Obviously, this is a huge issue.  Although I believe the "Required" workaround resolves the problem, I should not have to find additional options to back up my files.  If this is the way the new BE works, what's the point of the check box without using the "Required" option?

I think I'm getting good backups now, with the "Required" option set, however I'm nervous going forward.  I obviously can't check that the 500,000+ files are getting backed up to be sure each one of them is getting backed up as it should.  Maybe I've missed something with the new version, but it seems that checking the box at the top level, which checks all files and folders underneath it, should be enough to back up those files.

 

Comments 8 CommentsJump to latest comment

lmosla's picture

Hi,
What version of Lotus Domino are you using? Check out the Software Compatibility list http://www.symantec.com/business/support/index?pag... and make sure the version is listed.

Jamie Kelahan's picture

Yes, my version of Domino (8.5) is supported and I am not having an issue with Domino backups.  It's the Windows directories that are being skipped.

Jamie Kelahan's picture

I did not have that Hotfix installed.  I forgot that I was not able to get LiveUpdate to work correctly, so there were available Hotfixes that had not been applied.  (LiveUpdate would download the files, but fail when attempting to install).

I've manually downloaded the available Hotfixes, including 199866, and will see if that fixes the problem.

Thanks.

pkh's picture

You said that these  "missing" files are backed up when you use a full backup.  I presume your problem is htat they are missing in your incremental backups.  If these files are not modified since the last full or incremental backup, then they would not be backed up in the latest incremental backup.  This is how incremental backup works.  If these unmodified files are backed up in each and every incremental backups, then the incremental backups are equivalent to full backups.

Also, note that there are some filetypes which are automatically excluded from a backup by AFE.

Jamie Kelahan's picture

Thanks, but I know the difference between full and incremental backups.  I said that this happens with both Incremental and Full backups.

lmosla's picture

You probably have, but have you rebooted recently and tried recreating the jobs?

Jamie Kelahan's picture

It looks like one of the Hotfixes (most likely 199866, that Gurvinder linked) did the trick.  One of the servers that was having the problem ran an incremental backup last night and backed up files in the directories that were previously being skipped.

The other server is the one that I used the "Required" workaround.  I will remove the "Required" setting and verify that that server is fixed as well.

Thank you all for your help.