Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

BE2012 thinks VMWare VSS provider and Symantec VSS provider are installed

Created: 31 Jul 2013 • Updated: 01 Aug 2013 | 7 comments
This issue has been solved. See solution.

For a while now, one backup job returns everytime that the job completed with exceptions:

The job completed successfully.  However, the following conditions were encountered:

The backup has detected that both the VMware VSS Provider and the Symantec VSS Provider have been installed on the virtual machine. However, only one VSS Provider can be used on a virtual machine. You must uninstall the VMware VSS Provider.

I admit: at first, the server did have the VSS provider installed: this is a Windows Server Core, and I didn't think of refusing the VSS provider through command line at VMWare Tools installation.

But I removed the VMWare VSS provider through command line. Even more, I also tried to completely remove VMWare Tools and Backup Exec Agent, and do it right this time (through command line, no VSS provider with VMWare Tools). But it still didn't help.

I recently found a discussion which mentioned whuch registry keys and files should be deleted also (I lost the link), but after making sure these things were removed, I still got the exception.

Can someone tell me what I should check after removing VMWare tools, RAWS and reinstalling them?

Operating Systems:

Comments 7 CommentsJump to latest comment

Brepols NV's picture

The VMWare VSS Provider was already uninstalled, so this one didn't help.

I noticed the note at the bottom:

Note: The Remote Agent is not required to protect the file system of VMWare virtual machines, even if file level GRT option is enabled. However, RAWS is required for application GRT backups, for file level GRT restores from databases such has SQL, Exchange, or Sharepoint. 

I could have removed the Agent from this specific server, as it doesn't need GRT-backups, but I wanted this problem really solved in case I run in to this on other, more important, servers. Certainly if we're moving more and more to Windows Server Core.

Brepols NV's picture

Thanks Kunal, the first technote was the one I once followed (but lost afterwards).

As said, I did follow those steps, but I made the mistake of never trying the steps at the bottom: taking a snapshot from VMWare, and more importantly, checking the BeVssProvider-logs.

I couldn't find any BeVssProvider-logs after 21/03/2013, and I read in the Technote above that you needed to add arguments to the pre- and post-scripts.

I opened the Pre-script, and noticed following command after ":BEGIN_PROCESSING":

IF EXIST "%ProgramFiles%\VMware\VMware Tools\Drivers\vss\VCBRequestor.dll" (
reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BeVssProviderConflict" /f
exit 0
)

So, out of curiosity, I went back to the registry, and check if that key existed. Because once, I had the VMWare VSS provider installed, and BE had difficulties with it. As I expected, the key "BeVssProviderConflict" was still present.

I deleted the key "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BeVssProviderConflict" and retried the backup: no warnings anymore.

 

Before I mark this as solved, however, I want to make sure that everything on the server is OK:

I installed the BE agent successfully, but:

1) The only VSS provider available is the Microsoft VSS Provider. Even during backup, the BeVssProvider-service does not start, and no Symantec VSS Provider becomes visible in "vssadmin list providers".

2) There are no log files under "Program Files\SYMANTEC\BACKUP EXEC\RAWS\VSS Provider\logs" since more than four months.

Should I be worried?

SOLUTION
Kunal.Mudliyar's picture

A rule of thumb is both the providers cannot be present on the virtual machine as it can  cause issues during the quiesce operation

BE will use the BEVSSprovider whenever it want to use it, usually during a backup job all the other times it will not show

Try executing the Pre script

issues a list povider command

Later execute a Post script

 
===
Have you installed the remote agent that must have clered the VSS logs
 
To enable the logging
 
1)  Edit the "Pre" and "Post" scripts in C:\Program Files\Symantec\Backup Exec\VSS Provider and %systemroot% 
2)  Add -logging to the end of each argument. Example. %Programfiles%\Symantec\Backup Exec\BE VSS Provider\BeVssRequestor.exe" -post2 -logscreen -logging. There are three arguments in each script. 
 
==
 
If the backup was successful I guess there are no conflicts

Technical Support

Symantec

Brepols NV's picture

Thanks Kunal, you are right on both accounts:

Running the Pre script and then listing the providers returns the backup exec VSS provider. I guess that on this server, the backup I'm running doesn't require VSS.

The logging is not enabled in the scripts so that's normal too. Maybe in a previous release, the logging was enabled automatically (since I never enabled it myself), although the log files were always empty anyway.

 

No Technote I found pointed to the registry key I found in the Pre script, so if you're facing issues because you have two VSS providers installed, and you remove one, it's important that you check that the registry key "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BeVssProviderConflict" is removed, otherwise the exception wil continue to bug you, even if you only have one VSS Provider installed.