Video Screencast Help

BE2012SP2 / Exchange Backup: -1032 The file cannot be accessed because the file is locked or in use. (E00000395)

Created: 15 Aug 2013 | 8 comments

Hi

This is a fairly new implementation of BE2012 SP2 -- no upgrades (apart from SP1->SP1a->SP2).

When doing Exchange backups, this is the error.

This happens on ALL Exchange servers -- meaning both 2007 and 2010 on various OS's (WS 2003, 2008, 2008R2).

 

I found a very very helpful article with a hotfix! For a previous version :D

 

I tried to exclude the folder "C:\Temp\Backup Exec" from virus scanner on the Exchange server, the folder containing the Exchange db & logs is excluded as well. The backup exec server is not running a virusscanner.

 

Please help as I've been pulling my hair out on this one..

 

Thanks a lot!!

Operating Systems:

Comments 8 CommentsJump to latest comment

lmosla's picture

Hi,  Are you backing up to tape or to disk?

EDIT:  If disk please exclude the IMG folder from any virus scan.

ithFrederic's picture

Hi Imosla

Thanks for the hint. B2D all the way; tape backup is the second phase for when all issues are straightened.

However, there is no virusscanner on the BE server, at all.

Kunal.Mudliyar's picture
On the Exchange server
 
From the Registry Editor, navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Backup Exec For 
 
Windows\Backup Exec\Engine\Exchange
 
Right click and add a new String Value, "OnHostTemp".
 
Right click and set the value of OnHostTemp to "C:\Temp".
 
Restart all Backup Exec service on Media server and the Backup Exec Remote Agent service on the
Exchange Server. Run the backup job of Exchange Resources from media server. 
 
Ref:
'Though the technote does not applies to the BE version you can on you can try it out.

Technical Support

Symantec

lmosla's picture

Check the drive where the b2d's are located for fragmentation. I've seen fragmentation cause this type of error and a defrag resolves it.  

In addition if there are multiple databases being backed up in the jobs try seperating them and create a new b2d to see if that helps.

MusSeth's picture

In addition to kunal please make sure to have backup exec logon account full control on c:\temp directory... If the permissions on this folder is not set properly, then the backup may still fail with the above error

ithFrederic's picture

Hi all

Thanks for the replies.

OnHostTemp: Didn't try it yet as it worked in the beginning and only started failing after a few weeks. Will try it out, however it would be strange.

Permissions: I did check it; however, logon account is domain admin in all instances.

 

My tests will probably be for Friday. Thanks again, will keep you updated!

lmosla's picture

You could also try running a backup without GRT enabled.

and check Windows Events during the time of the backup for errors.

okay.'s picture

Hi all,

the same problems for me.

Created new B2D-Folder (so defrag is not the problem): Error 1032.

Backup to Dedup: Error 1032.

Backup without GRT is fine, but this is not an option for my company.

OnHostTemp brings also the Error 1032.

 

So I hope there is anyboy who can help me with this problem.

 

Kind Regards

Oliver