Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

BE2014 DLM not delete already expired backup sets

Created: 12 Jun 2014 • Updated: 16 Jun 2014 | 14 comments
ksattler's picture

Hello,

I have upgraded a BE2012 SP4 installation to BE2014. The backups go to a DataDomain DD160 using as a OpenStorage device.

There a lot of backup sets which are already have been expired. The DLM of BE2014 seems not deleting already expired backup sets (e.g. from BE2012).

For new expired backup sets the deletion works.

 

How can I delete the >1000 expired backup sets?

 

 

Operating Systems:

Comments 14 CommentsJump to latest comment

WWSupport's picture

We are experiencing a similar issue. We have just installed BE 2014 in a test environment and cannot delete expired backup sets that were created by 2012.

ksattler's picture

I have opened a ticket two days ago. Symantec knows of this issue and they are working on it.

ikmit's picture

Any update on this?

This problem effectively stopped this weekend's run of full backups

DaveyMG's picture

Same issue here after upgrading from BE2012 to BE2014, expired B2D backup sets aren't being deleted.

BE2014 doesn't appear to have a UI option to delete a backup set so even though I can see there are expired sets without any dependent backup sets, I can't delete them manually.

I've also found expired B2D sets that have Duplicate-to-Tape backup sets dependent on them, even though there is a corresponding D2T set for the expired B2D set. I would expect D2T sets to only be dependent on other D2T sets.

I've got a case logged but so far I've been asked to install a hotfix related to a problem of backup sets being deleted prematurely. This didn't change the situation for me.

Frank_'s picture

I have exactly the same issue. Upgrade from 2012 to 2014 with the latest (cummulative HOTFIX 218257)

Expired media is filling up the disk because of dependency with duplicates on tape.

jerrys79's picture

ksattler,

do you have an update on the case you opened?

Thanks.

Celebi IT's picture

http://www.symantec.com/business/support/index?pag...

 

 Backup Exec button > Configuration and Settings > Backup Exec Settings > Storage > Allow Backup Exec to delete all expired backup sets

VirgilDobos's picture

Hi folks,

Starting with Backup Exec 2012, disk backup storage is managed by a new disk management function called Data Lifecycle Management (DLM). This allows BE to correctly manage disk targets and remove expired backup data. The Backup Definitions (jobs) have a setting for how long the backup data should be kept. After that timeframe has expired, DLM will delete the backup sets from Disk. DLM checks for any expired data every 4 hours by default. DLM is only used for disk targets (Backup to Disk (B2D) and Deduplication), while tape targets are managed by Media Sets like the previous versions of BE.

This being said, there are several considerations you should factor in. For example, if the backup image is the last recovery point, it will not be deleted until there is a newer one. The following article explains the two main situations where an expired backup sets will not be deleted after the expiration date and/or inability to overwrite or delete the last backup set: http://www.symantec.com/docs/TECH187957

I used several times the regkey mentioned within the article and that solved the problem: KEY_LOCAL_MACHINE\SOFTWARE\Symantec\Backup Exec For Windows\Backup Exec\Server\DeleteLastRecoverySetsOnceExpired. This registry key should delete all expired backup images.

Hope this helps.

Virgil Dobos | Sr. Technical Consultant | Condo-Protego | www.condoprotego.com 

Colin Weaver's picture

For BE 2014 this setting is exposed in the BE console so no need to edit the registry

 

Celebi IT already mentioned this earlier in the thread

DPILLC's picture

Same issue.  Upgraded to 2014 last week with all hot fixes.  Registry and config properly set as noted.  Still have backup sets from 2011 "marked" as expired with long ago expiration dates.

Moltron1's picture

I also upgraded from 2012 to 2014, and have OST / Data Domains.  There are quite a few expired sets, and they are not being removed.  Also, it seems like I can't expire them manually.  I've tried doing this, and get no error message, yet the set still shows the previous expiration.   Not sure whats going on with that.  I am expiring them so they'll get deleted and free me up some space?  Anyone also have this issue?

DaveyMG's picture

After 6 weeks my support case status is "Awaiting Hotfix". Not very meaningful - have they identified the problem and are working on a fix, or are they still trying to work out what the problem is?

Meanwhile my B2D storage is slowly filling up, even recently created backup sets that are set as expired are not being groomed nor will manually expiring them cause them to be deleted.

maurijo's picture

Call symantec, ask duty manager, raise to severity one, sit and wait.

kamel1204's picture

Hi

I have the same problem any news in this from Symantech Teck support

thanks