Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

BEMCLI vs Be2012 Restore option

Created: 25 Feb 2013 • Updated: 10 Mar 2013 | 1 comment
This issue has been solved. See solution.

The Problem

I am working with the BEMCLI library and particular running the Submit-BEFileSystemRestoreJob -and- noticed a rather nasty side effect.

When I do a restore inside the BE2012 program and send my output to a VHD I do not get promped to format the drive every time it creates a mount point. 

In the powershell (with BE commands extended) OR even in the regular BEMCLI I get prompted to format the drive that stores the VHD from windows explorer.

Pretty scarey since I am only storing a VHD file on the E: drive - but yet I am being asked to format the entire E: drive. 

I have read every message board article I can find covering this topic and am stuck.  There is no way known to block the prompt other than a systray Autoit window watcher script.

So far I have tried a lot of things written by some very misguided authors

  • Turning off all auto-play functionality
  • Turning off automount (in powershell prior to creating the VHD)
  • Running the Powershell script in Hidden Mode

Any known work arounds? 

Runnnig 64 bit BE 2012 on Server 2008 R2 Enterprise 64bit.  

---

The Complaint!

I of course want to run this as a post run command to get around some of the major incompabilities the virtualization engine has with certain machines. 

BTW If I could edit the VHD's it were to write too,  instead of worrying about every drive configuration when restoring them in SDR mode - it would save a huge amount of headache!!!   For software based RAIDS / dynamic disks / Sans connected machines.  Why should a sans connected disk throw off an entire virtulization option for a machine if I only want one drive on that machine.

If you ever want some SERIOUS suggestion for this interface esp on the virtualization side - please ask away !! ;)

Operating Systems:

Comments 1 CommentJump to latest comment

MadcowInUT's picture

Found out through much testing that my eniviornment that was causing it. Will rebuild it and see if I can find the source.

SOLUTION