Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Black screen, blinking cursor after deploying ghost image

Created: 07 Jan 2013 • Updated: 10 Jan 2013 | 18 comments

We recently got some HP Compaq Pro 6300 desktops in.  We pulled the image off just fine, but when we deployed it, the computer booted into a black screen with a blinking cursor, as if the HD was empty.  We are using Windows 7 images and Ghost 11.5.

We tried to pull the image and deploy the image both using the -IB switch, but that didn't help.  We have tried all Sata Operations settings.  We are using the same machine to pull the image and deploy the image, just swapping hard drives, so it is not a matter of hardware differences.

We are using MS Dos ghost client.  We tried the WinPE client, but it doesn't include the network drivers we need, and we are having trouble injecting them manually.

We have ghosted many machines before, but we are at a loss here.  Would WinPE make a difference if we could inject the network drivers?  Any other suggestions?

Discussion Filed Under:

Comments 18 CommentsJump to latest comment

Nitin's picture

Hello,

Can you please confirm the build number which you are using? If the console version is 11.5.0.2113 then you will see the issue which is mentioned in one of the old thread in this forum at (http://www.symantec.com/connect/forums/blinking-cu...). You need to try with the latest ghost version available which is 11.5.1.2266 (apply sebsquent patches on top of 2.5.1.2266 with the help of Symantec support team is recommended).

Regards,
Nitin

If you feel your issue has been addressed to, please use the "Mark as Solution" link for the relevant thread

EdT's picture

As you are imaging Win 7 - are you ensuring that BOTH the partitions are imaged?  Without the 100Mb system partition, Win 7 will not boot.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Nitin's picture

@EdT : Yes, you may be right but in that case you will see the blue screen or some kind of boot loader message. But here user gets a blank screen with curcor blinking. So I suspect this is bug in older version of ghost and it is worth to try with latest ghost binary.

Regards,
Nitin

If you feel your issue has been addressed to, please use the "Mark as Solution" link for the relevant thread

EdT's picture

Actually, I believe that the blinking cursor may be an indication that the boot process has failed badly.

If I recall correctly, the changes between 2113 and 2266 are more to do with supporting sysprep on windows 7 rather than any specific imaging issues, but updating to the latest release removes one variable from the equation.

What I would also suggest is that you check that the bios settings to make sure that both source and target machines are set to IDE COMPATIBILITY MODE, as MSDOS has no support for SATA hard disk or for ACPI, and there are also issues with large hard disks due to the limitations of DOS CHS block addressing which only allocates 32 bit for the CHS information.

I would always recommend WinPE for any modern hardware, and if you are having problems injecting drivers, you need to bear in mind that the version of WinPE shipping with GSS is based on the Vista 32 bit kernel and therefore needs 32 bit vista drivers to be added - REGARDLESS of the operating system you are imaging.

Drivers must be added for both the NIC and SATA hardware if you are imaging over the network.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

mocards120's picture

We were using an older version of Ghost.  We have installed all updates are are now using version 11.5.1.2266.  We made a bootable Ghost flash drive using WinPE and loaded the needed drivers.  Everything seemed to work fine (and faster using the new version.)  After deploying the image (without errors) I still got the blinking cursor with black screen.  We are doing an entire disk image, so we should be capturing all partitions.

We have a few more things to try on our end, but we are running out of things to try.  Thanks for all the information so far, and helping with our issue.

Edit: Some additional info:  We have used ghost to image over 10 different models of desktops and have never seen this issue before.  The new PCs have some sort of UEFI instead of BIOS, so we think that may have something to do with it.

Nitin's picture

Hello,

Thanks for sharing the information. Currently ghost doesnt support UEFI imaging. Please try with Legacy mode and check.

Extra info : Ghost tools in new release of Deployment Solution will support the UEFI imaging. But currently we have no information about timelines for release date of DS.

Regards,
Nitin

If you feel your issue has been addressed to, please use the "Mark as Solution" link for the relevant thread

mocards120's picture

We finally figured out that the main problem was that the hard drives in the new PCs is set to GPT, not MBR.  Ghost apparently doesn't like GPT.  To fix our problem, we had to format the hard drive, add it in as a secondary drive, convert it from GPT to MBR, and then make a new image.  Only then would ghost work correctly and create a bootable image.

140.6's picture

mocards120,

We just got the same machines in and had the same exact issue as you did.  I imaged the PC did a successful image creation but once we restored the image back to the same machine, we got the blinking cursor.  I did what you mentioned, slaved the drive in another PC, set the drive to MBR, then popped into one of the new PCs and ran the Win7 install.  After it all was said and done, the Win7 install created the 100 MB EFI partition again followed with the 500 GB partition where the OS was installed.  Is that how yours also ended up?

mocards120's picture

No.  With our machines, the change from EFI to MBR was successful and stuck throughout the Win7 installed process.  We have been able to Ghost over other EFI drives with success.  Maybe your machines have an option to go from EFI to MBR in the BIOS?  Ours didn't, but our roundabout solution worked.

Nitin's picture

This is not true.

Symantec Ghost supports GPT-formatted disks using the following executable programs:

■ Ghost

■ Ghost32

■ Ghost64

■ ghost for Linux

■ GhDplyAw32

■ GDisk

■ GDisk32

■ GDisk64

■ gdisk for Linux

■ Ghost Walker

■ Ghost Walker 32

■ GhConfig

■ GhConfig32

■ GhConfig64

■ ghconfig for Linux

■ GhRegEdit

■ GhRegEdit32

■ GhRegEdit64

■ ghregedit for Linux

■ OmniFS

■ OmniFS32

■ OmniFS64

■ omnifs for Linux

You can find the details in user guide on page 48-49.

Regards,
Nitin

If you feel your issue has been addressed to, please use the "Mark as Solution" link for the relevant thread

EdT's picture

This is more than likely a side effect of the UEFI bios. Perhaps changing the formatting of the hard disks has changed the default behaviour of the bios and resulted in a successful outcome.  It may be worth spending a bit more time investigating the exact issue in your hardware in case it comes back and bites you at a later date.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

kbgs1's picture

we are having a similar issue blinking cursor after ghosting- does anyone see that SSD's may be a cause? we have had no problems imaging using ghost in the last 5 years- now we have gone ssd we have had nothing but issues.

EdT's picture

Looking at other imaging products, updates were released which included SSD support, so as Ghost has not had any updates since before SSDs started appearing in machines, I suspect there are going to be issues with SSD imaging.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

FCPL's picture

I, too, am seeing the blinking cursor when trying to image onto a drive.  I have an image created on a Lenovo M81 - Win7 Pro x64.  Actually, I have two disk images - one from a HDD and one from a SSD.  For both drives, Windows was installed from scratch.

In each case (hdd and ssd), the image pulled clean without errors.  Deploying to a new drive (hdd image to new hdd, ssd image to new ssd) completes without errors.  When trying to boot to the new drive, however, all I get is the blinking cursor in the upper left corner of the screen.

I get this behavior no matter how I try to deploy the image. I've tried using the GhostCast Server (11.5.1.2266), with PCDOS and WinPE.  I have also tried skipping GhostCast and doing a local disk-to-disk transfer, also with both PCDOS and WinPE.

What really baffles me is that I imaged other M81s about a year ago, with SSD drives. They worked fine, and for the life of me I cannot tell what might have been different.

Can someone please offer some suggestions? I'm pretty stuck at the moment, and don't fancy the idea of installing 30 machines from scratch.

Thanks in advance.

FCPL's picture

I'll have to run some more tests, but I think the problem was with the MBR.  I popped in a Win7 system recovery disk and ran "bootrec /fixmbr" from a command prompt, and all was well again.  It booted like a champ.  Now to figure out how the mbr got hosed in the first place...

kbgs1's picture

After trying every fix offered on this feed and none of them working. i started removing elements of the process to see where the issue was, long story short for some reason i this would only happen when i imaged from a server using pxe and tfpt or any network related option.

so what i did is created the a bootable disk with ghost and imaged locally disk to image....then copied the image to my image store and can push out using ghostcast server....not the best fix but i actually feel more comfortable creating the image to a local drive rather than across the network

GJR_Tech's picture

Here's my solution after trying several of the other options listed above.  Granted - this has only been done with Windows 7 64-bit...haven't tested with any other OS yet.  From what I've read, Windows 8 now requires UEFI and therefore all new computers being released will have that.  When you start with a new installation, UEFI requires a GPT partition table.  Unfortunately - Ghost seems to be able to pull the image successfully but cannot deploy it.

My simplest solution was to go into BIOS, and under 'Storage', go to 'Boot Order' and disable the UEFI Boot Sources.  Save changes and exit, then proceed to start a fresh installation.  Now your drive should be created with MBR partitions and Ghost should not have an issue capturing and deploying the image.

Just make sure that the other computers you are deploying to have already had the same BIOS changes done to them!  

Nitin's picture

New ghost binaries does support UEFI imaging which are part of Deployment Solution. DS have been released recently. You may want to contact Symantec Tech support to opt those.

Regards,
Nitin

If you feel your issue has been addressed to, please use the "Mark as Solution" link for the relevant thread