Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

BMR Backup fails with status code 1

Created: 05 Jan 2014 • Updated: 07 Jan 2014 | 5 comments
Nicenavin's picture
This issue has been solved. See solution.

Hi Friends,

My Master server is Windows 2003 and BMR Boot server is Windows 2008 and client also Windows 2008.

I have configured the BMR - Backup and Ran it. And In backup policy the host name mentioned as IP address of the client.

The backup job has completed with status code:1 and error reported that " Failed to import Config file"

Tried with tech notes for solutions, not availble.

  1. Is it recommanded ipaddress or hostname , whcih should be mention in the policy?
  2. Is there any solution for error code1?

Below are the logs:

 ----------------------------------------------

01/02/2014 20:25:14 - transfering BMR information to the master server
01/02/2014 20:25:14 - connecting
01/02/2014 20:25:14 - connected; connect time: 0:00:00
01/02/2014 20:25:20 - Error bpbrm (pid=5132) BMRERR: Received BMR error: Failed to import Config file. (1)
01/02/2014 20:25:21 - end writing
Operation Status: 1
01/02/2014 20:25:21 - end Bare Metal Restore: Bare Metal Restore Save; elapsed time 0:00:17
01/02/2014 20:25:21 - begin Bare Metal Restore: Policy Execution Manager Preprocessed
Operation Status: 0
01/02/2014 20:37:50 - end Bare Metal Restore: Policy Execution Manager Preprocessed; elapsed time 0:12:29
01/02/2014 20:37:50 - begin Bare Metal Restore: End Notify Script
01/02/2014 20:37:51 - Info RUNCMD (pid=4296) started
01/02/2014 20:37:51 - Info RUNCMD (pid=4296) exiting with status: 0
Operation Status: 0
01/02/2014 20:37:51 - end Bare Metal Restore: End Notify Script; elapsed time 0:00:01
Operation Status: 1
01/02/2014 20:37:51 - end Parent Job; elapsed time 0:12:47
the requested operation was partially successful  (1)

Awaiting ......

Thanks & regards,

Navin

Operating Systems:

Comments 5 CommentsJump to latest comment

mandar_khanolkar's picture

Please check bmrd log file on your NB master server generated post import failure for any clue. You can find this file in netbackup/logs/bmrd directory.

thanks.

mandar

Nicenavin's picture

$Header 65543,51216,119,1388850109,18000,kek3bkvnnp01 0,51216,128,119,1,1388850109233,9760,6696,0:,57:BinaryFileBlock size is not 0, Vector should not be used!,30:DbInterface::writeBinaryFile(),1 0,51216,128,119,2,1388850109233,9760,6696,0:,25:BinaryFileBlock size is 1,30:DbInterface::writeBinaryFile(),1 0,51216,128,119,3,1388850109233,9760,6696,0:,57:BinaryFileBlock size is not 0, Vector should not be used!,30:DbInterface::writeBinaryFile(),1 0,51216,128,119,4,1388850109233,9760,6696,0:,25:BinaryFileBlock size is 2,30:DbInterface::writeBinaryFile(),1 0,51216,128,119,5,1388850109264,9760,6696,0:,122:SQL Err code:-1Msg: [Sybase][ODBC Driver][SQL Anywhere]Column 'PackageId' in table 'BMR_PackageToDeviceIds' cannot be NULL,48:CPackageToDeviceIdsDb::insertDb(DbInterface *db),1 0,51216,128,119,6,1388850109264,9760,6696,0:,66:Stored Procedure failed = BmrDba.BMR_PackageToDeviceIdsInsert_PROC,48:CPackageToDeviceIdsDb::insertDb(DbInterface *db),1 0,51216,128,119,7,1388850109264,9760,6696,0:,45:Failed to insert CPackageToDeviceIds rc = 299,18:CBmrDb::insertDb(),1 1,51216,128,119,8,1388850109280,9760,6696,0:,0:,28:ImportCfg.cpp:ImportConfig(),1,(21|) 0,51216,128,119,1,1388876958379,3280,7084,0:,57:BinaryFileBlock size is not 0, Vector should not be used!,30:DbInterface::writeBinaryFile(),1 0,51216,128,119,2,1388876958379,3280,7084,0:,25:BinaryFileBlock size is 1,30:DbInterface::writeBinaryFile(),1 0,51216,128,119,3,1388876958379,3280,7084,0:,57:BinaryFileBlock size is not 0, Vector should not be used!,30:DbInterface::writeBinaryFile(),1 0,51216,128,119,4,1388876958379,3280,7084,0:,25:BinaryFileBlock size is 2,30:DbInterface::writeBinaryFile(),1 0,51216,128,119,5,1388876958395,3280,7084,0:,122:SQL Err code:-1Msg: [Sybase][ODBC Driver][SQL Anywhere]Column 'PackageId' in table 'BMR_PackageToDeviceIds' cannot be NULL,48:CPackageToDeviceIdsDb::insertDb(DbInterface *db),1 0,51216,128,119,6,1388876958395,3280,7084,0:,66:Stored Procedure failed = BmrDba.BMR_PackageToDeviceIdsInsert_PROC,48:CPackageToDeviceIdsDb::insertDb(DbInterface *db),1 0,51216,128,119,7,1388876958395,3280,7084,0:,45:Failed to insert CPackageToDeviceIds rc = 299,18:CBmrDb::insertDb(),1 1,51216,128,119,8,1388876958410,3280,7084,0:,0:,28:ImportCfg.cpp:ImportConfig(),1,(21|)

Thanks & Regards,

Naveen

Jaime_Vazquez's picture

Naveen:

I wrote this TECH article to assist in diagnostics for such issues.

BMR enabled backup jobs fail with status code 1
http://www.symantec.com/docs/TECH207639

Based on the information in the bmrd log, you are having an insert problem into the BMRDB for the client configuration. Root cause of that can either be a problem with the configuration "bundle.dat" file created or with the BMRDB itself.

As per notes in the TECH article, copy the file "bundle.dat" from the client to the Master Server and attempt to do a manual import, using the noted command "..\Netbackup\binbmrs -o import -res Config -path <..>".

Your server environment, as set up, is not the problem. For this type of operation, the Boot Server is not active.

This may entail opening a support case for the issue. If I had a copy o this file, I would try to do the manual import into my test server to verify the condition of the file itself.  If it is a good working file, you would probably need to recreate/rebuild your BMRDB. This article explains how that is done.

How to rebuild the BMR database (BMRDB)
http://www.symantec.com/docs/TECH207454

Rebuilding a BMRDB does not cause any data loss situation for NetBackup.

And, yes, using a host name entry in the client list in the policy is recommended, but not strictly required. I would look in the client's Windows Registry to see how NBU itself has the client registered and suggest setting it to that.

HKEY_LOCAL_MACHINE\SOFTWARE\Veritas\NetBackup\Current_Version\config\Client_Name

I hope this helps.

mandar_khanolkar's picture

This issue could be related to some device driver package ripping and association with device. In short the bmr bundle.dat (backup config) might not be formed correctly on this system.

I would recommend you to open a support case with symantec to get quick solution on this issue.

Thanks.
mandar

Nicenavin's picture

Hi Friends,

Thank you very much for Mandar, Jaime, Chetan.

Logged a case with Symntec and updated the "eebinstaller" patch.

After ran the BMR backups and completed successfully.

Regards,

Navin

Thanks & Regards,

Naveen

SOLUTION