Video Screencast Help

BMR Restore "No Network Interface were Discovered"

Created: 08 Oct 2012 | 13 comments

Hi,

I have taken BMR backup of VM machine and I tried to restore and boot the same BMR backup in the same backed up VM machine by mounting SRT created bootable ISO image in VM.

While BMR restore i am facing "No network interface were discovered". I am trying to boot the VM machine SRT bootable ISO image but it shows the no network interface were discovered error. Please suggest solution. Whether SRT need any drivers? also please share any video of how to add drivers in driver package wizard of boot server assistant. OR kindly share video of BMR restore with bootable media.

Comments 13 CommentsJump to latest comment

Yasuhisa Ishikawa's picture

Please tell us more detail about your configuration.

Which version of NetBackup are you using?
What OS?
What type of virtualization hypervisor?
Which type of virual NIC are you configured?
Which driver is loaded for this NIC when the VM running?

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

Anandha Kannan - Sify's picture

Which version of NetBackup are you using?

Netbackup 7.5.0.1

What OS?

Windows 2008 R2 64 bit enterprise Server

What type of virtualization hypervisor?

ESX - VM 5

Which type of virtual NIC are you configured?

Client Machine adapter is VMXNET3

Which driver is loaded for this NIC when the VM running?

 

 

 

MY BOOTSERVER DETAILS: its a Blade Server(sorry but i mentioned as VM server in prev comment)

 

Host Name:                 INMAPIBAK002
OS Name:                   Microsoft Windows Server 2008 R2 Standard
OS Version:                6.1.7601 Service Pack 1 Build 7601
OS Manufacturer:           Microsoft Corporation
OS Configuration:          Member Server
OS Build Type:             Multiprocessor Free
Registered Owner:          Windows User
Registered Organization:
Product ID:                55041-178-8022673-84958
Original Install Date:     2/17/2012, 8:47:55 PM
System Boot Time:          10/8/2012, 4:12:07 PM
System Manufacturer:       HP
System Model:              ProLiant BL460c G6
System Type:               x64-based PC
Processor(s):              2 Processor(s) Installed.
                           [01]: Intel64 Family 6 Model 26 Stepping 5 GenuineInt
el ~1595 Mhz
                           [02]: Intel64 Family 6 Model 26 Stepping 5 GenuineInt
el ~1595 Mhz
BIOS Version:              HP I24, 5/5/2011
Windows Directory:         C:\Windows
System Directory:          C:\Windows\system32
Boot Device:               \Device\HarddiskVolume1
System Locale:             en-us;English (United States)
Input Locale:              en-us;English (United States)
Time Zone:                 (UTC+05:30) Chennai, Kolkata, Mumbai, New Delhi
Total Physical Memory:     32,758 MB
Available Physical Memory: 30,164 MB
Virtual Memory: Max Size:  65,514 MB
Virtual Memory: Available: 62,921 MB
Virtual Memory: In Use:    2,593 MB
Page File Location(s):     D:\pagefile.sys
Domain:                    appscloud.net
Logon Server:              \\INMAPIBAK002
Hotfix(s):                 1 Hotfix(s) Installed.
                           [01]: KB976902
Network Card(s):           14 NIC(s) Installed.
                           [01]: HP NC532i Dual Port 10GbE Multifunction BL-c Ad
apter
                                 Connection Name: 6
                                 DHCP Enabled:    Yes
                                 DHCP Server:     N/A
                                 IP address(es)
                           [02]: HP NC532i Dual Port 10GbE Multifunction BL-c Ad
apter
                                 Connection Name: 5
                                 DHCP Enabled:    Yes
                                 DHCP Server:     N/A
                                 IP address(es)
                           [03]: HP Network Teaming Virtual Miniport Driver
                                 Connection Name: Kuoni-Management
                                 DHCP Enabled:    No
                                 IP address(es)
                                 [01]: 119.227.222.94
                           [04]: HP NC532i Dual Port 10GbE Multifunction BL-c Ad
apter
                                 Connection Name: 7
                                 DHCP Enabled:    Yes
                                 DHCP Server:     N/A
                                 IP address(es)
                           [05]: HP NC532i Dual Port 10GbE Multifunction BL-c Ad
apter
                                 Connection Name: 8
                                 DHCP Enabled:    Yes
                                 DHCP Server:     N/A
                                 IP address(es)
                           [06]: HP NC532i Dual Port 10GbE Multifunction BL-c Ad
apter
                                 Connection Name: 1
                                 DHCP Enabled:    Yes
                                 DHCP Server:     N/A
                                 IP address(es)
                           [07]: HP NC532i Dual Port 10GbE Multifunction BL-c Ad
apter
                                 Connection Name: 2
                                 DHCP Enabled:    Yes
                                 DHCP Server:     N/A
                                 IP address(es)
                           [08]: HP NC532i Dual Port 10GbE Multifunction BL-c Ad
apter
                                 Connection Name: 3
                                 Status:          Media disconnected
                           [09]: HP NC532i Dual Port 10GbE Multifunction BL-c Ad
apter
                                 Connection Name: 4
                                 DHCP Enabled:    Yes
                                 DHCP Server:     N/A
                                 IP address(es)
                           [10]: HP Network Teaming Virtual Miniport Driver
                                 Connection Name: Infy-Mgnt
                                 DHCP Enabled:    No
                                 IP address(es)
                                 [01]: 192.168.52.5
                           [11]: HP Network Teaming Virtual Miniport Driver
                                 Connection Name: Local Area Connection 2
                                 DHCP Enabled:    No
                                 IP address(es)
                                 [01]: 172.16.100.214
                           [12]: HP Network Teaming Virtual Miniport Driver
                                 Connection Name: Local Area Connection 3
                                 DHCP Enabled:    Yes
                                 DHCP Server:     255.255.255.255
                                 IP address(es)
                                 [01]: 169.254.205.121
                           [13]: HP Network Teaming Virtual Miniport Driver
                                 Connection Name: Mgnt
                                 DHCP Enabled:    No
                                 IP address(es)
                                 [01]: 119.227.214.234
                           [14]: HP Network Teaming Virtual Miniport Driver
                                 Connection Name: VM-Mgnt-197
                                 DHCP Enabled:    No
                                 IP address(es)
                                 [01]: 192.168.50.201

 

MY CLient VM client Details to which am going to do BMR restore:

 

Host Name:                 VPS-DIFF-BKUP-T
OS Name:                   Microsoftr Windows Serverr 2008 Standard
OS Version:                6.0.6002 Service Pack 2 Build 6002
OS Manufacturer:           Microsoft Corporation
OS Configuration:          Standalone Server
OS Build Type:             Multiprocessor Free
Registered Owner:          Windows User
Registered Organization:
Product ID:                92573-082-2500115-76452
Original Install Date:     8/9/2012, 8:23:19 AM
System Boot Time:          10/10/2012, 1:01:06 AM
System Manufacturer:       VMware, Inc.
System Model:              VMware Virtual Platform
System Type:               x64-based PC
Processor(s):              2 Processor(s) Installed.
                           [01]: Intel64 Family 6 Model 44 Stepping 2 GenuineIn
el ~2667 Mhz
                           [02]: Intel64 Family 6 Model 44 Stepping 2 GenuineIn
el ~2667 Mhz
BIOS Version:              Phoenix Technologies LTD 6.00, 9/21/2011
Windows Directory:         C:\Windows
System Directory:          C:\Windows\system32
Boot Device:               \Device\HarddiskVolume1
System Locale:             en-us;English (United States)
Input Locale:              en-us;English (United States)
Time Zone:                 (GMT+05:30) Chennai, Kolkata, Mumbai, New Delhi
Total Physical Memory:     4,094 MB
Available Physical Memory: 3,159 MB
Page File: Max Size:       8,364 MB
Page File: Available:      7,429 MB
Page File: In Use:         935 MB
Page File Location(s):     C:\pagefile.sys
Domain:                    WORKGROUP
Logon Server:              \\VPS-DIFF-BKUP-T
Hotfix(s):                 104 Hotfix(s) Installed.
                           [01]: {47740627-D81D-4A45-A215-03B075A18EC7}
                           [02]: {A8E86480-A9C1-4414-8AA2-B05A485C82F0}
                           [03]: {65AFCB03-3111-47E2-B1ED-198D6B0BC96E}
                           [04]: KB971513
                           [05]: KB971512
                           [06]: KB960362
                           [07]: KB2117917
                           [08]: KB2296011
                           [09]: KB2305420
                           [10]: KB2347290
                           [11]: KB2387149
                           [12]: KB2393802
                           [13]: KB2419640
                           [14]: KB2423089
                           [15]: KB2442962
                           [16]: KB2481109
                           [17]: KB2483185
                           [18]: KB2492386
                           [19]: KB2505189
                           [20]: KB2506014
                           [21]: KB2506212
                           [22]: KB2507618
                           [23]: KB2507938
                           [24]: KB2508429
                           [25]: KB2509553
                           [26]: KB2510581
                           [27]: KB2511455
                           [28]: KB2533623
                           [29]: KB2535512
                           [30]: KB2536275
                           [31]: KB2536276
                           [32]: KB2544521
                           [33]: KB2544893
                           [34]: KB2545698
                           [35]: KB2563227
                           [36]: KB2564958
                           [37]: KB2570947
                           [38]: KB2584146
                           [39]: KB2585542
                           [40]: KB2598479
                           [41]: KB2604094
                           [42]: KB2618451
                           [43]: KB2620704
                           [44]: KB2620712
                           [45]: KB2621440
                           [46]: KB2631813
                           [47]: KB2633952
                           [48]: KB2643719
                           [49]: KB2644615
                           [50]: KB2645640
                           [51]: KB2646524
                           [52]: KB2653956
                           [53]: KB2654428
                           [54]: KB2655992
                           [55]: KB2656362
                           [56]: KB2656374
                           [57]: KB2659262
                           [58]: KB2676562
                           [59]: KB2677070
                           [60]: KB2679255
                           [61]: KB2685939
                           [62]: KB2686833
                           [63]: KB2688338
                           [64]: KB2690533
                           [65]: KB2691442
                           [66]: KB2695962
                           [67]: KB2698365
                           [68]: KB2699988
                           [69]: KB2718523
                           [70]: KB2718704
                           [71]: KB2719985
                           [72]: KB954155
                           [73]: KB955430
                           [74]: KB956250
                           [75]: KB961501
                           [76]: KB967723
                           [77]: KB968389
                           [78]: KB970238
                           [79]: KB971029
                           [80]: KB971657
                           [81]: KB972270
                           [82]: KB973507
                           [83]: KB973565
                           [84]: KB973917
                           [85]: KB974318
                           [86]: KB974571
                           [87]: KB975560
                           [88]: KB975929
                           [89]: KB976470
                           [90]: KB978338
                           [91]: KB978542
                           [92]: KB978601
                           [93]: KB979099
                           [94]: KB979309
                           [95]: KB979482
                           [96]: KB979687
                           [97]: KB979688
                           [98]: KB979910
                           [99]: KB980248
                           [100]: KB980842
                           [101]: KB981322
                           [102]: KB982132
                           [103]: KB982799
                           [104]: KB968930
Network Card(s):           1 NIC(s) Installed.
                           [01]: vmxnet3 Ethernet Adapter
                                 Connection Name: Local Area Connection
                                 DHCP Enabled:    No
                                 IP address(es)
                                 [01]: 192.168.50.208
 

Yasuhisa Ishikawa's picture

Are you restoring onto same VM or newly created VM?
In my lab, there are no problem restoring onto same VM.

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

Anandha Kannan - Sify's picture

Yes, am restoring onto same VM. But now i encountered new error please find that below

 

Hi While doing BMR restore in activity monitor job failed with allocation failed 10 error. Please find the failed detail status below

 

10/10/2012 3:50:58 AM - begin Restore
10/10/2012 3:50:59 AM - restoring image VPS-Diff-Bkup-Test_1349732030
10/10/2012 3:51:00 AM - requesting resource @aaaaN
10/10/2012 3:51:00 AM - Error nbjm(pid=6472) NBU status: 2107, EMM status: Requested media server does not have credentials or is not configured for the storage server
10/10/2012 3:51:00 AM - Error nbjm(pid=6472) NBU status: 2107, EMM status: Requested media server does not have credentials or is not configured for the storage server
10/10/2012 3:51:21 AM - Warning bprd(pid=9876) Restore must be resumed prior to first image expiration on 11/9/2012 3:03:50 AM
10/10/2012 3:51:21 AM - end Restore; elapsed time: 00:00:23
allocation failed(10)

Please suggest your solution asap.

 

And also please find the attached BMR error which i faced in restoring VM.

 

 

 

BMR error.jpg
RLeon's picture

For your first problem, I had the exact same issue. It was solved. Basically it comes down to this:

The default BMR SRT restore environment (after boot and after PXE tftp transfers / after cd boot) would only work when using the E1000 virtual network interface from VMWare ESX.
To make the SRT support other virtual network inferfaces, such as VMXNET3, their NIC drivers will have to be integrated into the SRT during its creation.

For how to integrate additional NIC / Storage Controller drivers in to SRTs, please refer to the BMR guide.

Yasuhisa Ishikawa's picture

Requested media server does not have credentials or is not configured for the storage server

Check if user and password on the storage server is changed(are you using OST?) .
Now it seems to me you can not backup to and restore from this storage server. If you really in urgent, please log a call with Symantec.

I doubt like RLeon first. It is better to use popular NIC like e1000.
But BMR works with vmxnet3 in my lab running NetBackup 7.5.0.3.

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

Anandha Kannan - Sify's picture

Hi,

Please let me know  this.

1. i have booted my BMR restore environment client machine with bootable media created by SRT.

2. And i selected network based SRT while doing prepare to restore window.

 

whether what i did is correct or i have select CD based SRT in prepere to restore window.

 

Also please find the attached screenshot shows that no drivers. suggest me how to install the drivers in SRT and where i can download the drivers.

bmr restore error.jpg
Anandha Kannan - Sify's picture

Hi

 

If i create SRT with NB 7.5.0.3 client will it work? to fix the driver issue... which i have faced like in the attached screenshot above.

Anandha Kannan - Sify's picture

Hi Please find my BMR protected client details in the attached screen shot. Please tel me wat r the drivers i need to add in the SRT.

drivers.JPG
Nathan Kippen's picture

I'll be the third to say you need to use/create an e1000 interface on the VOE (virtual operating enviornment) ... and pxe boot using that interface.

Symantec Certified Specialist
(NBU 7.5.0.6)
Don't forget to vote or mark solution!

RLeon's picture

Or.... If you really hate the e1000 interface with a passion, you could integrate your preferred nic driver in to a srt and create an iso from it. (or pxe it).

The first step to integrating drivers in to a srt is to copy the "current" configuration of a client to a new custom configuration; which I don't see you doing from your screenshot.
You have to right click a "current" configuration, select "new client configuration", then copy it to a new custom configuration. With a new custom configuration, you will be able to finally integrate your drivers. Then, you create a new srt from this custom configuration.

As for getting the drivers, they are nornally captured from the client in to the BMR db when you do a BMR backup of the client. From your screenshot, I can see that BMR already has the vmxnet3 driver, you just need to integrate it to a new srt manually from using a new custom configuration.

Please go through the BMR guide, and the parts that talk about copying the "current" configurations to new ones for editing.

Yasuhisa Ishikawa's picture

Please let me know  this.

1. i have booted my BMR restore environment client machine with bootable media created by SRT.

2. And i selected network based SRT while doing prepare to restore window.

No. If you are to boot from media, you have to select SRT for media boot while doing 'prepare to restore'.

Now, I tested with NetBackup 7.5.0.1, and got same issue. But, recovery by network boot ends successfuly. FYI, my previous test is also network boot.
I'm wondering why, but if you really need to recover it ASAP, try network boot.

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

Anandha Kannan - Sify's picture

Thanks for all.....

 

By using E1000 driver i tried and completed BMR restore