Video Screencast Help

Boot to PXE doesn't work from a Job, only from task.

Created: 12 Nov 2013 • Updated: 19 Nov 2013 | 6 comments
YannickVR's picture
This issue has been solved. See solution.

I have the weirdest problem right now.. New installation of DS7.5, created boot images, jobs and tasks etc.

My "Deploy image" job has these tasks;

Boot to PXE WinPE x86
Deploy Image

If i run this job on a client, it just reboots (PXE-M0F). If i go to the Boot to PXE WinPE x86 task and schedule the client with only this task, the client gets the boot image and boots to WinPE.

Any ideas? As far as I know my whole installation is the same as my previous installation which didn't have this particular problem (enough other problems though, like ****ing up the BDC package all the time.

Operating Systems:

Comments 6 CommentsJump to latest comment

YannickVR's picture

Only difference with my previous config that i can think of is that i had a X64/X86 boot program before (i'm deploying a x86 os) and i have a x86 only one now.. creating a new x64x86 winpe now..

YannickVR's picture

So, more testing done, it's still weird.

I've set up the NBC to respond to Managed Computers with the F8 menu. Booted the computer and got the F8 menu, after 3 seconds boots to next device.

Then added the computer to my job which starts with boot to winpe. Computer boots, Altiris responds.. with PXE-M0F!

Now I created a new job and a new boot to task and it seems to work now.. more testing to come!

Also, the BDC package, even after a complete reinstall, gets corrupted again and again (whole ghost x86 and x64 folder gets deleted, save for one .exe

YannickVR's picture

I did not, thanks for the link, i quickly looked at it and it seems a part of my solution.

I had to reinstall the complete environment because of something else (do not ever delete the BDC package in the console, GUID is referenced by procedures), but before I didn't have to set the "respond to.." for managed computers, as long as they had job assigned with a boot to pxe task in the start they would boot, and now they didn't. But if it was only the boot to pxe task they would.. Anyway, changed that now, i will also have a look at changing the stored procedure :)

Thomas Baird's picture

There is a new SP coming out Monday hopefully with the first HF for the product to help resolve a handful of those reboot to issues. We've been testing this daily and think we got it finally. Everyone should get this HF when released (again hopefully Monday, but we'll see right?).

Remember as well that in 7.5 we need to enable the respond to options in General Settings or the tasks will fail. More control and grainularity comes at the cost of paying more attention to setup details. :)

Thomas Baird
Enthusiast for making things better!

YannickVR's picture

Any other fixes in the SP?

I've applied the fixes that Mistral posted and PXE is working like a charm now :)