Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Boot Wizard can't / won't install .inf driver C600/X79 SATA device

Created: 21 Feb 2013 • Updated: 21 Feb 2013 | 2 comments
This issue has been solved. See solution.

Boot Wizard complains when I try to add a driver for the C600/X79 Intel SATA device into the Win PE 512 driver set.  

The storage issue is complicated by the fact that the drives are connected to the system in a Dell PERC raid configuration.  This implies "two storage" drivers are needed.  I have found and installed the PERC driver and the NIC driver.  I now receive errors only on the intel C600/X79 chipset driver for SATA controller - AND, I can use the existing driver set via PXE to capture and deploy to these systems but NOT the Ghost Console.

 

Possibilities gleaned from perusing this forum include:

Malformed driver file - newer versions of the driver will install, but will not work.  

MSXML6.DLL missing - I checked for this and this file is present on my server.

I have found that the device ID is not present in the file that will install but not work, and is present in the driver file that WON'T install:

The line in the driver file specifying the exact device :

 

[INTEL_HDC]
%PCI\VEN_8086&DEV_1D02.DeviceDesc%=intelahci,PCI\VEN_8086&DEV_1D02

does not appear in the NEW drivers, and thus when attempting to use that, Ghost fails to boot to the virtual partition on the basis that this driver is not found.  However, Ghost fails to install the driver from the older driver pacakage that specifies the device "8086&DEV_1D02" with the error :

 

And adding the line to the file to tell the newer driver to manage this device also fails with the error:

"Following drivers had problems installing to Windows PE"  Error Code 0x3

 

I have tried installing the same drivers into the MS DOS PE environment as well, in case the older files might be more compatible.  The same failure occured.

 

Is there a way to integrate a stand-alone driver, the name in this case is "intelahci.inf" with no other metadata around it into the PE?

OR.

Is there a way to ratchet down Ghost Console's error checking?

 

M.K. McDowell

Metis Technology Solutions

Air Traffic Operations Lab

NASA Langley Research Center

Operating Systems:

Comments 2 CommentsJump to latest comment

EdT's picture

Check out this technote: https://www-secure.symantec.com/connect/articles/do-i-have-correct-driver-winpe

Are you aware that the drivers needed by the version of WinPE supplied with Ghost Solution Suite 2.5.1.2266 are Vista 32 bit drivers, as WinPE uses the Vista kernel.

Might be worth a call to support (see sticky posting at top of forum) in case your particular Intel controller needs the 2269 patch. Sticking a disk into any optical drives on your system is a temporary workaround in this situation.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

McNASA's picture

Yes, I actually have now solved this issue with a manual edit of the pci.manifest.txt file, a solution that was suggested after I ran another search.

I added line to the manifest using information from the task log on the device ID and the PCI Subsystem and following that it worked like a champ.

I don't actually know if the driver file (the .inf) is IN the PE package or not, it's still checked even after Ghost told me it had problems adding them.  I don't know if there is a way to verify that.

Nevertheless I will check your link and it might clarify the situation for me, thank you for answering!  

 

--M

 

SOLUTION