Video Screencast Help

bootwiz.exe does not sync winpe image to task servers

Created: 21 Nov 2012 • Updated: 29 Nov 2012 | 15 comments
This issue has been solved. See solution.

Hello,

I am running Altiris 7.1

our winpe image was created on the altiris NS server ( that is also a task server and a package server)
on this server we see the winpe image , etcetera , in the folder structure ...\Altiris\Altiris Agent\Agents\Deployment\Task Handler\...
and on this site booting to winpe works fine.

when we recreate the preboot environment in the console to sync them to our other altiris task servers we see the bootwiz.exe process startingon these taskservers,  also we see the folder cfg-tmp being created with some content in it, on these task servers.  after 5 minutes the bootwiz.exe stops

result: when you look in \Altiris\Altiris Agent\Agents\Deployment\Task Handler\bootwiz\iso-imgs folder is empty.
    \Altiris\Altiris Agent\Agents\Deployment\Task Handler\bootwiz\Configs is empty 
    \Altiris\Altiris Agent\Agents\Deployment\Task Handler\SBS\Images does not have the winpe folder, only the default bstrap.

booting to winpe is off course not working without these files
This is the case on all remote taskservers

seems everything goes fine up until creating the cfg-tmp folder , but then?why is bootwiz not doing with its supposed to, although in the console the recreation is marked as succesfull for all task servers.     where is the specific logging for this process?  bootwiz.log is only logging for creating images.

Thanks

Dries
 

Comments 15 CommentsJump to latest comment

dries_point's picture

the link you posted could be usefull in the future, but it talks about the ghost images, meaning the windows or linux images you create.  this will be synced with a package server. but i am talking about a step before that.

My issue is about the winpe image that is needed in the pre-boot environment

 

I used  in the subject the word "sync" ,  maybe bootwiz.exe does not need to sync but just builds locally the winpe image again based on the info from the NS server where the initial winpe was created...

 

anyways this is not happening, 

 

reading this usefull document now... ( see attachements )

Deployment Solution 7.1 SP1 Architecture & Dataflow (May 18 2012)

AttachmentSize
Deployment Solution 7.1 SP1 Architecture & Dataflow (May 18 2012)[1].pdf 2.2 MB
Mistral's picture

Yes i know the article is not really related to your issue ... but you never know if the package replication onto "itself" (which is true for the deployment share) could break more than this.

It just poped into my mind immediately after i read you have a package server installed on your NS.

 

Mistral's picture

This should be another useful document (esp. again 5.)

http://www.symantec.com/business/support/index?pag...

"NOTE: Your Notification Server(s) do not have Package Services installed by default as recommended, but they are Task Servers, which can cause a problem with Deployment Solution 7.1.  More will be said about this in the "Common Issues" section below."

Thomas Baird's picture

After Bootwiz runs, the images are not left under BootWiz, but are moved to SBS\Images.  This is where the WinPE images are kept.  Once moved, a BAT file is then run to create the .0 file in that location.  This is by design.  The Bootwiz "temp" location is just that - temporary, where we construct everything before moving it to it's permenant location.  The location under SBS Images is shared for TFTP and is not as secure because of this, so we put as little there as possible.

My guess, based on your description, is that it's actually working.  Try PXE booting to see.

 

Please note that these "images" are WinPE / PXE images, not machine images such that you might capture and deploy.  For the latter, Bootwiz has no effect at all.

Thomas Baird
Private Consultant

 

dries_point's picture

ok thank you,

 

the sbs\images on the site server does not contain the winpe files/folder

 

when i test pxe boot i can select winpe to boot but then receive error:

 

pxeprezere: pxe server list format is invalid

 

 

 

 

Thomas Baird's picture

What DOES the images folder contain?

PXE troubleshooting can take many avenues.  For the error you're seeing, we have to first know if you're using DHCP option  66, 67 or not (forced mode in our KB) to point to the .0 file.  If the folders are actually missing, then yeah, you'll get this error.  But if it makes the temp files and does NOT put them in the Images folder, it generally leaves the temp folder.  Something may be deleting them (or someone).  There is likely (not always) a BootWiz log file in the Bootwiz folder that might tell us something as well.

And again, at this point, it's probably easiest to simply call support.  :D  But we'll keep watching.

Thomas Baird
Private Consultant

 

Rajaganesh's picture

You may try repairing the winpe files on the remote PXE server.

Go to \\ <NS Name>\Nscap\bin\win64\x64\deployment\Taskhandler folder

Right click on each msi files and click repair.This will put back the missing files in winpe.

Recreate the winpe and allow the bootwiz to run. Then try the pxe boot.

Additionally you need to make sure that the DHCP scope options (66,67,60 and 43) are set properly as Thomas mentioned in the Previous post.

dries_point's picture

@thomas:   in the sbs\images folder i have only the Bstrap folder and 2 subfolders x86 en x64, in these 2 subfolder a bstrap.0 file

dhcp boot option 66 and 67 was already used    66=pxe server ip   67=BStrap\X86pc\BStrap.0

60,43 are not used, this is for the forced dhcp mode right? i have ip helpers on my cisco switch so i believe this is not necessery.

@rajaganesh i will try your suggestion, thanks.

 

2 general questions that might affect this issue:

1)  my site server is only a task server so far, is it necessary to also be a package server at this moment,  i know its needed to have your windows images replicated

2) how wrong is het to have NS, TS and PS on the same server?

 

FYI:

something i tested yesterday : I copied the winpe files from the main site to the site server and placed them under the SBS\images folder,  when i tested the pxe boot i get past the pxe server list error and received a boot device inaccessable error from the boot manager. this seems to be a step further using the winpe image and proving the boot options work?  only the copied winpe is somehow corrupt, probably you cant just copie it , so i undid this whole action. 

what also was remarkable during this test was that bootwiz.exe did not run anymore after the winpe files were present.(when you update the agent)  Now that the winpe files are gone again bootwiz.exe starts again everytime you update the symantec agent

Mistral's picture

1) Every TS also need DSS and PS installed, or the deployment system will fail in many cases.

The Deployment Automation Agent (PECT) will connect to a TS and download all packages from there, so you need a DSS there (Deployment Site Service) and a PS to replicate all the images/drivers/copyfile...

See the document i linked above again:

"By design, at this time, the assumption is made that when you connect to a Task Server for your Deployment Tasks (ALL deployment tasks are delivered this way), the Task Server will also have the image stored locally, as well as having the Deployment Share for the imaging tools (see the 3rd bullet).  Work is being done to allow more flexibility in your Site Server configuration, but at this time, this is a requirement."

This will change in CMS 7.5 btw.

2) PS on NS might destroy images (and more) ... it is not recommended (so just don't - it does not even make sense as the NS is already a package source). Never remove the TS from NS!

 

dries_point's picture

@Rajaganesh : repairing did not help

@Mistral:

1) ok we will make the TS/DSS also a PS

2) i dubblchecked, our NS is only a TS/DSS not a PS , so we are good there.

 

one more thing ; on the console we tried to make a new winpe to see how it handles this one.

its available in boot menu , but the files itself were also not created, not on the main server and not on the site server,   seems like a bigger problem.

 

i ll contact support

Mistral's picture

Maybe bootwiz fails because the driver packages are not yet replicated (missing PS).

dries_point's picture

ok, support did a webex session,

 

as a workaround we copied the completen SBS/images folder to the site server, winpe is booting now on the site server

they will analyze the bootwiz.log to see why a new winpe in the console is not created on the main server

and probably this is related to the not sync of winpe files to site servers.

Rajaganesh's picture

If the Symantec management agent installed in the D: drive then this could be the issue

http://www.symantec.com/docs/TECH159164

Capturing and Deploying images requires the use of Task Servers and Package Servers.  Though currently you can in fact install PXE services on any Site Server, you will run into problems capturing if your SBS server is not also a Package Server AND Task Server.  All three, currently, must be together for Imaging to work correctly.

See this article : http://www.symantec.com/docs/HOWTO21724
 

 

 

dries_point's picture

This is solved by support,  

 

to generate a new winpe we forgat to activate an OEM environment.

we also reinstalled our site servers immediately with package servers

So i believe for replication of winpe to site servers you need the package server functionality.

 

At this moment we have a new problem about selecting the correct oem environment.

in the console only ADO is available, but in the bootwiz folder structure only DS is present.

I will create a new post

 

thank you all.

 

SOLUTION