Video Screencast Help

Bootwiz.exe not starting when creating Preboot Environments

Created: 20 Jun 2013 | 5 comments

I'm running Altiris Suite 7.1 SP2 MP1.  Whenever I try to create or recreate a Preboot Environment, Bootwiz.exe is not starting up.  I was able to create a PXE Preboot before and it appears in the images folder.  Now whenever I try to create something, Altiris Console tells me it exists but the files don't appear anywhere on my server.  Has anyone run into this before?  I've attempted several other solutions I found in the Symantec forums but nothing has worked so far.  

Thanks!

Operating Systems:

Comments 5 CommentsJump to latest comment

Thomas Baird's picture

Bootwiz will not run until the agent on the site server gets a policy update.  Go to the agent on that site server (or the agent on the NS which is a site server) and force a policy update.  It should get it.  You can even look at the policy file to see if it received the updated policy.

If you're not getting updated policies, there's a bigger problem.

Thomas Baird
Private Consultant

 

bmarshbanks's picture

Where exactly can I find the policy file to make sure the update has been recieved?  I have forced a policy update on my servers and that has not solved the problem so far.  I suspect there is most likely a bigger issue but I just want to make sure.  Would you recommend reinstalling the Deployment Solution if the policy file doesn't show the updates?  Thanks Thomas!

Thomas Baird's picture

client policies are under the agent on the site servers.

 

If BootWiz is not running on the NS, there may be a bootwiz log you can look at.  It's simply called bootwiz.txt.  The registry key to do this is enabled on the NS, but NOT on site servers by default.  Sad tale - it should be.  To turn on BootWiz logging, you can look at HOWTO84000 .  This is because it "sounds" like Bootwiz is running, but failing so you never see it.  Not positive.

 

No, I don't suggest remove/reinstall.

 

The client policy file is the larger of 2 files under program files\altiris\altiris agent\client policies.  In there, you can find sections about each WinPE preboot menu you build, and the status, such as create, delete, etc.

Thomas Baird
Private Consultant

 

bmarshbanks's picture

First off, thanks for helping out!  I really appreciate it.

In the bootwiz log, this is the exit code: Exit code: (20) 20 BDC_EXIT_INVALID_OS_TYPE - Invalid OS type.  There is also a 581 (BDC_ERR_LOAD_LIBRARY) error in the log file.  I wasn't able to find any information about these errors other than what the codes explicitly state.  Based on the time stamps of the log, it looks like Altiris is trying to run Bootwiz to update my configurations pretty much constantly.  Almost as soon as it fails out with that error, it tries again.

I checked the policy and it looks like all the PXE and Automation configurations exist, they just aren't being updated.  The Action Type for all of them are create.  

I hope this information makes sense!

bmarshbanks's picture

I did a little more looking into the log file.  The 581 error seems to be caused because Bootwiz is looking for the following file and it's not there.

D:\Program Files\Altiris\Altiris Agent\Agents\Deployment\Task Handler\Bootwiz\Platforms\WINPE2\wimgapi.dll

Bootwiz also seems to be looking for some language files that don't exist as well.

2013/06/24 07:54:23 D:  CBootWizardApp::LoadLanguageDLL (sBaseName='D:\Program Files\Altiris\Altiris Agent\Agents\Deployment\Task Handler\Bootwiz\BootWiz', sLangCode='en', bShowError=0) - Loading language resources for 'en'
2013/06/24 07:54:23 D:      CBootWizardApp::LoadLanguageDLL - Language resources loaded from 'D:\Program Files\Altiris\Altiris Agent\Agents\Deployment\Task Handler\Bootwiz\BootWiz_en.dll'
2013/06/24 07:54:23 D:  CBootWizardApp::LoadLanguageHelp - Trying to load help file D:\Program Files\Altiris\Altiris Agent\Agents\Deployment\Task Handler\Bootwiz\BootWiz_en.chm
2013/06/24 07:54:23 D:  CBootWizardApp::LoadLanguageHelp - Trying to load help file D:\Program Files\Altiris\Altiris Agent\Agents\Deployment\Task Handler\Bootwiz\BootWiz.chm
2013/06/24 07:54:23 D:  CBootWizardApp::LoadLanguageHelp - Trying to load help file D:\Program Files\Altiris\Altiris Agent\Agents\Deployment\Task Handler\Bootwiz\BDC_en.chm
2013/06/24 07:54:23 D:  CBootWizardApp::LoadLanguageHelp - Trying to load help file D:\Program Files\Altiris\Altiris Agent\Agents\Deployment\Task Handler\Bootwiz\BDC.chm
2013/06/24 07:54:23 I:  CBootWizardApp::InitInstance - call to LoadLanguage failed

And finally I found these lines, I'm not sure if they are relevant.

 
2013/06/24 07:54:23 I: .-CPlatforms::InitPlatforms - Platform count=8
2013/06/24 07:54:23 I: .     LINUX_X86       (LINUX>LINUX>LINUXPE-X86)         Status=NotInstalled   Ini='D:\Program Files\Altiris\Altiris Agent\Agents\Deployment\Task Handler\Bootwiz\Platforms\linuxx86.ini'
2013/06/24 07:54:23 I: .     LINUX_X64       (LINUX>LINUX>LINUXPE-X64)         Status=NotInstalled   Ini='D:\Program Files\Altiris\Altiris Agent\Agents\Deployment\Task Handler\Bootwiz\Platforms\linuxx64.ini'
2013/06/24 07:54:23 I: .     WINPE21_X86     (WINPE>WINPE2>WINPE21-X86)        Status=NotAvailable   Ini='D:\Program Files\Altiris\Altiris Agent\Agents\Deployment\Task Handler\Bootwiz\Platforms\WinPe2X86.ini'
2013/06/24 07:54:23 I: .     WINPE21_X64     (WINPE>WINPE2>WINPE21-X64)        Status=NotAvailable   Ini='D:\Program Files\Altiris\Altiris Agent\Agents\Deployment\Task Handler\Bootwiz\Platforms\WinPe2X64.ini'
2013/06/24 07:54:23 I: .     LINPROD_X86     (LINPROD>LINPROD>LINPROD-X86)     Status=NotAvailable   Ini='D:\Program Files\Altiris\Altiris Agent\Agents\Deployment\Task Handler\Bootwiz\Platforms\LinX86.ini'
2013/06/24 07:54:23 I: .     LINPROD_X64     (LINPROD>LINPROD>LINPROD-X64)     Status=NotAvailable   Ini='D:\Program Files\Altiris\Altiris Agent\Agents\Deployment\Task Handler\Bootwiz\Platforms\LinX64.ini'
2013/06/24 07:54:23 I: .     WINDOWS_X86     (WINDOWS>WINDOWS>WINDOWS-X86)     Status=NotAvailable   Ini='D:\Program Files\Altiris\Altiris Agent\Agents\Deployment\Task Handler\Bootwiz\Platforms\WinX86.ini'
2013/06/24 07:54:23 I: .     WINDOWS_X64     (WINDOWS>WINDOWS>WINDOWS-X64)     Status=NotAvailable   Ini='D:\Program Files\Altiris\Altiris Agent\Agents\Deployment\Task Handler\Bootwiz\Platforms\WinX64.ini'
2013/06/24 07:54:23 I: .-CPlatforms::InitPlatforms - Hidden platform count=0
2013/06/24 07:54:23 I: .<CPlatforms::InitPlatforms - returning 1 (success = 1)