Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

bpcd listening but nt functioning properly.

Created: 01 Feb 2013 • Updated: 06 Feb 2013 | 5 comments
This issue has been solved. See solution.

Hi Experts,

Please help me here to resolve the issue...

 

 

Master /Media -AIX-7.0.1

Client:Red hat

when trying to telnet the client  from media server getting below error.

Trying...
Connected to xxxxx.
Escape character is '^]'.
 

: error while loading shared libraries: /usr/openv/lib/libnbmangle.so: cannot restore segment prot after reloc: Permission denied
Connection closed.
 

1)ping and rev ping are working fine

2)nslookup and rev lookup working fine.

3)bpgetconfig -g from media server--

socket write failed

Discussion Filed Under:

Comments 5 CommentsJump to latest comment

Barbaros Kilic's picture

Hi,

your media server has many interfaces?

Pls from MS ; traceroute <client IP > and then

according to result IP, ıs that ip at client host file?

Barbaros Kilic

RamNagalla's picture

hi Srivani,

I remember its due to some pack in Linux client , when i had this issue.. 

please get the bpcd log..

there is some pack or package that needs to remove in Linux client.

please post the bpcd log.

EDIT

what is your Netbackup version in Lunix?

I just find this, may be related..

http://www.symantec.com/business/support/index?pag...

SOLUTION
Marianne's picture

See these TNs:

http://www.symantec.com/docs/TECH58689

http://www.symantec.com/docs/TECH156342

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Stumpr2's picture

/etc/xinetd.d we need to confirm if there are files bpcd & vnetd

these files have the script for the path for bpcd and vnetd 

# Service bpcd for NetBackup
service bpcd
{
        socket_type = stream
        protocol = tcp
        wait = no
        user = root
        server = /usr/openv/netbackup/bin/bpcd
        disable = no

}
 

service vnetd
{
        socket_type = stream
        protocol = tcp
        wait = no
        user = root
        server = /usr/openv/bin/vnetd <-- NOTE netbackup is missing
        disable = no
        instances = UNLIMITED
        cps = 1000 1

}

 

VERITAS ain't it the truth?

sri vani's picture

Solution:

On the system in question, run the following commands as root to enabled proper access to the necessary libraries:

chcon -t textrel_shlib_t /usr/openv/lib/libnbmangle.so
chcon -t textrel_shlib_t /usr/openv/lib/libvxPBXCommon.so
chcon -t textrel_shlib_t /usr/openv/lib/libvxPBX.so
chcon -t textrel_shlib_t /usr/openv/lib/libvxPBXVxSS.so
chcon -t textrel_shlib_t /usr/openv/lib/libvxVxSSIOP.so
chcon -t textrel_shlib_t /usr/openv/lib/libnbservice.so

Then stop and start xinetd.

/etc/init.d/xinetd stop
/etc/init.d/xinetd start