Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

bpsetconfig to delete an entry

Created: 09 Oct 2012 • Updated: 31 Dec 2012 | 10 comments
This issue has been solved. See solution.

Hello to everybody,

I need your help..  I would to delete an entry into bp.conf file on a lot of unix hosts.

Is it possible using the "bpsetconfig" ? or with this command i can only add/update a "new" configuration ?

In this last case how can i delete this entry?

bp.conf before:

CLIENT_READ_TIMEOUT = 1800
LIST_FILES_TIMEOUT = 1800
Buffer_Size = 256
 

bp.con after:

CLIENT_READ_TIMEOUT = 1800
LIST_FILES_TIMEOUT = 1800
 

 Many thanks to everybody

R.

Comments 10 CommentsJump to latest comment

Marianne's picture

I cannot find any reference to Buffer_Size as being a valid bp.conf entry.
Seems you will have to manually edit client's bp.conf to remove this entry.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Andy Welburn's picture

It seems that the entry "Buffer_Size = 256" *is* a valid entry in-so-much as bpsetconfig *will* allow you to add that value into the bp.conf of a client (tried other spurious entries which *did not*).

Did a little testing & it is a straight-forward *fix*

Using a file myfile.lis with an entry of Buffer_Size = 256 the following command updated the bp.conf of the client with that entry:

bpsetconfig -h client <path-to-file>/myfile.lis

Changing the entry in bpconf.lis to Buffer_Size = & re-running the same command removes the entry from the bp.conf on the client.

Just script it if you've more than a handful of clients to amend.

SOLUTION
spillo1981's picture

Hello,

i tried with your suggestion but unfortunately the problem persist. I think that the only solution is to delete manually the entry into each bp.conf

Andy Welburn's picture

Curious in that I managed to get it to work.

Any format or typos issues in your "Buffer_Size =" entry? That's the only reason I can think of at the moment why it doesn't work.

spillo1981's picture

I tried with

Buffer_size = "

Buffer_size = ""

#Buffer_size =

whit the same result.. The entry is still present..

Marianne's picture

Seems Andy had success with:
Buffer_Size =

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

spillo1981's picture

With this entry

Buffer_Size =   

the entry is deleted if the target host is a windows server... but it doesn't work with unix server ( in my case Linux RH and AIX server.. )  the parameter become "0"

It is very strange..

Andy Welburn's picture

As you say, strange.

Just tried: Master - Solaris 9 -> Client RHEL without issue (previously Solaris9 -> Solaris 10)

NB6.5.6 throughout (sssshh, keep *that* quiet!)

spillo1981's picture

Nothing..

I tried with a linux and an Aix O.S. but the entry Buffer_Size become = 0

Andy Welburn's picture

That's unfortunate.

Looks like you'll have to do it 'long-hand' then ......