Video Screencast Help

Breaking Hierarchy for solving replication problems?

Created: 07 Apr 2014 • Updated: 10 Apr 2014 | 10 comments
This issue has been solved. See solution.

Hi,

Since upgrading from 7.1 to 7.5 I seem to have problems with the differential and complete replication. The "Replicate now" is working fine. Does anyone have expirience with breaking the hierarchy and recreating it for solving problems with replication. Any issues wich could occur when removing child NSs?

I am thankful for any kind of inputs!

Stefan

Operating Systems:

Comments 10 CommentsJump to latest comment

Igor Perevozchikov's picture

Hi,

what exact problem you have with replications?

If you will break hierarchy and then re-recreate it back, then it will doesn't solve, because all previouslly performed replication(s) information is stored in replication SQL tables on parent and on chils NS SQL Servers.

Such SQL tables, like "ReplicationItem" and "ReplicationItemDependencies".

 

Thanks,

IP.

iddqd idkfa idclip

Stefan S.'s picture

Thanks that is what I thougt. I was suggested this step by a guy from support.

The problem I have is that all "custom" items do no longer get replicated with neither full nor differential. Also the report which can be found in the "hierarchy mangement" under custom does not show any items.

So I was thinking i would require some kind of database clean-up script instead.

The report itself fails with the error "Failed to generate the hierarchy replication code report". And further down in the logs it says "SQL Exception details: code=8169, line=10, procedure=spGetTree3.

I have by the way reported back that error including logs to the support guy... waiting for and answer.

Igor Perevozchikov's picture

First, you've talked about a problem with replication functionality, therefore breaking and re-creating hierarchy nodes don't solve this problem with replication functionaliy.

But now you're talking about "custom items" aren't replicated due errors.

Did you try to replicate your "custom item", using stand-alone replication rule? Will same problem occurs?

Stand-aloneReplication.jpg

Stand-aloneReplication2.jpg

Thanks,

IP.

iddqd idkfa idclip

Stefan S.'s picture

Actually the main question you have already answered. Does the breaking and recreating fix my replication issue? And your answer was NO. That is the same what I thought. Now that this is confirmed I do not have to waste my time on trying that....

However as I said I still have a problem. What I meant with was the following:

hierarchy.JPG

In the replication settings i have configured "Custom" that I am able to select items individually. For example I have enabled the folder with all my Managed Software Delivery policies for replication. Once enabled they should be replicated with the "differential" and "full" replication schedule. However it seems like since upgrading from 7.1 to 7.5 this has stopped working. This is the main problem.

When I was suggested the "solution" with breaking and recreating the hierarchy I was thinking I need to know which items are enabled for replication to be able to reconfigure the items in case this information gets lost during the recreation of hierarchy. Therefore I thought the report "Review the current Item replication report" is the one to look at but this is the one which always comes back empty. Not even an error is show in the web console. However there is the error mentioned above in the SMP logs... So I thought that is maybe a starting point....

"Replicate Now" and "Standalone replication" seems to be functioning normal.

Igor Perevozchikov's picture

Hi Stefan,

And your Parent and Child SMP Servers have latest same version 7.5 and other solutions, such as Software Management solution on SMP servers also have latest same version 7.5.

Could you please attach SMP logs, where you're seeing errors?

Thank you!

iddqd idkfa idclip

Igor Perevozchikov's picture

Stefan, could you please collect "Altiris profiler" logs.

Open Altiris Profiler ⇒ Start profiling ⇒ Reproduce your problem ⇒ Stop profiling and save all collected profiler logs and send to me.

Profiler_7_5.jpg

 

Thank you!

iddqd idkfa idclip

Stefan S.'s picture

I forgot to mention I am running 7.5 HF3 on parent and all child NSs. Upgrade was done from 7.1 SP2 MP1 Rollup v6.

Igor Perevozchikov's picture

Hi Stefan,

I've sent solution and details about this problem via mail. Let know if problem will be fixed on your environment.

Thanks,

IP.
 

iddqd idkfa idclip

SOLUTION