Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

BSOD 0xD3 with SWV 7.5 SP1

Created: 16 May 2014 • Updated: 16 May 2014 | 5 comments

After updating SWV to 7.5 SP1 I got a BSOD 0xD3:
Bug Check 0xD3: DRIVER_PORTION_MUST_BE_NONPAGED
0x8D79A770, 2, 1, 0x846A327B

System: Windows 7 SP1, 32 bit

It happens even with no layer beeing activated at system start.
The system does not generate a memory dump.
It's reproducible.
It still is present after reinstallation of SWV.

Workaround I found:
sc config fslx start= demand
fslx seems to get started by vzservice.

The description at [1],
"This bug check is usually caused by drivers that have incorrectly marked their own code or data as pageable."
seems to be not convenient in this case. The bug check seems to be triggered as a side effect.
[1] http://msdn.microsoft.com/en-us/library/windows/ha...
The installer sets
sc config fslx start= boot
and this works on a different installation (same system type).

How can this supposed side effect happen?
What is a clean solution?

Ueli

 

Operating Systems:

Comments 5 CommentsJump to latest comment

Ueli's picture

After MANY hours of

- driver analysis to find possible incompatibilities
- kernel debugging
- comparing and adjusting parameters under the registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\FSLX\Parameters\FSL

I conclude:
It must be SWV itself which produces a BSOD 0xD3 at boot.

The working reference implementation of Win7 (virtual machine) has:

PROFILESDIRECTORY=C:\Users

ExcludePaths=
0x0002    [_B_]DESKTOP[_E_]
0x0002    [_B_]PERSONAL[_E_]

The failing implementation of Win7 had:

PROFILESDIRECTORY=H:\Users1

and ExcludePaths with some additional existing volume, eg. =
0x0002    H:\
0x0002    [_B_]DESKTOP[_E_]
0x0002    [_B_]PERSONAL[_E_]

After setting both values to the same data as in the reference implementation the tested implementation worked. (Setting one value only is not sufficient.)

This is no real solution because

- the profiles directory actually is H:\Users1 and the value was set by the installer of SWV
- no additional exclude path can be set but I would like to exclude every volume
- even with wrong parameters the BSOD should not happen

This was tested with existing C:\Users and with entering "H:\" with the GUI (SWV Admin) to get the right syntax.

Could someone confirm this or provide contradicting evidence?

Ueli

balachandar_manimala's picture
Hello,

Could you please provide exact repro steps to replicate this issue in-house so that we can start working on it?

Also please add the build number from which you upgraded to 7.5_SP1.

Regards,

Bala
Ueli's picture

Hello Bala

From Dec 17 2013 on I had the error described in
http://www.symantec.com/connect/forums/any-active-... ,
in the case here with Windows Defender.

Because of that I updated from SWV 6.4 to 7.5 and then tried every new HF of 7.5 I found.
Note that in retrospect it looks simple but actually it took me a long time to find out at all that the Defender problem was due to SWV.
I also deactivated and reactivated the service fslx several times.
A further problem is mentioned at the end.

Try to reproduce like this:

1
Win7 32 bit installation in VirtualBox, on VHD with ~25 GB.
3 partitions:
<no letter>, 100 MB, System-reserviert
C:, 24.0 GB, Win7_32
H:, 0.99 GB, Volume
all formatted as NTFS

3.86 GB free on C:
1.00 GB pagefile.sys
Programme und Funktionen reports 59 programs
1024 MB RAM in VirtualBox

2
uninstall Symantec Workspace Virtualization Agent

3
reboot

4
delete
HKEY_LOCAL_MACHINE\SOFTWARE\Symantec
C:\fslrdr

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\FSLX doesn't exist at this moment.
Otherwise delete it also.

5
install Symantec Workspace Virtualization 7.5 SP1 (7.5.749)
(Symantec_Workspace_Virtualization.exe in Symantec_Workspace_Virtualization_7.5_SP1_ML_win.zip)
with option
+Symantec Workspace Virtualizationi Admin Tool

6
reboot
->success

now you find:
C:\fslrdr
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\FSLX
with
ExcludePaths=
0x0002    [_B_]DESKTOP[_E_]
0x0002    [_B_]PERSONAL[_E_]

7
add with GUI global exclusion H: with subdirectories
This sets
ExcludePaths=
0x0002    H:\
0x0002    [_B_]DESKTOP[_E_]
0x0002    [_B_]PERSONAL[_E_]

8
reboot
->BSOD 0xD3, fslx.sys

further problem:
At least on one installation I often have long periods of 100 % CPU load, with explorer.exe as cause, and very annoying slowdown of the user interface.
I don't know how far this is due to fslx but everytime I deactivated fslx the problem was immediately gone.

Regards
Ueli
 

balachandar_manimala's picture

Hello Ueli,

Thanks for the message. We have been able to reproduce this issue and are working on fixing it.

We will keep you posted as we make progress.

Regards,

Bala

balachandar_manimala's picture

“Symantec Workspace Virtualization and Symantec Workspace Streaming 7.5 SP1 HF1” is now GA.