Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Building Block SQL mirror failover - Event ID:13397

Created: 10 Sep 2013 • Updated: 13 Sep 2013 | 8 comments
This issue has been solved. See solution.

Guys,

I have installed EV building block set up for MBX and FSA using EV 10.04 on Server 2008 R2 and SQL server 2008. The solution spread across two sites with 3 x EV and a SQL servers in PRI and 3 x EV servers and a SQL server in DR. We have set up database mirrorring bewteen PRI and DR. Each server is using its Alias including SQL servers.

PRI
SQLServer1.myDomain.com
myEVServer1.myDomain.com       [MBX]
myEVServer2.myDomain.com       [FSA]

DR
SQLServer2.myDomain.com
myEVServer3.myDomain.com      [MBX]
myEVServer4.myDomain.com      [FSA]

Aliases
evSQLServer -> sqlserver1.myDomain.com
evserver1 -> myevserver1.myDomain.com
evserver2 -> myevserver2.myDomain.com

TEST 1 -- We failover the SQL server using SQL Manager by making the mirrored copy the PRI copy, change the Alias of evSQLServer -> sqlserver2.myDomain.com, change DNS alias for EV servers (as above) and run USL. USL completed successfully.The below error is noticed on every active EV server priodically.

The connection 'Provider=SQLOLEDB;Server=A-SANIA;Database=EVVSGLASVSG01_1_1;Integrated Security=SSPI' was lost and the system is waiting to reconnect (Thread Id: 8852)

Server=A-SANIA           [actual name of PROD SQL server].

When user access the Mailbox archives (VV & VC enabled), archive search and item recall is works OK. When user access the FSA archives, the items either remain in the initialising state (fails eventually) OR error appears saying the file can not be opened. I have notied RPC server not available errors for storage service under EV FSA windows event viewer.

TEST 2 -- Then I failed back the SQL mirrorring to PROD, leaving both the active EV servers in DR, restart the EV services on all active EV servers and accessed File system archives, same failure as above. Mailbox archives works with NO issues.

TEST 3 -- With SQL remain in PROD, I brought back EV FSA only, leaving EV MBX server in DR . Restart the EV services on all active EV servers, access File system archives, all works with no issues.

TEST 4 -- What I have NOT tested is keeping both EV and FSA in PROD with Failover SQL mirrorring (to DR).

I am slightly confused where does the problem lie..on DR SQL box or DR EV FSA server?

Any suggestions and hints are highly appreciated...

Operating Systems:

Comments 8 CommentsJump to latest comment

Pradeep_Papnai's picture

The configuration which you are using for EV+SQL building blocks looks good.

After EV + SQL failover to DR site, you mentioned USL ran successfully which mean we had connectivity with EV directory database of DR SQL server & mailbox archivig/retriving was working fine.

There is connectivity warning only for FSA database. Again when you move SQL back to original site, EV functionality was working but FSA database warning still there.

What it looks to be issue with any tempoarily accessiblity problem with FSA database NOT to the entire configuration.

Can you check if you have SQL DSN difference in PROD & DR FS archiving server. In DR FS server, follow the steps mention in TN http://www.symantec.com/docs/TECH48664

And repeat your test.
 

Itegral's picture

I am going to check whether there is any SQL DSN difference in PROD & DR FSA. However, its worth mentioning that when I take properties of VSG - it shows PROD SQL server name rather Alias but VS shows SQL Alias.

I checked the same on VAC properties, it shows SQL Alias. Also, "HKEY_LOCAL_MACHINE\SOFTWARE\KVS\Enterprise Vault\Directory\DirectoryService" Key for the value in "SQLServer Name" shows SQL Alias.

Could that be an issue?

Pradeep_Papnai's picture

Good catch & Thanks for update. The directory database & VS stores are correctly pointing to correct SQL alias but NOT VSG database. May be you can you look at tech note & update it correct SQL alias http://www.symantec.com/docs/TECH64655
 and then test failover again.

SOLUTION
Itegral's picture

The SQL DSN is empty on PROD and DR...

Reading your above comment, you said "connectivity warning only for FSA database" - why did you say that??

The warning is generic for Database=EVVSGLASVSG01_1_1 pointing towards physical name of the PROD SQL server not the alias. The same warning appearing on DR EV Mailbox server as well but that is working fine.

When I try open shortcut from the file server, it doesnt open and leaves events on EV FSA server like events 6654, 6655, 6656

Reason: The RPC server is unavailable. (0x800706ba).

The event "

'Provider=SQLOLEDB;Server=HQ-TANIA;Database=EVVSGLASVSG01_1_1;Integrated Security=SSPI' was lost and the system is waiting to reconnect (Thread Id: 3668)" appearing every 5 min on BOTH EV servers[FSA and MBX].

where is it picking up the actual name of the SQL server not ALIAS in the event viewer??

 

Itegral's picture

I have run the FSA archiving task on the DR server with DR SQL and its processing for good 15min. Before that it used to just finish off quickly. What possibily could it be doing?

Pradeep_Papnai's picture

Oh!, I initially thought the datbase is for FSA, but later realize it is VSG as it's name indicate.

Is your VAC still prod SQL server instead of alias SQL name for VSG? and Can you check 32 BIT DSN (%systemdrive%\Windows\SysWoW64\Odbcad32.exe) TN http://www.symantec.com/docs/TECH75498

Lastly you have mentioned FSA archiving task is working for 15 minutes? Is it working without making any changes? Do you still error 13397 while connecting to SQL VSG database?
 

Itegral's picture

Fingerprint Database script resolved the issue. Thanks for your help!!

Pradeep_Papnai's picture

Glad to hear that your issue is solved :)