Video Screencast Help
Scheduled Maintenance: Symantec Connect is scheduled to be down Saturday, April 19 from 10am to 2pm Pacific Standard Time (GMT: 5pm to 9pm) for server migration and upgrade.
Please accept our apologies in advance for any inconvenience this might cause.

CA client search Attachment critaia

Created: 03 Apr 2013 • Updated: 03 Jun 2013 | 16 comments
This issue has been solved. See solution.

In the old version, the attachements Number we use -1 to set the schedule scheule no matter have attachment or not

However we just discover the result are different if we use the attachement numbers "Does not matter"

Any Idea? Is it due to we upgrade the version from version 8 and version 10??

Operating Systems:

Comments 16 CommentsJump to latest comment

Kenneth Adams's picture

Kenneth,

By default, CA searches don't care if a message has any attachments.  You should not have needed to specify anything in the Attachments portion of the CA search criteria.  Can you provide examples of a search from CA 8 and CA 10 to point out the differences?

As far at the search criteria usage goes, there has been no change in the Attachments portion since CA 6 days, with the exception of an issue that started with 8.0.0 where the number of attachments in some configurations was limited to 3 or 6 characters in stead of the 9 characters from pre-8.0 version.  That has been fixed and the 9 character limit is back in CA 10.

 

Ken Adams

Backline Support for CA, DA, ACE, UCE, PSTD, ARMS, EVDC
US Support Region

Kenneth Yeung's picture

In the CA search, we can specific we the email we monitor have attachement or not

Attach the screen capture for you.

In the verison 8 , that is bug, if we scheulde search and the critiea have attament and the attachement size >0, it will auto change back to '0'

Not sure is it similar issue in version 10

attachement.gif
Kenneth Adams's picture

Kenneth,

The screen shot only shows the "Does not matter" option.  Do you also specify any specific message size that gets the size specification set back to 0?  I'm trying to understand what you are telling me with your comment "it will auto change back to '0'.  What automatically changes back to '0'?

 

Ken Adams

Backline Support for CA, DA, ACE, UCE, PSTD, ARMS, EVDC
US Support Region

Kenneth Yeung's picture

Hi Kenneth,

Currently ,  same setting location but the number is '-1' , i think those schedule criteria was from upgraded version 8.

Not sure value -1 mean what

Kenneth Adams's picture

Kenneth,

Where are you seeing the -1?  Looking at my CA 10.0.3 lab's New Search screen, I don't see a -1 anywhere in any of the available, default options.  When looking in the Attachments section, the default is "Does not matter", with the 'File extensions' field containing the following grayed out information that is not used in searches:

e.g. .htm .xls

None of the other criteria fields have any number, including -1, specified.

Ken

 

Ken Adams

Backline Support for CA, DA, ACE, UCE, PSTD, ARMS, EVDC
US Support Region

Kenneth Yeung's picture

Hi Kenneth,

Is it possible we change the setting from SQL backend? So user dont need to create new search

Kenneth Yeung's picture

That is the problem, because in the version 8 , it allow us to input '-1'

but after upgrade, we cannot do it. but it didnt heltp us convert from '-1' to Does not mattter.

Not sure any impact , if we want to change from '-1' to Does not matter, it need us to create a schedule search

TonySterling's picture

Why do you want -1 to be entered here?  What is the purpose?

Kenneth Yeung's picture

THe -1 is a workaround in version 8, at that time, CA have a bug, if we choose have attachment > 0 in schedule search it will make it roll back to 0, so at that time , I forgot is the production manager tell this workaround or from Symantec UK tell the compliance dept to use -1 to do it first

But aftr we upgrade into version 10, the '-1' value seem to accpetable, and recently, we found out that

some old schedule search ,  will miss some email, unless we use does not matter. So now, I think we just want a simple way to change the vaule from -1 to Does Not Matter,(we have around 100 schedule search)

TonySterling's picture

Ah, ok.  Unless support would provide a way to do en masse I think you would have to change the searches manually. 

You might want to open a case with Symantec to see if a workaround exists already.

Kenneth Yeung's picture

The support said this is not product broken and no simply way to update the search, have to recreate those scheudle search 1 by 1.

That's why I am asking here to see any one know how to change the SQL value and make it happen

TonySterling's picture

I can't think of a supported way to change the paramerters of the search.  If you were able to update your search criteria it would invalidate your reports.

Sorry, but looks like you will need to recreate them.

Kenneth Adams's picture

Tony is correct, Kenneth.  Changing the search criteria through SQL table content manipulation invalidates teh data for your reports.  As such, we don't support any such data manipulation.  Sorry, but you will have to recreate those searches - not the schedules, just the searches.

 

Ken Adams

Backline Support for CA, DA, ACE, UCE, PSTD, ARMS, EVDC
US Support Region

Kenneth Yeung's picture

Thank, but when I try to create a new scheudle search , and choose the attachment size greater than 1, after I save it, it will change back greater than 0,

Is it the bug?

 

TonySterling's picture

For that you will want to contact support so they can verify what is going on and if necessary get a defect logged.

SOLUTION
Kenneth Adams's picture

Update on this issue:

Kenneth did log a case with Symantec.  Upon investigation, we found the issue had already been defected by Kenneth while on 8.0.4.  The fix is in 10.0.3.  TECH177471 will be out in the next few days with the appropriate information for this issue.

Ken Adams

Backline Support for CA, DA, ACE, UCE, PSTD, ARMS, EVDC
US Support Region