Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Caching User Names in EV Cache Mode

Created: 04 Jul 2011 • Updated: 06 Jul 2011 | 9 comments
Rick Grigg at Matrix's picture
This issue has been solved. See solution.

Does anyone know if it's possible to have user names cached in EV for synchronization?  In other words, can someone tell me if there is a way to have user names cached so that when a synchronization in version 9.02 is about to begin, the user would only have to input thier password?

I believe the answer is "no" since the prompt is not coming from Exchange but just wondered if anyone has been able to work this out.

Thanks!

Rick Grigg

Comments 9 CommentsJump to latest comment

JesusWept3's picture

Are you talking about synchronization of vault cache from outlook?

Rob.Wilcox's picture

VC synch will "normally" use the logged in user credentials, AFAIK... depending on whether the EV server has been added to the local intranet zone (by policy or otherwise).

Are you users logged in as non-domain accounts?  I mean what's the context of the request?

JesusWept3's picture

Lots and lots of people are reporting that the VC aspx files are requesting authentication and that the fix given by Microsoft is to remove Basic Authentication from those aspx files so the only with method is IWA

Rob.Wilcox's picture

I have basic + integrated checked on my Enterprise Vault virtual directory in IIS on Windows 2003, and don't get prompted for credentials when synchronising for Windows XP, or Windows 7 as a domain user account.

I do have this set though :

JesusWept3's picture

Rob
I ujderstand this and it's the default configuration and for most people including myself that works
However there have been a number of posts on these forums where the VC syncs always cause a prompt for username and password where as download/clientaction/searcho2k etc all work flawlessly

Like I mentioned, another user on this forum gave up and called ms and found that for those pages they had to remove basic authentication, and it worked

Most people go through the technote about un/pw prompts and the first thing is always intranet zone stuff

SOLUTION
Rick Grigg at Matrix's picture

Thanks kindly for the responses everyone!  Greatly appreciated!!

To answer some of the questions that were posted on this;

 - Users that are working with EV Cache Mode are being prompted for their credentials - once per session (expected behaviour)

- This client would like to have the user name and domain name already filled in by the system so that the users would not have to know that thier name and domain is required for proper authentication.  (the client is using 3 domains so domain names are required as part of the authentication process)

- Not looking to have the passwords cached (obviously), just the user names - i.e.:  domain_name\user_name

At any rate, I have the answer I was looking for and thanks again everyone for stepping up on this one!  Greatly appreciated !!

Rick Grigg

R Meeker's picture

I have seen a user with SSL on their EV IIS which causes VC to fail synch, reports "the certificate authority that generated the server's certificate is not recognised". upgrading to xpsp3 from xpsp2 resolved this, no root cause.

If you install fiddler V2 with SSL packet diagnostics it installs it's own certificate and when this is done XP SP2 clients are then able to synch their VC. Which I thought pointed to a Certificate issue, but since finding that an updgrade to XP sp3 resolved it I am slightly lost.

**apologies, comment might be off subject**

Rob.Wilcox's picture

I *guess* your certificate isn't from a trusted source?  Or..  your certificate is installed against the computer name, not it's FQDN?

Rob.Wilcox's picture

Well, I'd like to try to understand which configurations have this problem so that we adjust our documentation at least.

For example, I have a proxy server setup in my IE settings.. and I get prompted all the time now....