Video Screencast Help

Can I change the SQL port from 1433 to something else?

Created: 15 Aug 2012 | 5 comments

Hello all,

I've been running my SEPM's so that they are configured to communicate with my SQL server on port 1433. Now we getting a new 2008 server and the DBA's would like us to use a port other than 1433.

Is there a supported process for changing the SQL communication port across all my SEPM's?

I tried to just re-run the Management Server Configuration Wizard and specify the new port, but I got an error about the SEPM not being able to create the database.

Any suggestions would be most appreciated,

-Mike

P.S. I have v11 and v12.1 SEPM's reporting to the same database...in case the process is different.

Comments 5 CommentsJump to latest comment

sandra.g's picture

The SQL Server is remote to the SEPM, yes?

Just off the top of my head: Was the port already changed on the SQL server to the new port when you run the Management Server Configuration Wizard? If you did change that SQL Server port, was the SQL Server service then restarted? I didn't find a process document, but I found this troubleshooting KB. It does say 11.0 for category, but I don't think database communications are that different between the 11.x and 12.1. Obviously make adjustments for your version of SQL Server, too. http://www.symantec.com/docs/TECH95721

I have v11 and v12.1 SEPM's reporting to the same database...in case the process is different.

I hope you mean database server, as the database schema are very different between 11.x and 12.1 :)

sandra

Symantec, Information Developer
Installation, Migration, Deployment and Patching
User Protection & Productivity, Endpoint Protection

Don't forget to mark your thread as 'solved' with the answer that best help

iamadmin's picture

Hi Sandra,

 

Yes, the SQL 2008 server is on a totally different box.

Yes, the port was already changed on the SQL server before I attempted to run the Configuration Wizard.

Is the SQL server service you're speaking of on the SQL server, or on the SEPM? I restarted the SEMSRV on the SEPM. Unknown what the DBA did on the SQL server.

I will check out the DOC, thanks!

11 and 12.1 are on the same server, different instance. SEM5 for v11 and SEM12 for v12.1

Thanks for the reply!!

-Mike

_Brian's picture

Yes, shouldn't be a problem. We also use a different port than 1433.

Ashish-Sharma's picture

The default port is typically 1433. You specify this port number when you create the database.

Best Practices guide for Installing the Symantec Endpoint Protection Manager with a SQL Server 2005 Database

http://www.symantec.com/business/support/index?page=content&id=TECH104405

Thanks In Advance

Ashish Sharma

 

 

Chetan Savade's picture

Hi,

I think you should repair SQL database & after that try to run management server configuration wizard.

Let me know if helped.

 

Chetan Savade
Technical Support Engineer, Endpoint Security
Enterprise Technical Support
CCNA | CCNP | MCSE | SCTS |

Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.<