Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Can we define the SMTP server port number in Servicedesk 7??

Created: 28 Apr 2010 • Updated: 30 Oct 2010 | 5 comments
naresh.gokara's picture

Can we define the SMTP server Port number in Servicedesk 7?? we are using it on POrt 2525, so we want to change the port number. Any Ideas...??

Comments 5 CommentsJump to latest comment

Bondo's picture

The spot to configure the port should be right under the spot where you configure the smtp server but it is not.  You need to make a small change to a Workflow.

Open the SD.EmailServices project
Open the Primary Model
Search for the Send Email component - you will find it close to the bottom of the model
Switch to the email Settings tab and change your port to 2525
Save the project and publish to the server

Let me know if you have any problems.

-Bondo

naresh.gokara's picture

Hi Bondo,

Thanks for the Help.. I have tried changing the port number in SD.Emailservices Project, but still I am not able to send Email notifications.. I have specified the SMTP server address and admin email settings console> Master Settings>Email Settings... please let me know if any further configuration needs to be done or if i miss any thing.

Thanks in Advance.

Regards,
Naresh 

Bondo's picture

Did you publish the workflow after you made the changes to SD.Emailservices?  You may need to restart IIS after publishing as well.  If you haven't published a workflow before let me know and I can write something up for you.

naresh.gokara's picture

Yes Bondo... I have published the project and also i have restarted the IIS.. still the same issue.. more over... when ever I am trying to Submit a request/Incident, Its filling the logs with hell lot of errors... Here is one FYR...

Application Name: SD.DataServices
Process ID: 3592
Date :Apr-30-2010 06:30:40 PM
Log Level :Error
Log Category :LogicBase.Components.Default.Logging.CreateLogEntryComponent
Machine Name: SERVICEDESK
Message:
User Search failed with the following: Could not read in object   System.Exception: Could not read in object ---> LogicBase.Framework.ObjectDeserializationError: could not deserialize: System.Collections.ArrayList ---> System.Exception: could not find type SD.Components.NotificationServer7Reports.GetAllLocationsComponent at LogicBase.Framework.ArrayListTypeConverter.GetObject(ObjectStorageContainer storageContainer, ObjectStorageObjectData values, Type valueType, ObjectStorageErrorHandler errorHandler) at LogicBase.Framework.ObjectReadStream.ReadRelationshipConverter(ObjectStorageValue objValue, Type type, ObjectStorageRelationshipTypeConverter converter) --- End of inner exception stack trace --- at LogicBase.Framework.ObjectReadStream.ReadRelationshipConverter(ObjectStorageValue objValue, Type type, ObjectStorageRelationshipTypeConverter converter) at LogicBase.Framework.ObjectReadStream.ReadConverter(ObjectStorageValue objValue, Type type, ObjectStorageTypeConverter converter) at LogicBase.Framework.ObjectReadStream.ReadValue(ObjectStorageValue objValue, Type type) at LogicBase.Framework.ObjectReadStream.GetValue(String name, Type type) at LogicBase.Framework.ObjectReadStream.GetValue[T](String name) at LogicBase.Core.Models.AbstractComponentModel.ReadFromStream(ObjectReadStream info) at LogicBase.Framework.ObjectStorage.Deserialize(ObjectStorageContainer storageContainer) at LogicBase.Framework.ObjectStorage.Deserialize(FileInfo fromFile) --- End of inner exception stack trace --- at LogicBase.Framework.ObjectStorage.Deserialize(FileInfo fromFile) at LogicBase.Core.AbstractOrchestrationProject.GetComponentModelPrivate(Model model, Type componentModelType) at LogicBase.Core.ExecutionEngine.EndComponentExecutionDelegate.Execute(IData data, IOrchestrationComponent comp, String& outputPath, IExecutionEngine engine, TLExecutionContext context) at LogicBase.Core.ExecutionEngine.AbstractExecutionEngine.DoRunComp(IOrchestrationComponent comp, IData data, TLExecutionContext context)

So, because of the above errors.. its getting timed out and if not its simply saying there was an error sending Email confirmation to the cusotmer..

Please Help me... I need to solve this issue ASAP...

Thanks in advance.

Fabrice B M Raud's picture

Hello Bondo,

Yes Not intuitive and part of customization as we talked on thread ago.

FABEMARA Consulting S.L.
Torrejòn de Ardoz (Madrid)

http://www.fabemara.es

http://assistance.fabemara.com