Video Screencast Help

Cannot boot to WinPE

Created: 28 Oct 2013 | 6 comments

I am using Deployment Solution 7.5 for the first time. I cannot boot the managed computer to WinPE, the message is:

Validating the network connection <validation criteria = -169.254>...

Restarting DHCP client service: retry 1....

The NBS is installed on a site server and the services are running. I have loaded the driver into the Preboot driver database, tried both Win7 32bit and WinVista 32bit. After loading the drivers I recreated the Preboot Configuration. Then I updated the agent on the site server.

I know the drivers are correct as I tried them on the client before loading the driver in the Preboot driver database. I also have a known good network connection.

Operating Systems:

Comments 6 CommentsJump to latest comment

YannickVR's picture

Are you sure that you're loading the 32 bit WinPE environment? Also, if you run ipconfig, if possible, do you see the networkadapter with a 169.x address? Are you booting with PXE? Also note that WinPE4 is based on Windows 8, so if possible use a Windows 8 driver :)

Thomas Baird's picture

restarting DHCP is nearly 100% a network driver issue in WinPE.  In 7.5, remember this is PE4 or Windows 8.  That means, for your network cards, you must have Windows 8 (or compatible) drivers added into the Preboot Environment in the console (e.g. to Bootwiz).  Unlike PXE booting where the driver is loaded in the NIC, for PE booting, you have to go get the drivers.

Thomas Baird
Enthusiast for making things better!

Shauna's picture

Okay, changed to a test machine that had a Windows 8 driver. Now I get the following when the tablet reboots -

>>Start PXE over IPv4.

Station IP address is 10.1.21.22

PXE-E16: No offer received

Then Windows starts. I can't find references to this message in the 7.5 documentation or this forum.

I appreciate the help!

YannickVR's picture

Seems that the PXE responds but doesn't have a boot program for you.

Configure the NBS service to respond with your WinPE for unknown, predefined and managed. Also set the logging level for NBS to 9 and save the changes.

NBS logging can be found in altiris\altiris agent\agents\deployment\SBS\

Also check that you've got the correct WinPE built for your hardware.

Thomas Baird's picture

Note: This is a completely different issue.  You have an IP addy that the NIC received, but you never get to automation to see the IP addy you "missed" last time.

The other comments about checking for UEFI and such are correct.

Also, in 7.5, under Settings | Deployment | NBS General Settings, you need to enable "respond to ..." for that computer type.  For instance, if it's a new computer, and the "respond to unknown computers is NOT selected, then PXE will NOT respond to this system, and yes, you'll get no PXE response.  This is commonly overlooked as requirement.  IF you have to change this, be sure to select "apply immediately" at the top.

GL!

Thomas Baird
Enthusiast for making things better!

BBC's picture

If the machine is configured to boot UEFI first, you will also see that error. Have you confirmed the machine is set to boot legacy mode or do you have a WinPE that boots UEFI?