Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Cannot connect to Class C broadcast addresses in a Class A network

Created: 11 Sep 2012 • Updated: 14 Sep 2012 | 4 comments
STHN's picture
This issue has been solved. See solution.

Today a customer reported a really strange issue.

His helpdesk guys showed him a screenshot of a pcA Quick Connect window which displays some clients from a class C network. The strange thing about that is that they dont't have a class C network.

They use 10.0.0.0 addresses and a 255.255.248.0 subnet mask.

So there is a range 10.49.88.1 - 10.49.95.254 with 10.49.88.0 as network address and 10.49.95.255 as broadcast address.

One client has got the address 10.49.90.255 from DHCP. When the helpdesk guy tried to connect to that client the address has been recognised as class C broadcast address and therefore a selection of all active hosts in that class C range is displayed. The same happens even if you try to connect to the actual broadcast address.

So doesn't pcAnywhere respect subnet masks!?

I look forward to your replies.

Comments 4 CommentsJump to latest comment

Jay Hicks's picture

Hello,

To be more specific, pcAnywhere determines an IP address ending in .255 to mean to scan the entire subnet for hosts.

From the pcA 12.5 SP4 Users Guide:

Symantec pcAnywhere lets you add subnets to include in a host search so that
you can search for hosts across the network....
[...]
Type the first three octets of the subnet that you want to include in the search results, and then type either .0 or .255 as the fourth octet. For example: 172.16.0.0

Regards

STHN's picture

This has solved the issue :)

Thanks!

PMCS GmbH & Co. KG - Consulting und Support für Altiris/SEP/EV und andere Symantec Produkte.
Please take the time and mark this post as solution if it solved your problem - thanks!