Video Screencast Help

cannot connect on socket

Created: 24 Aug 2012 • Updated: 13 Oct 2012 | 21 comments
mansoor.sheik's picture
This issue has been solved. See solution.

Hi all,

Encountering socket failed error in one of my Linux Machine(RHEL).

Ensured hostname resolution,but still error persists.Attached a log file which contains output of

bptestbpcd -client <ipaddress> -debug 

 

Master Server:HPX 11.31(64 bit),Netbackup version -7.1.0.2

Client:RHEL 5(64 bit), Netbackup Version - 7.1 

 

Comments 21 CommentsJump to latest comment

revaroo's picture

 

21:05:59.329 [1589] <16> bpcr_vnetd_connect_forward_socket_begin: vnet_connect_to_vnetd_ipi(172.17.162.51) failed: 18
21:05:59.329 [1589] <2> local_bpcr_connect: bpcr_vnetd_connect_forward_socket_begin failed: 25
21:05:59.330 [1589] <2> ConnectToBPCD: bpcd_connect_and_verify(172.17.162.51, 172.17.162.51) failed: 25
 
ok so I assume 172.17.162.51 is the client. Can you ping this IP from the host you run bptestbpcd?
If so, can you telnet 172.17.162.51 1556   ? does it connect?
Can you telnet 172.17.162.51 13782    ? does it connect?
 
Does the client have a firewall enabled?
 
 
Mark_Solutions's picture

The log also says connection reset by peer - something is breaking the connection - firewall?

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Marianne's picture

bptestbpcd is only useful when you also have bpcd log on the client.

Is this a new that has never worked before? Or did it work before and then stopped working?

Have you verified that iptables is disabled on the client?

 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

sazz.'s picture

Create a bpcd folder under netbackup\logs\ on the client

Run the bptestbpcd again and post the output of the client log.

Edit* Scrap it Marianne already asked for it

Gavrilov's picture

The common problem is when xinetd doesn't run on the client side. Try to start bpcd manually on the client first:

#bpcd -standalone

and after that  try bptestbpcd again.

Cheers,

Mike

falti.manullang's picture

add your master server name to client bp.conf.

Falti Manullang

 

 "If this post has helped you, please vote or mark as solution"

muhanad.daher's picture

Dear Mansoor,

 

this error manytimes related as all reply above, but you need to determined where is your error exactly.

you can do this:

1- check the hosts file in your master, media and client servers ( ip   name).

2- check if the agent on your client is up (/usr/openv/netbackup/bin/bpps) if not run do that (/usr/openv/netbackup/bin/bpup -v -f).

Regards,

Muhanad Daher

Senior Data Center Engineer

mansoor.sheik's picture

Hi All,

Thanks for your reply.I had a 3 days off. Sorry for the delay reply.

Hi revaroo,

I am able to telnet from master server( media server also) to client and viceversa by 1556 and 13782 port.

Hi Mark,

Firewall is stopped. Ensured by iptables status.

Hi Marianne/sazz,

Attach the client bpcd log.

Hi Gavilov,

Xinetd service is running.

Hi Falti,

Master server entry is der in bp.conf file of client.

Hi Muhanad,

Bpup command is not found in the mentioned path. Started netbackup under goodies.

Still issue persists. Kindly help me in resolving the same.

AttachmentSize
bpcd_client.txt 2.43 KB
Gavrilov's picture

Try to run on client:

#bpclntcmd -pn


#bpclntcmd -self

How many NICs does the client have?

Cheers,

Mike

falti.manullang's picture

 

Refer to marrine post in other problem.

https://www-secure.symantec.com/connect/forums/error-41-network-connection-timed-out-0#comment-5920731

Client is having a problem with connect-back via vnetd:

get_vnetd_forward_socket: get_string ipc_string failed: 5

 bpcd main: get_vnetd_forward_socket failed: 23

Please check state of bpcd and vnetd in netstat -a output on client.

If there are lots of connections in CLOSE_WAIT state, you can try to restart NBU Client Service, but a reboot might be needed.

 

Falti Manullang

 

 "If this post has helped you, please vote or mark as solution"

Marianne's picture

Have you verified that iptables is disabled on the client?

Check on client as follows:  

/sbin/service iptables status
Command should return:

Firewall is stopped.

If NOT:

/sbin/service iptables stop

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

mansoor.sheik's picture

Hi falti,

Restarted the server.

Hi Marianne,

Firewall is stopped and SElinux is also disabled.

Still issue persists.Kindly guide me on the same.

 

mansoor.sheik's picture

Hi,

Usually for bpclntcmd -pn command will give a below format output.

Expecting response from server <Master server>

<Client server domain name> <client name> <ip address> <port number>

But in the issue Linux machine, I am getting only the first line alone.

 

Gavrilov's picture

It means that master can't resolv or cached wrong ip. Or client has several NICs and sends request from unexpected IP.

Cheers,

Mike

Gavrilov's picture

Can you share your xinet configuration for bpcd and vnetd?

Could you also run on the client:

#telnet localhost 13782

Check if PBX is running on client:

#ps -ef |grep -i pbx

Does you client have several NICs? Cause it might be the problem.

Try to clear a host cache on master and on client (you haven't provided us bpclntcmd so it might help). Run this command on them:

#bpclntcmd -clear_host_cache

If nothing helps, try to upgrade client  up to 7.1.0.2 - maybe something wrong with binaries.

Cheers,

Mike

mansoor.sheik's picture

Hi Gavirilov,

Please find the output

[root@cdcdrwikiap02 ~]# ps -ef |grep -i pbx
root      2198     1  0 Aug28 ?        00:00:00 /opt/VRTSpbx/bin/pbx_exchange
root      2824  2799  0 03:13 pts/0    00:00:00 grep -i pbx
[root@cdcdrwikiap02 ~]# /opt/VRTSpbx/bin/pbx_exchange stop
Error in opening VxPBX CLI resource bundle
[root@cdcdrwikiap02 ~]# /opt/VRTSpbx/bin/pbx_exchange start
Error in opening VxPBX CLI resource bundle
 

Anything replated to PBx, but 1556 port is communicating.?

 

Gavrilov's picture

You can restart it this way:

# /opt/VRTSpbx/bin/vxpbx_exchanged stop

# /opt/VRTSpbx/bin/vxpbx_exchanged start

but you have to focus on this:

But in the issue Linux machine, I am getting only the first line alone.

It's common problem on multi-NIC hosts.

You still haven't post:

#bpclntcmd -self

Have you add this client into any politics?

Have you tried to clear host caches on both machines?

and so on... 

Cheers,

Mike

mansoor.sheik's picture

Hi,

After starting the PBX service in Client.bptestbpcd is completing successfully from master server.

But after some time again it is encountering the socket connection issue.

 

Please find the bpclntcmd command output.

root@hostname1 bin]# ./bpclntcmd -self
yp_get_default_domain failed: (12) Local domain name not set
NIS does not seem to be running: (1) Request arguments bad
gethostname() returned: hostname1
host cdcdrwikiap02: hostname at 172.17.162.51
aliases:     hostname1     172.17.162.51
 

chnage the current hostname to hostname1.

Gavrilov's picture

I see this error in your master server bpcd log:

21:05:44.279 [1589] <2> db_getCLIENT: db_CLIENTreceive: no entity was found 227
21:05:44.284 [1589] <2> ConnectToBPCD: db_getCLIENT(172.17.162.51) failed: 227

Run on master:

#bpplclients  |grep <client>

Try to restart PBX and just after it run:

#bpclntcmd -pn

Is it working?
 

Please, doublecheck that this commands return right data:

Run on client:

#bpclntcmd -ip 172.17.162.176

 

#bpclntcmd -hn bkpsvr

on master:

#bpclntcmd -ip 172.17.162.51
#bpclntcmd -hn <client_name>

Have you tried to reinstall NBU on client?
 

Cheers,

Mike

SOLUTION
Mark_Solutions's picture

What is in its bp.conf file paste or attach if possible - also, what is in its own hosts file - anything for itself against a different name?

How many NICS in use / how many IP addresses doe this client have?

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

mansoor.sheik's picture

Hi,

Reinstallation worked.

While perfroming reinstallation also i faced issue regarding the untar of the dump. Installed GNU tar and did the same.Now i am able to take backup from that server. Thanks for your support.