Video Screencast Help
Scheduled Maintenance: Symantec Connect is scheduled to be down Saturday, April 19 from 10am to 2pm Pacific Standard Time (GMT: 5pm to 9pm) for server migration and upgrades.
Please accept our apologies in advance for any inconvenience this might cause.

cannot connect on socket (25)

Created: 05 Sep 2013 • Updated: 17 Oct 2013 | 7 comments
This issue has been solved. See solution.

I have an SQL server receiving an error "cannot connect on socket (25)".  I've verified name resolution from client and server, services are running, and client and server are at same version (7.0.1).  Client is Windows Server 2008R2 and server is Windows Server 2003.  Server logs are included.  I need some direction on where to look.

Operating Systems:

Comments 7 CommentsJump to latest comment

captain jack sparrow's picture

from master/media server 

../admincmd/bptestbpcd -client clientname -verbose -debug

 

above should show you where the bottleneck is. could be port being blocked or communication stalled.

Try recycling services on client end 

after services are stopped 

from ../bin/bpps -a (for unix) or /bpps 

 

there shouldn't be any processes left except bpps.exe if there is then kill those process to ensure no hung process are there. before you start netbackup services.

clear cache from client and media server end

/bin/bpclntcmd -clear_host_cache

 Cheers !!!

CJS

 

AjinBabu's picture

HI,

Is the NBU service is started on client? 1 st check that .

Status  code  25 refers to  A process that timed out while it connects to another process for a particular operation. This problem can occur in the following situation: when a process tries to connect to the NetBackup request daemon (bprd) or database manager daemon (bpdbm) and the daemon is not running. (On Windows, these daemons are the NetBackup Request Manager and NetBackup database manager services.)

It can also occur in the following situations: the network or server is heavily loaded and has slow response time or an evaluation license key for NetBackup expired. However, the most common cause of this error is a host name resolution problem.

The following are other possible causes of this error caused by network connectivity issues or a required process such as pbx_exchange not running.

* nbjm is unable to connect to bpcd on the media server

* nbpem is unable to connect to nbproxy

* bptm on the media server is unable to connect to nbjm on the master server.

* You cannot perform an immediate backup operation.

These errors are caused either by network connectivity issues or if a required process such as pbx_exchange is not running.

 

Regards

Ajin

Marianne's picture

Is there a firewall between the server and client? If so, check that port 1556 is open in both directions.

If no firewall, check that Windows firewall is disabled on W2008 client.

Create these log folders on the client for further troubleshooting:
bpcd and dbclient

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Mark_Solutions's picture

I see that the Master is also the Media Server

So you need dcbus01.corp.DOMAIN.org to be able to resolve UC4V8.corp.DOMAIN.org and vice versa

What we need is the bpcd log file from the client - it most probably cannot resolve the Master (or even does not have NetBackup running)

Create \program files\veritas\netbackup\logs\bpcd on the client and then just see if you can connect to it via the Hosts Properties - Clients section of the Admin Console on the Master Server

Post the clients bpcd log once you have done this - if one is not created then the Master is not communcating with the Client at all which could be name resolution, NBU Service not running on the client, firewall etc.

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

mike-b's picture

Mark - as I stated in my initial post, I have verified name resolution from both the client and server side, and services are running.

I'm attaching the bpcd log from the client.  The only thing I notice is the line

ReadKeyfile: keyfile C:\Program Files\Veritas\NetBackup\bin\keyfile.dat does not exist

I've read that this is in reference to legacy encryption.  My policy is set for (AES 256) encryption so I'm not sure why this is popping.  Its not an issue on other servers.

 

Firewall is not running on either end.

AttachmentSize
dbclient_log.txt 152.74 KB
bpcd_log.txt 33.63 KB
mike-b's picture

Further troubleshooting has found that turning off encryption returns a successful backup.  So it seems the issue is with encryption during this SQL backup.  Does this help anyone in direction for suggestions?

mike-b's picture

bpkeyutil command resolved the socket issue when encryption was configured properly.

SOLUTION