Video Screencast Help

Cannot create PoolableConnectionFactory (Login failed for user ''. The user is not associated with a trusted SQL Server connection.)

Created: 24 Mar 2011 | 9 comments

 

 

 

i was trying to login to the sytem , but SEP fail to start  , log is below

after   i tried to run management configuration wizard , it also failed  and giving error message

"Failed to update System configuration files "

 

___________________________________________________________________________________________________________________

2011-03-24 11:50:24.851 SEVERE: ================== Server Environment ===================
2011-03-24 11:50:24.855 SEVERE: os.name = Windows Server 2008
2011-03-24 11:50:24.856 SEVERE: os.version = 6.0
2011-03-24 11:50:24.857 SEVERE: os.arch = x86
2011-03-24 11:50:24.858 SEVERE: java.version = 1.6.0_14
2011-03-24 11:50:24.860 SEVERE: java.vendor = Sun Microsystems Inc.
2011-03-24 11:50:24.861 SEVERE: java.vm.name = Java HotSpot(TM) Server VM
2011-03-24 11:50:24.862 SEVERE: java.vm.version = 14.0-b16
2011-03-24 11:50:24.863 SEVERE: java.home = C:\Program Files\Symantec\Symantec Endpoint Protection Manager\jdk\jre
2011-03-24 11:50:24.865 SEVERE: catalina.home = C:\Program Files\Symantec\Symantec Endpoint Protection Manager\tomcat
2011-03-24 11:50:24.866 SEVERE: java.user = null
2011-03-24 11:50:24.867 SEVERE: user.language = en
2011-03-24 11:50:24.868 SEVERE: user.country = US
2011-03-24 11:50:24.870 SEVERE: scm.server.version = 11.0.5002.333
2011-03-24 11:50:24.932 SEVERE: Unknown Exception
org.apache.commons.dbcp.SQLNestedException: Cannot create PoolableConnectionFactory (Login failed for user ''. The user is not associated with a trusted SQL Server connection.)
 at org.apache.commons.dbcp.BasicDataSource.createDataSource(BasicDataSource.java:1225)
 at org.apache.commons.dbcp.BasicDataSource.getConnection(BasicDataSource.java:880)
 at com.sygate.scm.server.db.util.DatabaseUtilities.getDefaultDatabaseConnection(DatabaseUtilities.java:285)
 at com.sygate.scm.server.db.util.DatabaseUtilities.getDefaultDatabaseConnection(DatabaseUtilities.java:276)
 at com.sygate.scm.server.servlet.StartupServlet.testConnection(StartupServlet.java:304)
 at com.sygate.scm.server.servlet.StartupServlet.init(StartupServlet.java:83)
 at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:880)
 at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:768)
 at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:3484)
 at org.apache.catalina.core.StandardContext.start(StandardContext.java:3710)
 at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1148)
 at org.apache.catalina.core.StandardHost.start(StandardHost.java:697)
 at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1148)
 at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:311)
 at org.apache.catalina.core.StandardService.start(StandardService.java:450)
 at org.apache.catalina.core.StandardServer.start(StandardServer.java:2213)
 at org.apache.catalina.startup.Catalina.start(Catalina.java:484)
 at org.apache.catalina.startup.Catalina.execute(Catalina.java:371)
 at org.apache.catalina.startup.Catalina.process(Catalina.java:134)
 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
 at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
 at java.lang.reflect.Method.invoke(Method.java:597)
 at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:151)
Caused by: java.sql.SQLException: Login failed for user ''. The user is not associated with a trusted SQL Server connection.
 at net.sourceforge.jtds.jdbc.SQLDiagnostic.addDiagnostic(SQLDiagnostic.java:364)
 at net.sourceforge.jtds.jdbc.TdsCore.tdsErrorToken(TdsCore.java:2754)
 at net.sourceforge.jtds.jdbc.TdsCore.nextToken(TdsCore.java:2195)
 at net.sourceforge.jtds.jdbc.TdsCore.login(TdsCore.java:598)
 at net.sourceforge.jtds.jdbc.ConnectionJDBC2.<init>(ConnectionJDBC2.java:335)
 at net.sourceforge.jtds.jdbc.ConnectionJDBC3.<init>(ConnectionJDBC3.java:50)
 at net.sourceforge.jtds.jdbc.Driver.connect(Driver.java:188)
 at org.apache.commons.dbcp.DriverConnectionFactory.createConnection(DriverConnectionFactory.java:38)
 at org.apache.commons.dbcp.PoolableConnectionFactory.makeObject(PoolableConnectionFactory.java:294)
 at org.apache.commons.dbcp.BasicDataSource.validateConnectionFactory(BasicDataSource.java:1247)
 at org.apache.commons.dbcp.BasicDataSource.createDataSource(BasicDataSource.java:1221)
 ... 23 more

Comments 9 CommentsJump to latest comment

Swapnil khare's picture

Hello

Please try following

  1. Check permissions to the SQL Server Agent Service Account's temp location
  2. Connect to the SQL Server
  3. Open the Services Applet (Start -> Run -> services.msc)
  4. Open the properties of the SQL Server Agent
  5. Click the 'Log On' tab and note the account that is used to start this service
  6. Open Windows Explorer and locate the temp directory for this account

&

Failed to update System configuration files error occurs due to Limited permissons

Try to Run Management Server Configuration Wizard as administrator

 

Thank you

 

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.