Video Screencast Help

Cannot delete replication partner

Created: 28 Mar 2013 | 21 comments

Trying to upgrade my SEPMs to 12.1.2 and I use replication. I'm trying to delete the replication partner per the upgrade process and I get "Replication is currently running. Please delete it later." If I click the "Cancel Replication" option, it says "Replication is canceled. For details, check the log files"

I've restarted the box, the service, the DB.

Something is obviously stuck so now what can I do?

Please help! Thanks!!

Comments 21 CommentsJump to latest comment

Dr. Unk's picture

My current version is 12.1 RU1

Server OS is Windows 2008

Rafeeq's picture

How are you trying to delete the partner?

 

Unable to remove replication partner with notification "Replication is currently running. Please delete later."

 

http://www.symantec.com/business/support/index?pag...

Dr. Unk's picture

I followed that KB and it did not work. No replication is actually going on. Something appears "stuck"

 

Rafeeq's picture

can you stop the symantec endpoint manager on the server B. and then log in to server A and delete replication?

if its holding on to something then restarting both the services should fix

if it fails again post the scm-server0.log found under sepm\logs folder.

Dr. Unk's picture

I stopped the sepm service on the secondary sepm than went back to the primary server and deleted it. Than I went back to the secondary server and restarted the services but it still shows as connecting and won't let me delete it

Also, scm-server log doesn't show much

pete_4u2002's picture

restart the SEPM and DB services and try deleting the replication partner

Dr. Unk's picture

I did but it did not work. Still won't let me delete

Dr. Unk's picture

So should I just delete from the primary SEPM and upgrade it only? Than upgrade the other even though I can't delete it however there is no replication actually taking place?

Maybe this is a bug?

Aurelien BOUMANNE's picture

Hi,

it's strongly not recommanded to try to upgrade a SEPM without completely removing the replicatino partners as the SEPM/DB might have different settings.

Is your replication set to Automatic replication ?

and what type of data are you replicating ? log between both sites ? install packages as well ? Suggest you to set your replication on a daily basis at a specific date, then wheck again the scm log again.

 

Regards,

Dr. Unk's picture

It is on a set schedule at a specified time. Log replication is only one way and it is only logs/policies, no packagesor LU content.

I can't edit the replication partner as it just hangs. Something is stuck.

So what should I do now? Rebuild? This seems like it should be an easy fix but everything I've tried does not work.

I need to get these upgraded as we need to get to 12.1.2 to support Server 2012.

If I turn off the SEPM services on the partner than can I upgrade the primary? If I have to go with one SEPM than I will because I don't know what else to do from here.

 

Aurelien BOUMANNE's picture

Did you set your SMTP email information regarding the replication notification ? if no, check if it's possible and verify if you get any replication failure notification in loop.

Dr. Unk's picture

It has been set but there have been no noifications

Rafeeq's picture

Do you have any Management server list assgined with your secondary replication partner?

for a min assign them with only primary server ip and then try to delete it.

Dr. Unk's picture

Did that as well.

I can just uninstall the SEPM, will it only remove local DB or does it mess anything up with the partner?

Dr. Unk's picture

Understood but its only going to remove locally not at the other site as well right?

Dr. Unk's picture

There is the option to "Delete Remote Site"

Can I do that? It says "Deleting a remote site also removes all of the replication partnerships in which this site partcipates"

Would this fix it?

Chetan Savade's picture

Yes, it should fix it.

Probably previously you were trying to delete incorrectly.

Chetan Savade
Technical Support Engineer, Endpoint Security
Enterprise Technical Support
CCNA | CCNP | MCSE | SCTS |

Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.<

Rafeeq's picture

 Delete it..let us know if that was successful!

Mithun Sanghavi's picture

Hello,

Change the MSL for all groups at the primary server to the default MSL of the primary.

Follow the Process as shown below:

ApplydefaultMSL1.JPG

 

 

ApplydefaultMSL2.JPG

NOTE: Make sure you Assign the Default Policy to all the Groups and Sub-groups.

Reference: https://www-secure.symantec.com/connect/forums/unable-delete-replication-partners-within-sep-manager

HOPE THAT WORKS FOR YOU.!!!

Mithun Sanghavi
Senior Consultant
MIM | MCSA | MCTS | STS | SSE | SSE+ | ITIL v3

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

SameerU's picture

Hi

Restart the replication server

Regards