Video Screencast Help

Cannot deploy image to solid state drive

Created: 16 Apr 2013 • Updated: 17 Apr 2013 | 7 comments
toca's picture
This issue has been solved. See solution.

Hi guys,

I have an rdeploy image job that is currently working on all models in the company.

But when I replace a normal hard drive with a solid state drive and try to image the machine

I get an error stating "The volume is full"

I reviewed the rdeploy log and really gave no extra information...

While in winpe i can see ssd drive but cannot open it.... when i try to open it; it's states that it needs to be formatted.

When i try to format it from winpe... does not work...... an even if it did i work not know how to format it..

I did some searching and articles were stating that its because an ssd format is different to normal ide.... but could not find a way to fix it...

I was thinking that maybe i should setup a format/partition job before deploying the image....

Has anyone else run into this problem before...?

Operating Systems:

Comments 7 CommentsJump to latest comment

BBC's picture

Hi Toca,

Maybe this is related to a specific type of SSD? Have you tried i.e. flashing the firmware of the SSD? We do mass deploy various hardware including SSD drives on a regular basis using RDeploy w/o issues. The only trouble so far we have seen is with Lenovo X1 Carbon where after a few weeks the SSD got corrupted and this was cured with the latest firmware version for the SSD.

-BBC

toca's picture

just an update guys,

 

I created a diskpart task that basically cleans the disk, creates partition and formats to ntfs...

this works well when I check the drive at this point... I am able to browse the drive and even add a folder in the drive without any issue...

but the moment i run the next task... the image deployment task.... it fails saying "the volume is full" and when i try to access the drive again.... i cannot access it.

 

Hi BBC...

If i have to update the firmware of the ssd, I asssume i need to put the ssd in a machine with an operating system already installed and update it that way?

toca's picture

BBC...

could you tell/advise me on which sdd brand i should by....

Discovered that the ssd brand in the machine is called "crucial".... so maybe i should get western digital or something

Gibson99's picture

where i work, we have over 1000 laptops, and all of them have solid state drives. i'm sure some of them are crucial brand, but there's a good variety - it's whatever dell threw in them when they built them.

when we ran XP, we used DS 6.8 to deploy images to them without issue.  now that we're on win7, we use DS 6.9 sp5.  every image is an rdeploy IMG with nothing custom.  I built the image in vmware, then captured using winpe/rdeploy.  for the deploy task, i use the canned "deploy image" task in DS 6.9, and then run a few other custom vbscripts to do things like tweak the unattend answer file based on which server it's imaging from (for regional settings), inject drivers, and copy some files, all while still in WinPE.

what version of DS are you using?  doing anything custom?  multiple partitions?  

one other thing i do to prevent weird problems is in the WinPE setup, i moved all of my mapped drives to the end of the alphabet.  so my deployment share is mapped to Z: rather than the default F:.  i have 2 other drives mapped to W: and Y:.  if you decide to try this, make sure you don't map anything to X: as that's the winpe ramdrive.  this simple change has saved me TONS of headaches.  of course if you're in DS 7.1 it may not even apply to you, but it's worth mentioning.

one thing to consider is maybe upgrading the bios of the machine receiving an ssd - it may handle drive translation better than the existing bios.

If a Connect post helped you out, be sure to click "Mark As Solution" or the "Thumbs Up" button to let other users know about it.

Thomas Baird's picture

not sure - we have several using SSD drives with no problem.

1) these aren't also the newer bios are they - UEFI?  That has made some - interesting issus.

2) if you partition with that task, then reboot and try again - does that make a difference?  Not that we're recommending that per-se, but it might "tell us something" about the problem.

Thomas Baird
Private Consultant

 

BBC's picture

FW updates usually happen either from USB or other emovable media CD/DVD, but can be done from within the OS for some drives.

#2 I'm surely not gonna recommend anything.

#3 Gibson's point is a great hint I think. Maybe the issue is with the IMG image (size, amount of partitions, etc.) or the configuration? I'd also be interested whether RDeploy actually starts and fails at some point of laying down the image or if it fails right at the very beginning.

toca's picture

Hey guys thanks for all the help,

I decided to make a new image unsing imagex and that worked....

SOLUTION