Video Screencast Help

Cannot detect media on tape list query but appears on robot/tld inventory

Created: 05 Jan 2014 • Updated: 17 Mar 2014 | 9 comments
This issue has been solved. See solution.

Hi,

Need your input on certain media tape that cannot query in tape list report but when I run a robot/tld inventory, media/tape are found. Tried also to expire them to use in duplication backup (SLP) but it displayed media is due to expire year 1970. Thats why when running duplication, it just trying to find the tape but status is just on que no error message. I check also on robtest that media's im looking for are in its designated slot in magazine.

E:\veritas\NetBackup\bin\admincmd>bpexpdate -d 0 -m a00012
Media A00012 is due to expire at 01/01/1970 08:00:00
Are you sure that the data on this media is not critical to
your business, and you are sure you want to delete A00012 y/n (n)? y

Regards

 

Operating Systems:

Comments 9 CommentsJump to latest comment

mph999's picture

What does is the output of

bpmedialist -m A00012   

nbemmcmd -listmedia -mediaid A00012

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
rsakimoto's picture

Here is the output:

E:\veritas\NetBackup\bin\admincmd>bpmedialist -m A00012
requested media id is not assigned to this host in the EMM database

E:\veritas\NetBackup\bin\admincmd>nbemmcmd -listmedia -mediaid A00012
NBEMMCMD, Version: 7.5.0.6
====================================================================
Media GUID:                     8d5e2a7a-1e79-4ebf-9bd4-da23cd330d5f
Media ID:                       A00012
Partner:                        -
Media Type:                     HCART2
Volume Group:                   000_00000_TLD
Application:                    Netbackup
Media Flags:                    1
Description:                    Added by Media Manager
Barcode:                        --------
Partner Barcode:                --------
Last Write Host:                NONE
Created:                        06/20/2012 09:52
Time Assigned:                  -
First Mount:                    09/13/2012 02:14
Last Mount:                     12/17/2013 13:17
Volume Expiration:              -
Data Expiration:                -
Last Written:                   12/17/2013 13:31
Last Read:                      -
Robot Type:                     TLD
Robot Control Host:             nbu002
Robot Number:                   0
Slot:                           48
Side/Face:                      -
Cleanings Remaining:            -
Number of Mounts:               190
Maximum Mounts Allowed:         0
Media Status:                   ACTIVE
Kilobytes:                      0
Images:                         0
Valid Images:                   0
Retention Period:               -
Number of Restores:             0
Optical Header Size Bytes:      0
Optical Sector Size Bytes:      0
Optical Partition Size Bytes:   0
Last Header Offset:             0
Adamm Guid:                     00000000-0000-0000-0000-000000000000
Rsm Guid:                       00000000-0000-0000-0000-000000000000
Origin Host:                    NONE
Master Host:                    nbu002
Server Group:                   -
Upgrade Conflicts Flag:
Pool Number:                    17
Volume Pool:                    NBU02_Monday
Previous Pool Name:             -
Vault Flags:                    -
Vault Container:                -
Vault Name:                     -
Vault Slot:                     -
Session ID:                     -
Date Vaulted:                   -
Return Date:                    -
Media on Hold:                  0
====================================================================
Command completed successfully.

E:\veritas\NetBackup\bin\admincmd>

SymTerry's picture

Hello,

I see the tape is in the NBU02_Monday pool. if you move it to the scratch pool does it get picked up? Also when you search the catalog by media, do you find anything? You also might try to delete the tape and inventory the robot.

rsakimoto's picture

Hi, Media cannot be searched in the catalog. I have tried to force expire and prompted no message which I believed is normal.

mph999's picture

The media does not show an assign time, so in theory it shouldn't be in the media db, and in fact we see this with the bpmedialist command.

When you try to expire a tape that is not in the mediadb you should get this message:

requested media id is not assigned to this host in the EMM database

.. but in this case you do not.

I've compared your nbemmcmd output to a tape on my test system and I don't see any difference that should cause this issue.

My thought at the momennt is that there is some incorrect entry left in the NBDB for some reason.

You can try deleting the tape but I don't think it will allow you as the system thinks it has a expiration date

You don;t mention, but I presume every time you run the bpexpdate command you get the same result, meaning it is having no effect.

I think the only thing you can do is log a call and ask for it to removed via an SQL script.

To do this the following will be required

nbsu -c -t output

/usr/openv/db/bin/nbdb_unload <some directory>

<some directory>  - this will be created when you run the command, we'll need all the files in it.

(I can't remember the Windows path - have a quick look about to find it ...)

My reasoning being that if we can't expire the tape, and if we can't delete it (check this) then there is not really any other option.

If you search through the .dat files in the nbdb_unload output it would be interesting to see how many different .dat files the string "A00012" appears in.

I would show this thread to the TSE who gets the call, and say that Martin Holt (that's me) has already looked at this.  Ask them to officailiy escalate it to Backline and put it in my name.and on the escalation email to mention this.

Also, thinking about it - can you also run ...db/bin/nbdb_backup -online <some other dir> and send in this output also.

Martin 

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
rsakimoto's picture

Hi mph999 (Martin),

I am currently opening a case to support right now with regards tou our dedup jobs which is taking a long time to process. Seems like it hang and stayed in 2%. Still process on writing taking 3 days now. The issue about expiring tapes relates to it as we need it on our duplication job. Backup to MSDP then SLP. I have tried to force expire tape and it result to no error or any message. Does this mean something wrong in our tape drives though no error appears. Shall I still mention you on the case so you can take a look at this also?

 

 

Marianne's picture

This issue is not caused by tape drives.

'Something' in NBU databases is holding on to the tapes.

Please show us output of 'vmquery -m A00012'?

I remember some time ago that we could see a different status with vmquery output.

 

PS: 

It seems you have not replied to these items in SymTerry's post:

if you move it to the scratch pool does it get picked up?
You also might try to delete the tape and inventory the robot.

Have you tried this?

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

rsakimoto's picture

Hi Marianne,

I will have to try if get pick on scratch pool and as well as the deleting the media/tape.

For result on vmquery -m A00012:

E:\veritas\Volmgr\bin>vmquery -m a00012
==================================================

media ID:              A00012
media type:            1/2" cartridge tape 2 (14)
barcode:               --------
media description:     Added by Media Manager
volume pool:           NBU02_Monday (17)
robot type:            TLD - Tape Library DLT (8)
robot number:          0
robot slot:            48
robot control host:    bdownbu002
volume group:          000_00000_TLD
vault name:            ---
vault sent date:       ---
vault return date:     ---
vault slot:            ---
vault session id:      ---
vault container id:    -
created:               6/20/2012 9:52:20 AM
assigned:              ---
last mounted:          12/17/2013 1:17:18 PM
first mount:           9/13/2012 2:14:17 AM
expiration date:       ---
number of mounts:      190
max mounts allowed:    ---

Marianne's picture

I cannot see any reason why this tape cannot be used for backup or duplication.

There is no need to expire it as this tape contains no valid images.

As per my previous post - have you tried SymTerry's suggestion to move tape to another pool or even delete it?

The only reason that I can think of why tape will not be selected for backup or duplication, is if there is an 'orphaned' resource allocation against it.

Please check output of 'nbrbutil -dump' to see if A00012 appears in the output.

One more thing - it is perfectly right for 'media list' report to NOT show tapes that are not assigned.

There are 2 different databases in NBU -

  1. a volume database that contains hardware info. This is the info that you see with vmquery command.
  2. a media database that contains backup info when the tape gets 'Assigned' (used for backups). This is the info that you see with bpmedialist command.
    When all images have expired, the tape gets removed from the media database (de-assigned) 

nbemmcmd -listmedia command combines info from both databases.

I remember a similar post where media appeared to have an expiration date when there was an attempt to expire unassigned tape. Will see if I can find it.

 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION