Video Screencast Help

Cannot install SSO Secondary Server

Created: 19 Jul 2013 • Updated: 17 Sep 2013 | 8 comments
This issue has been solved. See solution.


I have been trying to install the Shared Storage Option on an environment and am having problems when setting up the secondary SSO.  The setup is as follows

2x Backup Servers running Backup Exec 2010 R3 on Windows 2008 R2 (BK1 and BK2)
1x HP MSL2024

During the initial installation I installed a full version of Backup Exec on each of the servers.  The Tape Library is visible on both servers and I set up a number of jobs on each server.  I then realise that to share the tape library I need to use the SSO option.

I therefore set up BK1 as the Primary SSO server.  I then proceeded to install Secondary SSO on BK2, but after the installation completed, all the backup exec services could not start and the following error is reported

Adamm Database Event: Open Database Connection Failed!
Server = "BK1"

Instance = "BKUPEXEC"
Database = "BEDB"

Based on some rsearch in the forms I have done the following:
Opended TCP and UDP 135 from BK2 to BK1
Unistalled the Secondary SSO and Re-installed
Used the BEUtility.exe to set BK2 as Secondary SSO

None of the above have resolved the issue.  Can you please provide some assistance.

Operating Systems:

Comments 8 CommentsJump to latest comment

brian spiteri's picture


In addition to the above I wanted to check whether BK2 is trying to access the BK1 ADAMM database as this would probably required additional ports to 135 (most probably this requires an SQL port).  However I found no documentation about this.

Jaydeep S's picture

Brian here are the list of ports that need to be open.

brian spiteri's picture

Hi  Thnaks for the update.  The link provides a list of all the ports used by Backup Exec, but I would like to know what ports are required to be open between BK2 and BK1 who are part of the SSO setup.  Currently there is a firewall between the 2 servers and I need to open the required ports

As mentioned before I found an article that mentions TCP and UDP 135 should be open.

CraigV's picture

...have you tried to uninstall SAN SSO from the primary server and redo this?

Alternative ways to access Backup Exec Technical Support:

brian spiteri's picture

will try to uinstall the Primary SSO as suggested and let you know how it goes.

In the meantime can anyone confirm the ports that need to be open between the Primary and Secondary SSO servers.

brian spiteri's picture

Hi,  I ahve done some further research into the communication between the Secondary SSO and Primary SSO and found that the Secondary SSO is trying to communicate with the Primary SSO SQL database.

In our case the Primary SSO database is listing on Dynamic Port TCP 7372.  The  Backup Exec PVL service on the secondary SSO is attempting to communicate with SQL on the Primary SSO on the mentioned port.

To succesfully setup the SSO I will need to open this additional port in the firewall.  The ports required for SSO are not documented in the link, and it might be very useful to have them listed.   Will attemt to confirgure the above this week and let you know the outcome.

CraigV's picture

...MIGHT also be port 135...check below:


Alternative ways to access Backup Exec Technical Support:

brian spiteri's picture


I have managed to resolve the issue.  When the SSO setup inlcudes a firewall between the Primary Server and Secondary Server the following additional ports are required to what is already listed in

1) The Secondary Server will attempt to find the SQL Instance installed on the Primary Server.  This will be done by conneting to the SQL Browser service on the Primary server which uses TCP 1433 and UDP 1434.

The TCP 1433 and UDP 1434 must be opened from BK2 to BK1

2) As mentioned in my previous post above, the Primary SSO database is listing on Dynamic Port TCP 7372 and this port was opended as well.

The TCP 7372 must be opened from BK1 to BK2

When the above ports were opended the SSO started working correctly