Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

cannot restore exchange mailboxes

Created: 22 Dec 2012 | 2 comments

Hello,

I'm having a great deal of trouble trying to restore a couple deleted mailboxes to Exchange 2010 and could really use some help.

 

Quick environment snapshot:

2x Exch 2010 Std Srvs (1 CAS, 1 MBX).

1x BackupExec 2010 R3 server with an auto-loader directly attached.

 

This is what has been happening.

1. I setup a new restore job, selected the mailboxes i want to restore, from the date i want to restore, i select the device, i check "automatically recreate user accounts and mailboxes" in setting and then i click RUN. it starts, runs for about 10 hours, extracting the entire database from the looks of it and then fails, citing an unknown MAPI error.

 

Job ended: December-20-12 at 9:07:11 PM
Completed status: Failed
Final error: 0xe00002f8 - Cannot open one or more mail messages because of unknown MAPI errors. Review the job log for more information.
Final error category: Resource Errors
 
For additional information regarding this error refer to link V-79-57344-760

 

2. I setup a new restore job, selected the mailboxes i want to restore, from the date i want to restore, i select the device, i use redirect exchange sets to my mbx server in a recovery database and then i click RUN. it starts, runs for about 2 minutes then completes successful except there is an error in the log  citing it cannot connect to remote agent on, my backupexec server, 0 bytes moved, etc... now i'm no expert but as far as i know i cannot install the remote agent to the backup exec server.

 

Drive and media mount requested: 22/12/2012 9:13:38 AM
Drive and media information from media mount: 22/12/2012 9:15:11 AM
Robotic Library Name: AUTOLOADER
Drive Name: DRIVE
Slot: 15
Media Label: 000009L5
Media GUID: {4cced73f-0752-46e7-80f0-630d149cfe94}
Overwrite Protected Until: 25/08/2013 10:41:37 PM
Appendable Until: 18/08/2013 11:20:49 AM
 
All Media Used
 000009L5
 
 V-79-57344-3844 - The media server was unable to connect to the Remote Agent on machine MY BACKUPEXEC SERVER.
A selection on device VMVCB::\\MY-BACKUPEXEC-SERVER\VCGuestVm\(DC)DataCenter01(DC)\vm\MBX was skipped because of previous errors with the job.

i'm at a loss and really need some help. i'm sure its something really simple that over looking, please help, any help is appreciated.

 

thank you

Comments 2 CommentsJump to latest comment

Solution4all's picture

Hi,

Create a Backup to disk folder on local Ntfs partition and run duplicate backup on disk from the date you want to run restore mailbox to avoid Staging.Run restore from disk backup set if restore fails you can run restore right away no need to wait for 10 hours for staging.

We can not redirect restore a mailbox to a recovery database.Only a mailbox database can be redirected to recovery database. You can create a new mailbox and run redirect restore to newly created mailbox.

thanks,

 

Backup_Exec's picture

Hi

As rightly said by solution please create a duplicate backup to disk and then try doing restore the below link should help you to perform duplicate job

http://www.symantec.com/docs/TECH24544

Additionally ensure the account used for doing restore as active mailbox and it is part of Organization manangment and Exchange server group.

Last when you do a restore you can either specify name of DAG or you cab specify the name of CAS server in excgbage redirection optiin .

Please ensure BE2010 r3 is fully patched up with sp2 and all updates after it and remote agent version on mailbox server and CAS server is also on same level as Media server.

Hope that helps.

Sameer

Don't forget to give a "Thumbs Up" or Mark as "Solution" if someones advice has helped you.