Video Screencast Help

Cannot start Device & Media service. Backup Exec 12.5

Created: 04 Jun 2010 | 8 comments
Everything was fine until I tried to make NAS01 a Managed Media Server reporting to FILE01 (the central admin server). It then told me I would need to restart the services on NAS01, I tried and now the only thing that will start is the Remote Agent service.

Here's the error in event viewer:

Adamm Database Event: Open Database Connection Failed!

Error = ERROR_DATABASE_DOES_NOT_EXIST
Server = "NYNYCVFILE01"
Active Node = ""
Instance = "BkupExec"
Database = "BEDB"
Connection String = "DRIVER=SQL Server;SERVER=NYNYCVFILE01\BkupExec;DATABASE=BEDB;App=BEWS PVL"
The Backup Exec Device and Media Service could not connect to the specified database. Ensure that the specified database is running, and then try starting the service again. If this is a remote database, also ensure that the firewall is properly configured.

Windows Firewall is disabled on both servers.

Ran a UDL connection test (floowing this article: http://seer.entsupport.symantec.com/docs/256661.htm), and put "NYNYCVFILE01\BKUPEXEC" in as the server name. Test was successful

Ran a MDAC repair on NAS01 (following here: http://seer.entsupport.symantec.com/docs/291355.htm)

Made sure the LogOn for the service has admin priviledges on both servers and on FILE01 SQL database (follwing here: http://seer.entsupport.symantec.com/docs/321145.htm)

What am I missing?

Comments 8 CommentsJump to latest comment

rpollack's picture

Or better yet, is there a way to get Backup Exec to stop reporting to the central admin server, even though I can't actually start backup exec without that service running?

mickelingon's picture

Hi

I've the same problem and cannot connect a MMS to the CASO.
Everything is working remotely against the SQL. I can telnet and run SQLCMD to it. I can connect SQL Server Management Studiio Express to the remote instance.
But not connect the MMS.
In wireshark I get a lot of droped UDP packages when trying to install MMS. On dynamic ports though.
I have set static ports in SQL 1433 and using this I can remote connect. Is there any connection string in BE you have to spicify the port in?

Mike

Nimish_Patel's picture

It seems that the issue is with MMS not being able to communicate with the SQL instance on which the CAS database is hosted. Try following http://support.veritas.com/docs/300785

If this answers your question, mark this as the "Solution"
 

Thanks & Regards
Nimish Patel

mickelingon's picture

Hi
Any other suggestions, I've already had 2 Symantec employees looking at this and they asked me to check basic things that I had already checked.
Then they told me someone is going to call me today. But I haven't received any phonecall.
That's poor service. Most of the time you solve the problem before Symantec and when you really need help they don't know more then you do, and they work with it every day.
I just hope I can get help from the advanced team soon.

Mike

frustrated-withBE's picture

I think i have the same issue, was there any resolution on this one ?

 

I've gone through the above checks, i've gone as far as removing Backup exect ( 12.5 ) removing SQL instance and fully reinstalling. Problem persists ...

Ideas welcome !

Alberto Peña.'s picture

Hi everybody,   I had the same problem, I tried it:

1-. reinstall BE12.5,

2-. reinstall SQL

3-.Deattach / Attach the database  BEDB

4-.Apply the permissions in the Database BEDB, 

5-. Add the key values that recommend the Knowledge Base

6-.Check the MDAC version

After   all,  I had the same problem  the service didn't start

As the last try  I did it:  REPAIR the MDAC and  now it is worrking

http://www.symantec.com/business/support/index?page=content&id=TECH53595

 

regards

 

 

Mahesh Roja's picture

 

Solution:
1 .Stop all Backup Exec Services in the following order:
Backup Exec Job Engine
Backup Exec Agent Browser
Backup Exec Server
Backup Exec Device and Media
Backup Exec Remote Agent for Windows Systems
 
2. Cycle the Backup Exec SQL instance service.
2a. Typically called: SQL Server (BKUPEXEC)
 
3. Bring the Backup Exec Services up in the following order:
Backup Exec Remote Agent for Windows Systems
Backup Exec Device and Media
Backup Exec Server
Backup Exec Agent Browser
Backup Exec Job Engine
 
4. Open the Backup Exec console to verify the database connected.
 
 
 



Article URL http://www.symantec.com/docs/TECH69670

 

If that doesnt help, follow this

 

Backup Exec Device and Media service fails to start with the message "Database specified does not exist.

http://www.symantec.com/business/support/index?page=content&id=TECH36492

If this Info helps to resolve the issue please Mark as Solution

Thanks

CraigV's picture

...chances are good that what has happened is that your CASO now "owns" your MMS's database.

You can change that here in the registry:

HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Backup Exec For Windows\Adamm

Look for: Database Server Name key, and change it to show the name of your MMS. Restart your services. I get this issue the whole time when adding a server to my CASO...never mind the fact that I select the option to maintain everything on the local server!!!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...