Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

cannot update of client SleS 10 SP3 on 7.1.0.3

Created: 16 Oct 2012 • Updated: 16 Oct 2012 | 1 comment
nounejmak's picture
This issue has been solved. See solution.

i tried to update netbackup client from master server (sun5.10 with netbackup 7.1.0.3)

# bptestbpcd -verbose -client dgf4l200bk
1 1 1
164.26.211.170:38830 -> 5.13.129.25:13724
164.26.211.170:38846 -> 5.13.129.25:13724
PEER_NAME = bkhambk
HOST_NAME = dgf4l200bk
CLIENT_NAME = dgf4l200bk
VERSION = 0x06540000
PLATFORM = linuxS_x86_2.6
PATCH_VERSION = 6.5.5.0
SERVER_PATCH_VERSION = -1.-1.-1.-1
MASTER_SERVER = bkhambk
EMM_SERVER = bkhambk
164.26.211.170:38853 -> 5.13.129.25:13724
#

i started with update, but looks that i cannot do update

the client is sles 10 with sp3 - platform x86 and 32 bit

# /usr/openv/netbackup/bin/update_clients -ForceInstall -Install_Client_Bins -ClientList dblist

There are 1 clients to upgrade.

Do you want the bp.conf file on the clients updated
to list this server as the master server? [y,n] (y) n

The upgrade will likely take 1 to 3 minutes.
Do you want to upgrade clients now? [y,n] (y)
Please be patient.

Updating client dgf4l200bk -- Linux hardware running SuSE2.6.16
        dgf4l200bk: update failed, see /tmp/update_clients.10-16-1244.3606

The update trace can be found in /tmp/update_clients.10-16-1244.3606.
# cat /tmp/update_clients.10-16-1244.3606
        dgf4l200bk Linux/SuSE2.6.16 ...
CLIENT_CMD_SOCK from bpcd = 4
CLIENT_STAT_SOCK from bpcd = 5
BPCD connected
Couldn't read from file /usr/openv/netbackup/version on client dgf4l200bk
Client read errno = 0
bin_net.tar.3606 size = 1536
client_bin.tar.gz size = 94625347
.sizes_client_bin size = 2
NB-Java.tar.gz size = 125302407
.sizes_NB-Java size = 2
extract_java size = 16959
JRE.tar.gz size = 31917478
.sizes_JRE size = 2
nbj.conf.3606 size = 584
PBX.tar.gz size = 4680010
installpbx size = 53874
pddeagent.tar.gz size = 39282803
pdinstall size = 51826
dgf4l200bk.3606 size = 25
move_libs size = 3399
version size = 29
tar size = 373593
.sizes size = 14
client_config size = 76156

Detected an attempt to install incorrect platform and/or
operating system and version client binaries on dgf4l200.
client_config_failed

INF OTHER - EXIT STATUS = 1
EXIT STATUS = 1
 

Discussion Filed Under:

Comments 1 CommentJump to latest comment

Marianne's picture

All Linux 32-bit clients are no longer supported... sorry...

See NBU 7 OS Compatibility List: http://www.symantec.com/docs/TECH76648 
under 'Novell SUSE Linux Enterprise Server - NetBackup Client'.

Warning was clear in NBU 6.5 OS Compatibility list... http://www.symantec.com/docs/TECH70729 :

4. In NetBackup 7; Clients will be supported with 64-bit binaries only.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION