Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Cannot Update PGP Universal Server

Created: 27 Jan 2012 • Updated: 01 Feb 2012 | 7 comments
Sin City's picture
This issue has been solved. See solution.

Currently running 2.12 build 1035... trying to move to build 1128 before I start the upgrade process to 3.1.2.  Support recommended that I update to 2.12 build 1128 and run a backup before I install 3.1.2.

The problem is that when I try to upload the .pup package through the web console, it will crash back to login screen during the upload... and the upload will fail.  

I've tried every browser from firefox 5+, IE 7+, and Chrome.  Cleared caches.

I've tried rebooting the PGP Server.

I've tried other updates instead of the target update.

None of these options have worked.

I have tried uploading the update manually through an scp client, but the update will not show up in the update list.  Anyone have a clue how I can update my server?  I need to move to PGP 3.1.2

Comments 7 CommentsJump to latest comment

skuehn's picture

Please have a look at the update log (Reporting -> Logs -> Update).

Any entries?

Maybe it could help te retry the download - maybe the .pup file is corrupt.

Stephan

Julian_M's picture

delete all files in /var/lib/ovid/manifest and /var/lib/ovid/manifest/updates

then try upload again.

if does not work, upload file manually and run pgpupdate command

pgpupdate --help for more information

article related:

http://www.symantec.com/business/support/index?pag...

When you consider the issue resolved, please click Mark As Solution on the post that best provided the solution.
 

SOLUTION
Sin City's picture

@Skuehn I tried redownloading before with no luck... and I couldn't even run the update command because I couldn't upload the package.

@Julian_M While removing all of the files from those directories did not help the upload, I went ahead and uploaded the .pup file through SCP.  After that I was able to run the pgpupdate command through SSH.  The server is updating right now.  It looks like it is good to go.

Required the commands:
pgpupdate -p ".pup file here"
pgpupdate -i

It also may have helped to rename and remove the extra .'s in the .pup file name before running the command, I was having a little trouble at first.

I'll update thread if this worked out completely...

Thank You

Sin City's picture

My server still says it is updating even after 5 hours... not sure if that is normal or not.

Julian_M's picture

That may be possible . Please specify ammount of users and hardware details.

run top command, check if memory and cpu resources are being used.

When you consider the issue resolved, please click Mark As Solution on the post that best provided the solution.
 

Sin City's picture

Still in update mode this morning...

I've been watching top since yesterday and it's really doing a whole lot of nothing.

Sin City's picture

Okay, I've updated fully to build 1128...

After it got stuck, I rebooted the box, deleted the update files again, and reuploaded.

This time I used the command:

pgpupdate -i -p ".pupFILE"

This took several hours, but it completed and the server is happy again.