Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Cannot Upgrade FSA store after I moved server

Created: 25 Jan 2013 • Updated: 25 Jan 2013 | 17 comments
This issue has been solved. See solution.

Hello,

I am in the process of upgrading to EV10 from EV8 on different servers

Steps taken so far

Upgrade current 2k3 EV8 to EV9

Build new 2k8r2

Run server migration

All worked !!

However I need to upgrade the FSA Vaults and I also need to fix a SQL collation issue before I can go to V10

The FSA Migrator Report States that it cannot connect to svsymantec Which is the old servername before I ran the above steps.

I cannot figure out where its picking up this parameter.

Any suggestions?

Graham

 

Comments 17 CommentsJump to latest comment

TonySterling's picture

Could you dtrace the FSASummaryMigrator and attach that to a post for us?

 

GrahamHyland's picture

Thanks for getting back Dtrace below DTrace trace log for server:

AttachmentSize
DTRACE.TXT 23.05 KB
TonySterling's picture

So in the registry the SQL Server name is vsvsymantec, is that your SQL Server? 

Is EV up and running? 

TonySterling's picture

Here are the steps to update the registry:

Step 7 – Update the Directory database in the Registry (Enterprise Vault Server)

1. Click Start > Run, type regedit and click OK.

For 32bit systems, HKEY_LOCAL_MACHINE\Software\KVS\Enterprise Vault\Directory\DirectoryService.  

For 64bit systems, HKEY_LOCAL_MACHINE\Software\Wow6432Node\KVS\Enterprise Vault\Directory\DirectoryService

2. Double-click the SQLServer Name string value.

3. Enter the name of the new SQL server in the value data field and click OK.

4. Start the Enterprise Vault Directory Service, this will also start the Admin Service.

How to move the Enterprise Vault (EV) SQL databases

Article:TECH35744  |  Created: 2004-01-25  |  Updated: 2012-10-03  |  Article URL http://www.symantec.com/docs/TECH35744

 

GrahamHyland's picture

Yes that is my SQL server, it is actually the localhost - For some reason FSASumaryMigrator is looking for svsymantec (old SQL server) and not vsvsymantec (new SQL Server)

TonySterling's picture

Can you run this in SQL?

USE EnterpriseVaultDirectory

SELECT SQLServer, DatabaseName FROM VaultStoreEntry

GrahamHyland's picture

This reports SQEvault1.superq.lan

which is the DNS Alias

TonySterling's picture

Hmm, have you always used the SQL alias?

Also, what about this?  SELECT * FROM FSAReportingDatabase

TonySterling's picture

As a workaround to get upgraded you could always use the hostfile to point svsymantec to vsvsymantec

SOLUTION
GrahamHyland's picture

Yes have always used the Alias. Initial installation was via Third Party and I took over.
SELECT * FROM FSAReportingDatabase
reports the Alias SQEvault1.superq.lan

I'll use the hostfile workaround for now but would love to get to the bottom of it.

Thanks
Graham

GrahamHyland's picture

Unfortunatly that did not work, Could this be an Instance Issue rather than a DNS issue?

TonySterling's picture

In the registry look under DirectoryService, there is a key call SQLServerName.

TonySterling's picture

It could be it doesn't like the SQL Server Alias.  You could use this to set it to the sql server name.

How to remove Enterprise Vault SQL aliases.

Article:TECH143188  |  Created: 2010-11-01  |  Updated: 2010-11-01  |  Article URL http://www.symantec.com/docs/TECH143188

 

GrahamHyland's picture

sorry host file worked, typo earlier
so Its running at the moment
Graham

GrahamHyland's picture

Just checked that Article and still SQLserver is correct

Running Now Thanks for your help Tony