Video Screencast Help

Can't backup vMware's virtual machines

Created: 08 Apr 2013 • Updated: 09 Apr 2013 | 12 comments
This issue has been solved. See solution.

Hi,

I'm using Symantec Backup Exec 2010 R3 on Windows 2008 R2 64bit - both fully updated. Since 2 weeks I can't backup vMware's virtual machines direct from VMware host (vSphere 5.0.0 623860). When I check the selection list with the job and do a Resource Credentials test it finishes with Successful. Then when I try to run a job after few seconds I got error message:

Check status : Error: e0009b61, The job failed with the following error:
The logon account that was provided does not have valid credentials. Ensure that the user name and password are correct, and then try again.
 

User what is used to authenticate with the vMware host is a root (I deleted it adn recreated in BE). I've already done a vMware host restart and reinstalled whole Symantec Backup Exec server (OS + BE).

Did someone of you got similar issue and solved it or have any idea how to try to solve it?

Regards

Przemek

Operating Systems:

Comments 12 CommentsJump to latest comment

ZeRoC00L's picture

Is your ESX host licensed or is it runnin the free edition of ESXi?

If this response answers your concern, please mark it as a "solution"

Przemysław Pajewski's picture

It's licensed. A have also all needed licenses for BE and virtual hosts.

lmosla's picture

Make sure that your agent for AVVI has the correct permissions as shown in the following link  http://www.symantec.com/business/support/index?page=content&id=TECH129645

Przemysław Pajewski's picture

As I have already written I use "root" account of ESXi host server with administrator privileges.

That means that it has all possible permissions.

pkh's picture

Just a long shot.  Are you using a licenced version of ESX?  BE requires the vStorage API which only comes with the paid version of ESX.

Przemysław Pajewski's picture

I'm using vShpere Essentials (this is licensed veriosn) and Storage API is a licensed feature in this veriosn. Since last 1,5 year bacjup was working fine and nathing has changed on the VMware host site. All account, privileges are the same like befone. It happened in just one day, even before BE reinstall.

VJware's picture

Have PMed you how to enable debugging. Pls post or email me the output.

Przemysław Pajewski's picture

Hi, I've attached test backup job log as requested.

AttachmentSize
be-job-log.txt 17.53 KB
VJware's picture

I find this error in debug ~

BEREMOTE: [09-13-04 08:52:59] [2196]     - LogonUser failed: Logon failure: unknown user name or bad password.
BEREMOTE: [09-13-04 08:52:59] [2196]     [ndmp\ndmpsrvr]      - LogonuserError: 1326
BEREMOTE: [09-13-04 08:52:59] [2196]     [ndmp\ndmpsrvr]      - LogonUser failed for user: GDN-BACK01\Administrator
BENGINE:  [09-13-04 08:52:59] [3712]     [ndmp\ndmpcomm]      - ERROR: 69 Error: Windows LogonUser API failed.

Does this account "GDN-BACK01\Administrator" have appropriate permissions ?

 

EDIT** have a try at this KB too - http://www.symantec.com/business/support/index?pag...

SOLUTION
Przemysław Pajewski's picture

To have clear information:
- account gdn-back01\administrator is the backup server local account, server is the Win2k8R2 and is a member of AD domain (other than gdn-back01)

- to backup all Windows server (from inside OS) that are a domain member I use BE Agent and other domain account, that one works fine

- to backup VMs from VMware host I'm using other account (hosts root) and that one deosn't work

I don't think so the problem is gdn-back01\administrator account.

The strange thing I've found is when I edit Backup selection list and try to expand ESX's host tree it ask me always for right account. Then I choose root and got access. It looks like it can't remember this choice and authenticate.

VJware's picture

EDITED as just saw your reply.

 

Przemysław Pajewski's picture

VJware, you're right. The link you send is the right solution.

Now I can remember that I've changed local administrator password under user management in Windows, but not in the BE itself. And this is my default logon account. After password update it works fine.

Great thanks and best regards !!!