Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

Can't browse connect on android device

Created: 22 Jun 2012 • Updated: 23 Jun 2012 | 2 comments

Something has recently changed on the connect site. I am no longer able to browse connect on my android phones (previous - droid2, now a droid4 - both running gingerbread). i've tried with the stock browser and dolphin with the same results - just a spinning circle on a gray background.  

This is rather annoying as i used to read and post lots of material during my long, boring bus commute every day.  i can no longer do so, and am forced to play angry birds instead.  ;)

is anyone else having this problem?  i tried searching but didn't see anything relevant.

Comments 2 CommentsJump to latest comment

Zac H's picture

As another datapoint, it seems to work fine on my SGS2 (running ICS) with Dolphin browser.  In fact, I never knew they had a sweet mobile site.  Neat.

Gibson99's picture

So i just tried again on my droid4 and it's working fine. This new mobile site does look a lot better, and is more touch friendly (outside the login page anyway). I guess i managed to catch them while they were rolling out and testing this new site for mobiles.

If a Connect post helped you out, be sure to click "Mark As Solution" or the "Thumbs Up" button to let other users know about it.