Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Can't configure Oracle agent instance because error "Could not verify identification data.." appears.

Created: 19 May 2010 | 7 comments

Hello, 

I have installed RAWS agent on windows 2003 x64 SP1 R2 server and i try to configure Oracle instance.
When i have entered info about instance (as it present in manual ) and then pressed OK the error appear. Because i use russian version of BackupEXEc i specify translated error message: "Could not verify identification data for Oracle database connection. Try again".
I use user "SYS" and I'm sure that login-pass pair is correct.

When i do that with SGMON enabled on this server - i receive some errors in log:

VXMON_FU: [05.18.10 16:48:55] [0000] [4100] 05/18/10 16:48:55 OCIINTERCONNECT::LogonOracle: db = (PDR), home_dir = (c:\oracle\ora92), user =(sys), passwd= (****)
VXMON_FU: [05.18.10 16:48:55] [0000] [4100] 05/18/10 16:48:55 Current Oracle user name (sys)
VXMON_FU: [05.18.10 16:48:55] [0000] [4100] 05/18/10 16:48:55 putenv(ORACLE_SID=PDR)
VXMON_FU: [05.18.10 16:48:55] [0000] [4100] 05/18/10 16:48:55 putenv(ORACLE_HOME=c:\oracle\ora92)
VXMON_FU: [05.18.10 16:48:55] [0000] [4100] 05/18/10 16:48:55 ERR - oci.dll load failed: .

Trying with absolute path...
VXMON_FU: [05.18.10 16:48:55] [0000] [4100] 05/18/10 16:48:55 ERR - oci.dll not loaded:
VXMON_FU: [05.18.10 16:48:55] [0000] [4100] 05/18/10 16:48:55 Failed to logon to database, other error: Error code (0x1)
VXMON_FU: [05.18.10 16:48:55] [0000] [4100] 05/18/10 16:48:55 Returning E_RMAN_LOGON_OTHER error (0xe000100f)
VXMON_FU: [05.18.10 16:48:55] [0000] [4100] 05/18/10 16:48:55 OCIINTERCONNECT::LogonOracle: Logon is Unsuccessful

oci.dll is present in folder C:\oracle\ora92\bin

Anybody have some ideas about this touble?

Comments 7 CommentsJump to latest comment

sazz.'s picture

When you use the Remote Agent Utility, the user account with which you are logged on should be a member of the Oracle DBA group.

You must have administrator privileges to run the Remote Agent Utility.
To configure the Oracle Agent on Windows computers
On the computer on which the Remote Agent is installed, on the taskbar, click Start > All Programs > Symantec Backup Exec for Windows Servers > Backup Exec Remote Agent Utility.
Click the Database Access tab ->Enable media server authentication for Oracle and DB2 operations to enter the credentials that the media server will use for all operations on the Oracle server, including DBA-initiated operations. The media server also uses these credentials for authentication of the Oracle server.
To configure database access on the media server for Oracle operations
1. On the media server, on Tools menu, click Options.
2. On the properties pane, under Job Defaults, click Oracle.
3. Click the Modify list button.
On the Authentication Credentials for Oracle and DB2 Servers dialog box, you can add, edit, or delete a server name and a logon account.
4. Click New.
5. Enter the name of the Oracle server on which the instance is installed
molotov's picture

Yes, my account is a member of local administrators and ORA_DBA groups.

I can't configure Remote agent in "Oracle" tab. Other settings succesfully entered.

sazz.'s picture

Can you please attach the screen shot of oracle and DBA tabs from the raws utility on the oracle server

molotov's picture

I attached Filemon log (utility that logs file system access events) and screen shots you requested.

As i see, BE agent found oci.dll file but can't load correctly. Connection to oracle via SQLPLUS is correct and Oracle operates correctly (because users using this DB server with no exceptions).

Also i applied recommendations from article 311549 with no effect..

Screen-BE_Agent.jpg
AttachmentSize
Filemon.txt 2.48 KB