Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

Can't connect to SQL Default Instance

Created: 10 May 2012 | 8 comments
jamespringle819's picture

I have a SQL server that has 3 named instances and 1 default instance.  I can connect to all of the named instances and back them up but not the default instance.  The default instance is using not using the default port and I think I this is causing the problem.  When I try to select the default instance I get a Browse Failure message saying that the Microsoft SQL Server does not appear to be running or network connections are preventing access to it.

I have read a few articles for previous versions of BE and tried creating a .udl file to prove I can access the instance from the BE server which works correctly.  The main thing I am coming acroos is that there is no way for BE to connect to a deafult instance that is running on a custom port, this is due to limitations in DBNETLIB.

Is this the case or is there another way to backup my default instance?

Comments 8 CommentsJump to latest comment

ZeRoC00L's picture

Is the SQL Server Browser service for that instance started ?

If this response answers your concern, please mark it as a "solution"

jamespringle819's picture

There is only one entry for the SQL Server Browser in services and it is started.

ZeRoC00L's picture

Is the protocol TCP/IP enabled ?

  1. From the Microsoft SQL Server 200x -> Configuration Tools, open the 'Microsoft SQL Server Configuration Manager'.
  2. Expand ‘SQL Server 200x Network Configuration’, and then click ‘Protocols for <Instance Name>’.
    <Instance Name> is the name of the instance of Microsoft SQL
  3. Right-click ‘TCP/IP’ and then click ‘Enable’. The icon for the protocol will change to show that the protocol is enabled.

What version of SQL is it anyway ?

If this response answers your concern, please mark it as a "solution"

jamespringle819's picture

Yes TCP is enabled and we are using port 1414.  It is SQL Server 2008 R2 Service Pack 1 with CU 6.  This is the linkI was reading that suggests I won't be able to backup the default instance if it is not on the default port.

http://dbaspot.com/ms-sqlserver/469388-problem-communicating-sql-default-instance-ole-database-provider.html

VJware's picture

Is named pipes enabled ?

jamespringle819's picture

Yes named pipes is enabled.  Is there a way to get the BE server to connect using named pipes instead of a TCP/IP port?

ZeRoC00L's picture

Are you sure the BE service account has access to this instance ?

If this response answers your concern, please mark it as a "solution"

jamespringle819's picture

I have tried a variety of accounts and get the same message.  If I create a .udl file and use integrated windows authentication I can see the databases under that instance.  The instance was setup using our standard SQL admin account that works for the other instances.

I have just tried changing the port on te default instance to dynamic and I can now access it.  I just need to go through all the applications that have DB's onthis instance and ensure they still work.  Fortunately we are in a pre-staging environment so I have time ot sort out any problems.