Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Can't decrypt on second server with PGP Command Line

Created: 28 Mar 2011 • Updated: 28 Mar 2011 | 8 comments

We have PGP Command Line installed and working on a production server.  I recently installed PGP Command Line on a 2nd test server and want to replicate the decryption that is taking place on the production server.  I successfully authorized our license on the test server last Friday.  However, when I try to run the decryption batch file (see below) which is running successfully on the production server, it fails with the error message, "<2713:no license has been entered>".  The PGP_HOME_DIR environment variable is set to C:\Program Files\PGP Corporation\PCP Command Line on both servers (where the software is installed), and I copied the pubring.pkr and secring.skr files from the production server to the test server.  The files and directories referenced in the batch file exist on both servers.  What am I missing?

BTW - the production server is Windows 2003; the test server is Windows 2008 64-bit.  When I run pgp --version from the command line, I'm told I have version 9.8 build 28.

The content of the batch file is as follows:

pgp --decrypt c:\ceridiandownloads\ejout.txt.asc --passphrase "XXX-removed" --overwrite remove --output c:\ceridiandownloads\ejout.txt --home-dir "C:\Program Files\PGP Corporation\PGP Command Line"
pgp --decrypt c:\ceridiandownloads\ebout.txt.asc --passphrase "XXX-removed" --overwrite remove --output c:\ceridiandownloads\ebout.txt --home-dir "C:\Program Files\PGP Corporation\PGP Command Line"
pgp --decrypt c:\ceridiandownloads\eeout.txt.asc --passphrase "XXX-removed" --overwrite remove --output c:\ceridiandownloads\eeout.txt --home-dir "C:\Program Files\PGP Corporation\PGP Command Line"
 

Thanks for your help

Comments 8 CommentsJump to latest comment

dfinkelstein's picture

The license information is stored in the prefs file PGPPrefs.xml.

Double-check that the PGP_HOME_DIR environment variable is set properly for the batch process user, and that it matches what you set it to for the user who licensed PGP Command Line.

For the two users (the one who licensed Command Line, and the batch file user) run "pgp --version --verbose" and check that the "File information" section matches.

--------

David Finkelstein

Symantec R&D

Rob Scott's picture

The PGP_HOME_DIR environment variable is the same, but the File Information when I run pgp --version --verbose is different between the two servers.  How do I get them to match?

Thanks!

dfinkelstein's picture

The "Home Directory" entry under File Information should match what you are setting for PGP_HOME_DIR.  If it isn't, there's some issue with the proper setting of that environment variable for the user.  You could try using the "--home-dir" option instead.

--------

David Finkelstein

Symantec R&D

Rob Scott's picture

I am using the --home-dir option; see the commands I'm entering in my initial post.  What else could be causing this?  Isn't it odd that it's saying that no license has been entered?  Is there something wrong with the license authorization that said it was successful?  Or is this a normal error message when something's wrong with your keyring/settings?

Thanks!

Rob Scott's picture

BTW - if I change my command so the --home-dir option is set to the user's current Home Directory as listed under File Information in pgp --version --verbose, I get this error message:

<1001:could not open keyrings; file not found>

If I had a "\" to the end of the --home-dir option, I get:

<1009:unable to open preferences file>

Do I need to move the preferences file and the keyring files to this user's Home Directory?  Or will that just further mess things up?

I don't remember being asked to supply a Home Directory when I installed PGP Command Line on the second server, but perhaps a reinstall?

Thanks!

dfinkelstein's picture

I don't think you need to do a re-install, but a re-license, using the same "--home-dir" option.

--------

David Finkelstein

Symantec R&D

dfinkelstein's picture

Great, I'm glad you got it resolved.

--------

David Finkelstein

Symantec R&D