Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Can't generate an usefull pendrive with Ghost Boot Wizard for mapping network drive

Created: 10 Jun 2011 • Updated: 20 Sep 2012 | 12 comments
This issue has been solved. See solution.

Hello.

I work at UNICAMP, a public university in Brazil.

Months ago we purchased the Ghost Solution Suite and one of the features we use is the generation of bootable pendrivers or CDs to map a network drive and create or recovery an image from the network. We are using GSS 2.5.1 and I believe all tools are the most recent version.

We can use this feature sucessfully with almost all network cards, but for Intel Pro 1000 family it fails, always.

When I try the option for multiple cards ghost fails to find the network card.

When I try to use the option for only Intel Pro 1000, same bug.

When I try to use Intel's lastest dos driver for Intel Pro 1000, ghost can find the network card but fails to map the network drive (I'm getting "sys0006 error" and a message that the "resquest service" is not started).

I already tried everything: pc-dos, ms-dos, old driver from intel's website. Nothing is fixing it. For example: today I got this bug with Intel DH55TC motherboards.

The workaround is to use "netboot6.5", a free solution to boot a machine in dos and map a network drive. This is very annoying, because the free solution works perfectly... why ghost fails to map the network driver when the machine has Intel Pro 100 as the network card?

Does anyone know how can I send this bug officially to Symantec and require a fix for it?

Comments 12 CommentsJump to latest comment

EdT's picture

Although Ghost ships with some drivers, it is a fact of life that new hardware is being released every day and new drivers are also being released. If you have a working driver for your Intel Pro 1000 in the NetBootDisk 6.5 release, then why not copy that driver into your Ghost environment and use it? There are many reasons why drivers may not be working, such as incorrect configurations leading to connection problems.

You also mention that you have tried "everything" but I see no mention of WinPE, only DOS solutions. Frankly, PCDOS is an ancient piece of software that lacks support for modern hardware including SATA and also has significant limitations with large hard disks and with creating large GHO images. If you want to get Ghost working with modern hardware then I would strongly recommend using WinPE, which the current Ghost release offers in addition to PCDOS support.

There is little chance of a bug report resulting in any action from Symantec as the dev team was laid off some time ago during the recession, and since other Pro 1000 users are getting it to work, there appears to be nothing fundamentally wrong with the product. Perhaps a search of this forum for other postings relating to the Pro 1000 might be worth the time spent if you still wish to find a DOS solution .

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Gilsberty Boscolo's picture

Hi.

Thank you for the information sent (I didnt see it before because I was waiting an email telling me about an answer here... perhaps I need to setup my profile).

If I understood correctly there is no more dev team for Symantec Norton Ghost. I dont see any reason to purchase this program with no support and I dont understand why Symantenc is still selling it.

I did try everything for the DOS version work and you were right: I never tried the WinPE before (the DOS version works perfectly when the NIC driver is sucessfully loaded even with large disks).

I tried WinPE today with a poor result: the NIC drivers from ghost original package and the NIC drivers from Intel website are not giving network support for a boot CD with WinPE. So I'm in the exact same situation: ghost not being able to create a boot device to give me network support for INTEL PRO 1000.

EdT's picture

In order to get email notifications for your thread, you need to select the "Subscriptions" option below, and subscribe to it. 

Symantec Ghost Solution Suite and Norton Ghost are two different products, based on different technologies, but I understand that you are using Ghost Solution Suite, for which the latest available release is 2.5.1 at build 2266.  There are patches to take the build level up to 2269 2298 and 2605 but these are strictly maintenance patches and only available from support if you have a maintenance agreement and if you are experiencing one of the issues that these patches are designed to fix. So there is limited support available for the GSS product but there will be no more updated releases as the technology is being migrated into the DS product for build deployment.

If you know the chipset number for your Intel PRO 100 NIC, then you can search on the number in these forums as there are several threads pointing to driver download locations for drivers which are known to work with GSS. 

Bear in mind that for the version of WinPE used in GSS, you need to add the Vista 32 bit drivers for your NIC (as this version of WinPE is based on the Vista kernel)

Looking back at your original posting, you make reference to the excellent NetBootDisk download.  I have used this in the past together with the Ghost executables to image machines. Clearly, if this is working for your hardware, then it should not be too difficult to extract the driver stack they are using and incorporate this into your USB boot solution, or just build their boot environment onto a USB key, connect to your network share and run Ghost from there.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Gilsberty Boscolo's picture

Ouch... the email notification system is very simple. Thanks for the help, it is set now.

Now I understood the situation about GSS releases. Thanks once more.

I tried to locate threads about Intel PRO 1000 and ghost for DOS in june and yesterday. Today I researched for WinPE. I gave up (tried a winpe with only intel pro 1000 nic driver from intel's website... tried the ping/sleep trick... didnt work). I cant make a bootable device and I'm not that expert to extract NetBootDisk's driver to use with ghost.

The suggested workaround is exactly what we are using here: booting the machine with netbootdisk and running ghost from the network driver. Randomly the image creation crashes. Randomly the image recovery crashes. That kind of crash never happen when the machine is properly booted by a ghost's startup disk and thats why I tried so much to generate a startup disk from ghost boot wizard for intel pro 1000.

It seems that we are stuck with it till next release of GSS/DS and I'm starting to plan Clonezilla.

EdT's picture

Depending on whether you have the time and inclination to "play" around with WinPE, you could have a look at this article:

Adventures with WinPE Symantec Connect

This gives you the step by step instructions on how to download V2 of WinPE and get it working on various boot media. You can mount drivers dynamically from the WinPE command line using DRVLOAD <path to INF> file - remember to use only Vista 32 bit drivers. This gives you a quick way of checking whether drivers will load in WinPE and also a quick way to test different drivers.  The WinPE environment includes its own imaging utility called Imagex.exe

This works in a similar way to DOS but since it excludes the swap file and other dynamically generated content, it can actually create a smaller image than Ghost.  However, you can add the ghost executables to your WinPE boot media and use that also.

Getting the right drivers can be a challenge, which I why I asked what chipset was being used in your machines. Do your systems happen to use the 82579 NIC chipset?  This forum and the downloads forum have postings with links to drivers known to work with GSS and WinPE. For example:

https://www-secure.symantec.com/connect/downloads/intel-nic-82579-lmv-drivers

https://www-secure.symantec.com/connect/downloads/latest-nic-drivers-intel-82566

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Gilsberty Boscolo's picture

My NIC: 82578DC.

I tried both links using Ghost's WinPE generation with no success.

I will try to generate a WinPE 3.1 now (I know it is different than the tutorial you sent for 2.0 but I have only windows 7 here).

I will keep in contact.

Gilsberty Boscolo's picture

Hello.

Good news: I could boot my machine using a WinPE 3.1 with support for the network.

I tried to use ghost32.exe on this environment but I get a message "the necessary subsystem is not present".

What files should I put on my WinPE to get ghost32.exe working?

Below the commands I used to generate my WinPE 3.1 bootable pendrive.

--> winpe 3.1
copype.cmd amd64 c:\winpe_64
copy winpe.wim .\ISO\sources\boot.wim
dism /mount-wim /wimfile:ISO\sources\boot.wim /index:1 /mountdir:mount
dism /image:mount /Add-Package /PackagePath:"C:\Program Files\Windows AIK\Tools\PETools\amd64\WinPE_FPs\winpe-wmi.cab"
dism /image:mount /Add-Package /PackagePath:"C:\Program Files\Windows AIK\Tools\PETools\amd64\WinPE_FPs\pt-br\winpe-wmi_pt-br.cab"
dism /image:mount /Add-Package /PackagePath:"C:\Program Files\Windows AIK\Tools\PETools\amd64\WinPE_FPs\winpe-scripting.cab"
dism /image:mount /Add-Package /PackagePath:"C:\Program Files\Windows AIK\Tools\PETools\amd64\WinPE_FPs\pt-br\winpe-scripting_pt-br.cab"
dism /image:mount /Add-Package /PackagePath:"C:\Program Files\Windows AIK\Tools\PETools\amd64\WinPE_FPs\winpe-hta.cab"
dism /image:mount /Add-Package /PackagePath:"C:\Program Files\Windows AIK\Tools\PETools\amd64\WinPE_FPs\pt-br\winpe-hta_pt-br.cab"
dism /image:mount /Add-Package /PackagePath:"C:\Program Files\Windows AIK\Tools\PETools\amd64\WinPE_FPs\WINPE-DOT3SVC.cab"
dism /image:mount /Add-Package /PackagePath:"C:\Program Files\Windows AIK\Tools\PETools\amd64\WinPE_FPs\pt-br\WINPE-DOT3SVC_PT-BR.cab"
dism /image:mount /add-driver /driver:C:\intelpro1000_ndis62\ /recurse
copy "C:\Program Files (x86)\Symantec\Ghost\ghost32.exe" .\mount\windows\system32
dism /unmount-wim /mountdir:mount /commit
--> bootable pendrive
diskpart
list disk 
select disk 1
clean 
create partition primary 
select partition 1 
active 
format fs=fat32 quick
assign 
exit 
xcopy .\iso\*.* /s /e /f g:\
 

EdT's picture

Can I suggest you try formatting your boot device as NTFS instead of FAT32.  I have used WinPE 2 successfully with the Ghost32.exe from the old Ghost 8.3 suite without needing any other support files.

To check exactly what files you might need, build a standard WinPE 2.0 iso using Ghost Boot Wizard, mount the iso using any of the usual utilities (eg Slysoft's) and then check for the Ghost files present on the ISO.  I'm travelling at the moment so don't have access to my usual hardware to check for you.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Gilsberty Boscolo's picture

Hello.

I found the problem. My first WinPE 3.1 was generated using 64bits architeture (amd64).

Today I tried using a new WinPE 3.1 with 32 bits architeture (x86).

The commands are the same (just change "amd64" for "x86").

The ghost32.exe is working now with my WinPE 3.1 self generated bootable pendrive!

I'm testing now if the process will end with no erros.

By the way: when I created my own WinPE there were 6 ".inf" files for the network driver. Perhaps the problem with WinPE 2.0 (generated by ghost) is a bad ".inf" file... perhaps we need to add all the ".inf" files from Intel package (one by one I mean), that way the WinPE 2.0 should be able to give network support as the WinPE 3.1 (remembering that for WinPE 2.0 we should use vista 32 bits).

What do you think?

EdT's picture

The INF files list all the PNP IDs which they are designed to support, so if you can grab the plug and play ID of the NIC via a working operating system install (eg the vendor original installP), it should be possible to find a compatible INF.

You can also use DRVLOAD <path to INF>   from the WinPE command line to load a driver dynamically. You will immediately get a message saying whether the driver was loaded successfully or not, and if loaded successfully, you can try the usual IPCONFIG commands to release and renew an IP address to test that the NIC is working properly.  If not, try another driver INF.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Gilsberty Boscolo's picture

Thanks a lot for your help.

WinPE 3.1 is working perfectly with ghost32. Your tip about the dynamic load of new drivers is priceless.

It was my pleasure to work with you.

Till next time.

Gilsberty Boscolo's picture

Hello!

I decided to write this summary to save your time!
If you are reading this to find a solution for a problem similar to mine then I'm sure you will be grateful.

We got a few suggestions listed below.

DOS:

1) ghost boot wizard: no solution

2) netbootdisk + ghost: the image process crashes randomly at any % - from 1 to 99

WinPE:

1) ghost boot wizard: it is possible to make it work giving the correct ".inf" file when loading the NIC driver

2) WinPE 3.1 + ghost: working perfectly!

Workaround: clonezilla was not tested.

To generate a succefull pendrive with WinPE 3.1 and ghost32.exe I used the simple guide written below.

1 - install symantec ghost suite

2 - install WAIK 3.0

3 - update WAIK to version 3.1

4 - download the latest drivers for your NIC (the drivers must be for Windows 7 32 bits)

4 - type the next commands using the prompt from WAIK (remember to run the prompt as administrator)

--> you may want to review the commands to check the instalation folders of each software

01 - copype.cmd x86 c:\winpe_x86
02 - copy winpe.wim .\ISO\sources\boot.wim
03 - dism /mount-wim /wimfile:ISO\sources\boot.wim /index:1 /mountdir:mount
04 - dism /image:mount /Add-Package /PackagePath:"C:\Program Files\Windows AIK\Tools\PETools\x86\WinPE_FPs\winpe-wmi.cab"
05 - dism /image:mount /Add-Package /PackagePath:"C:\Program Files\Windows AIK\Tools\PETools\x86\WinPE_FPs\pt-br\winpe-wmi_pt-br.cab"
06 - dism /image:mount /Add-Package /PackagePath:"C:\Program Files\Windows AIK\Tools\PETools\x86\WinPE_FPs\winpe-scripting.cab"
07 - dism /image:mount /Add-Package /PackagePath:"C:\Program Files\Windows AIK\Tools\PETools\x86\WinPE_FPs\pt-br\winpe-scripting_pt-br.cab"
08 - dism /image:mount /Add-Package /PackagePath:"C:\Program Files\Windows AIK\Tools\PETools\x86\WinPE_FPs\winpe-hta.cab"
09 - dism /image:mount /Add-Package /PackagePath:"C:\Program Files\Windows AIK\Tools\PETools\x86\WinPE_FPs\pt-br\winpe-hta_pt-br.cab"
10 - dism /image:mount /Add-Package /PackagePath:"C:\Program Files\Windows AIK\Tools\PETools\x86\WinPE_FPs\WINPE-DOT3SVC.cab"
11 - dism /image:mount /Add-Package /PackagePath:"C:\Program Files\Windows AIK\Tools\PETools\x86\WinPE_FPs\pt-br\WINPE-DOT3SVC_PT-BR.cab"
12 - dism /image:mount /add-driver /driver:<path-to-folder-with-inf-files/driver-for-your-nic-windows7-32bits>
13 - copy "C:\Program Files (x86)\Symantec\Ghost\ghost32.exe" .\mount\windows\system32
14 - dism /unmount-wim /mountdir:mount /commit
15 - diskpart
16 - list disk          (check wich number is your pendrive)
17 - select disk 1  (assuming that your pendrive was the number 1 in the previous list)
18 - clean
19 - create partition primary
20 - select partition 1
21 - active
22 - format fs=fat32 quick
23 - assign
24 - exit
25 - xcopy .\iso\*.* /s /e /f  f:\    (assuming the pendrive is using letter f:)

The steps 10 and 11 are very specific for my network where we are implementing 802.1x and for a full support to this feature there is the need of more files/work/setup.
You can safely skip both commands if you dont have 802.1x in your network.

If you want to generate an ISO for future use with CD/DVD execute the command below at a elevated prompt (you must be at "c:\winpe_x86").

oscdimg -n -b"etfsboot.com" .\ISO <path>\<file>.iso 

After you use your WinPE 3.1 boot with ghost32.exe you will receive a command prompt.

At this point if the network failed to be started you can use "drvload <path>/<file>.inf" to dynamically load a different NIC driver. As soon you find the correct driver you can redo the guide to generate the WinPE with the correct ".inf" for your NIC.

When the NIC driver is correct you will have network support by DHCP. You will need to map a network resource where your images will be saved or recovered. There is an example below.

net use i: \\<server>\shared-folder /user:<username>@domain <password>

After getting access to your shared-folder just execute ghost!

ghost32

Final tip: you can edit the startup file for WinPE using the command below.
notepad c:\winpe_x86\mount\windows\system32\startnet.cmd
Make sure to keep wpeinit as the first command and freely add any new commands you need (for example: you can add the network mapping by net use).
This way WinPE will automatically execute your commands after the boot process.

Thats it.

Thanks for your time.

SOLUTION