Video Screencast Help

Can't get policies list from Netbackup gui.

Created: 16 Sep 2012 | 9 comments

Hi All,

I have a Solaris 10 netbackup server and Solaris 10 clients. The netbackup version is 7.5.

I have got this situation: bprd and bpdbm not started.

bprd deamon started from Gui
nbpem deamon started from Gui
Both above returned to status stopped after a while.
nbstserv and bpdbm couldn't be started.

Within jnbSA log, when I click on Policies from the graphical interface, I'm getting the following error:

ErrorHandler--->(aqueryFacet) Status Code: 0 -> .
vrts.nbu.admin.icache.NBGUIORBConfigurator:10.172.17.30:1556:nbsl
[15-09-2012 23:42:18:728] jacorb.orb.giop:INFO: ClientConnectionManager: found ClientGIOPConnection to 10.172.17.30:1556:nbsl (470794d4)
ICACHE.PBXIOPCredsHandler-> ServiceContext registered.
(ObjSvc)Symantec.NetBackup.SL.PolicyMgmt.PolicyQueryFacet.getHWOSList
    Request ID: 34
    Server: masterserverBZ
    Time Taken: 15012ms
    Successful:
    Reply Status: Unknown
    UserException: Symantec.NetBackup.SL.NBSLOpException
    Data[0]: Host: masterserverBZ Error Code: 25 Error Msg: cannot connect on socket Additional Info:
vrts.nbu.admin.policymgmt.BackupPoliciesManager-> getHardwareOSList(): NBUCommandExecutionException while building hardware/OS list: cannot connect on socket(25)

vrts.nbu.admin.NBUCommandOutputException: Could not get list of client hardware and operating systems supported by the server masterserverBZ. Reason: cannot connect on socket(25)

You will be unable to configure clients for masterserverBZ
        at vrts.nbu.admin.policymgmt.BackupPoliciesManager.getHardwareOSList(BackupPoliciesManager.java:9427)
        at vrts.nbu.admin.policymgmt.BackupPoliciesManager.createPolicyResources(BackupPoliciesManager.java:9250)
        at vrts.nbu.admin.policymgmt.BackupPoliciesManager$LoadWorker.construct(BackupPoliciesManager.java:1161)
        at vrts.common.utilities.SwingWorker$2.run(SwingWorker.java:135)
        at java.lang.Thread.run(Unknown Source)
^C

Also,

 /opt/openv/netbackup/bin/bpclntcmd -pn is giving no output.

Could you help onthis. If any other information is needed, just let me know.

BR

Comments 9 CommentsJump to latest comment

mph999's picture

I would hazard a guess the EMM DB isn't running, given that bpdbm isn't running.

 

 

Do exactly these steps.

stop NBU and then run

/usr/openv/db/bin/nbdb_ping

You should see a message saying :

Database [NBDB] is alive and well on server [NB_womble].   (Your server name will be different)

If you see a message saying the database is unavailable then you will need to recreate the transaction log to see if that resolves the issue.  To rebuild the transaction log, follow these steps exactly.

(If this does not fix, and the DB still won't respond to bpdbm_ping I receommend you log a call)

/usr/openv/netbackup/bin/goodies/netbackup stop

/usr/openv/db/bin/nbdb_admin -auto_start NONE

. /usr/openv/db/vxdbms_env.sh

cd /usr/openv/db/data

mv NBDB.log NBDB.log.bad

/usr/openv/db/bin/dbeng11 -f NBDB

/usr/openv/db/bin/nbdb_admin -auto_start NBDB

( /usr/openv/db/bin/nbdb_admin -auto_start BMRDB  -  If you use BMR)

/usr/openv/db/bin/nbdbms_start_server

/usr/openv/db/bin/nbdb_ping

If it now shows the DB as alive and well, hopefully issue is fixed and you can restart NBU

Martin

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
eomaber's picture

Hi Martin,

I did the following. The db is then available, but bpdbm deamon is not started. Also, I got an error while running dbeng11.

# /etc/init.d/netbackup stop
#  /etc/init.d/netbackup stop
stopping the NetBackup Bare Metal Restore Boot Server daemon
stopping the NetBackup Service Monitor
stopping the NetBackup CloudStore Service Container
stopping the NetBackup Vault daemon
stopping the NetBackup Bare Metal Restore daemon
stopping the NetBackup Agent Request Server
stopping the NetBackup Service Layer
stopping the NetBackup Remote Monitoring Management System
stopping the NetBackup Indexing Manager
stopping the NetBackup Job Manager
stopping nbproxy...
stopping the NetBackup compatibility daemon
stopping the Media Manager device daemon
stopping the Media Manager volume daemon
stopping the Media Manager robotic control daemons
stopping the NetBackup Resource Broker
stopping the NetBackup Enterprise Media Manager
stopping the NetBackup Audit Manager
stopping the NetBackup Event Manager
stopping the NetBackup Database Server
stopping the NetBackup client daemon
stopping the NetBackup network daemon
#
#
# /usr/openv/db/bin/nbdb_ping
Database [NBDB] is not available.
#
# /usr/openv/db/bin/nbdb_admin -auto_start NONE . /usr/openv/db/vxdbms_env.sh
Successfully removed NBDB from databases.conf
Successfully removed BMRDB from databases.conf
Successfully removed NBAZDB from databases.conf
#
# cd /usr/openv/db/data
#
# mv NBDB.log NBDB.log.bad
#
# /usr/openv/db/bin/dbeng11 -f NBDB
ld.so.1: dbeng11: fatal: libdbserv11_r.so: open failed: No such file or directory
Killed
#
# /usr/openv/db/bin/nbdb_admin -auto_start NBDB
Successfully added NBDB to databases.conf.
#
# /usr/openv/db/bin/nbdb_admin -auto_start BMRDB
Successfully added BMRDB to databases.conf.
#
# /usr/openv/db/bin/nbdbms_start_server
#
# /usr/openv/db/bin/nbdb_ping
Database [NBDB] is alive and well on server [NB_masterserverBZ].
#
# /etc/init.d/netbackup start

Marianne's picture

Check bpdbm and bprd logs.

See my post below.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

eomaber's picture

Thanks for your reply Marianne.

The hostname given by hostname and the one in bp.conf are same.

I couldn't add a log for bpdbm. I used the command:

/usr/openv/netbackup/bin/vxlogcfg -a -p 51216 -o bpdbm -s DebugLevel=5 -s DebugLevel=6

V-1-8-16 Unable to decipher the Originator name "bpdbm".  Please try using the Originator ID.
 

Could you help on this.

Thanks

revaroo's picture

bpdbm is not a unified log, it's a legacy log.

Create the directory netbackup\logs\bpdbm\

it will then log in here the next time it starts.

mph999's picture

You missed this step.

. /usr/openv/db/vxdbms_env.sh

Should hae been run on a new line

... which is why you get this error

ld.so.1: dbeng11: fatal: libdbserv11_r.so: open failed: No such file or directory

No matter, if the DB is alive and well it is running and that is all that matters.
 

Martin
 

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
eomaber's picture

Now, it works fine. Thanks Martin for your support.

Thanks to Marianne as well.

Marianne's picture

Any possibility that hostname was changed on the master server? Or bp.conf file?

Please compare 'hostname' output with 1st SERVER entry in /usr/openv/netbackup/bp.conf - they need to match.

If these are the same, please check bprd and bpdbm logs.
If log folders don't exist in /usr/openv/netbackup/logs, please create them and restart NBU.

bprd and bpdbm startup attempt as well as reason for termination will be logged in the log files.

Please copy log files to .txt files that reflect process name (e.g. bprd.txt) and post as File attachments.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Marianne's picture

Please double-check above post!

If log folders don't exist in /usr/openv/netbackup/logs, please create them and restart NBU.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links