Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

can't import registry settings to Windows 7

Created: 09 May 2012 | 4 comments

Trying to import registry settings into a windows 7 64bit client but can't. The job says it runs successfuly but nothing shows up in the registry. If i run the command manually it goes fine, but if i run it through the job, nothing. I'm running with system account credentials, i've tried "regedit /s" and "reg import" I've tried calling the files directly, and i've tried calling them via a batch file and nothing. The job works perfectly on a windows xp station but fails on windows 7 64bit station (i say fail because i see nothing in the registry despite altiris saying it went fine). Any help greatly appreciated. I've tried searching and couldn't find anything.

 

Thanks.

 

Comments 4 CommentsJump to latest comment

Zac H's picture

Are you maybe writing to the HKCU key?  Or maybe should or shouldn't be writing to the HKLM\Software\WOW6432Node key on the Windows 7 box?

Saeed's picture

Which version are you using.. As per my knowledge this is a problem in DS 6.9... 

If you trying to add something to the HK current user and the use credential are not the same as the logged on user it will not work.

 

Might want to try and use a VB Script.. t

If a forum post solves your problem, please flag it as a solution. If you like an article, blog post or download vote it up.
 

KESH MAN's picture

This could be due to the UAC settings turned on Win 7 machines. Turn the UAC off and run the task again. I faced the same issue and this did the trick.

Altiris Administrator

Eli Lilly and Company, Indianapolis, USA

 

 

For Forum threads, please click "Mark as Solution" if answered

reto.zuerrer's picture

Which key do you want to import? Is XP 32-Bit?

 

 

Reto Zürrer | FYRE Consulting | http://www.fyre-consulting.ch